Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-20-2007, 02:22 PM   #1
1 Rivet Member
 
1990 36' Land Yacht
High Springs , Sunny Florida
Join Date: Apr 2007
Posts: 9
1990 land yacht electrical

Hi, Have several questions, By mistake we plugged ac power cord into 220 instead of 110. Heard a few clicks then nothing. After plugging into 110 some things are not working. for instance light in micro works but not clock. Beside the engenius electrical box is there another breaker box. I have read other posts that talk about another box.

Thanks
__________________

__________________
nana's ride is offline   Reply With Quote
Old 05-20-2007, 02:49 PM   #2
Rivet Master
 
silverleeper's Avatar
 
1967 22' Safari
1960 Caravel
Edmonds , Washington
Join Date: Aug 2004
Posts: 2,499
Images: 8
Ouch!!

Hi, If you have power to the micro and the clock is not working the circuit is fried. Did you try unpluging the micro for a minute or so and then plug it back in? Sometimes this will help.
__________________

__________________
Lee

1973 F-250 4X4 390
1965 Chevy Suburban 454
AIR 6030
WBCCI 4258
TCT

silverleeper is offline   Reply With Quote
Old 05-20-2007, 03:31 PM   #3
Site Team
 
azflycaster's Avatar
 
1975 25' Tradewind
Dewey , Arizona
Join Date: Mar 2005
Posts: 12,125
Images: 62
Blog Entries: 1
If the unplug - plug does not work, check to see if the unit has any fuses that might have blown. If not, the unit is most likely toast. You may have fried your power converter as well.
__________________

Richard

Wally Byam Airstream Club 7513
azflycaster is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! Electrical problem FranceyS Electrical - Systems, Generators, Batteries & Solar 6 08-03-2010 03:57 PM
Electrical problem--99 safari Andrew Carey Electrical - Systems, Generators, Batteries & Solar 2 11-16-2002 03:04 PM
Wiring for electrical horn on 310 shelocta Airstream Motorhome Forums 3 09-03-2002 10:40 PM
Electrical problem resolved davidz71 Electrical - Systems, Generators, Batteries & Solar 5 08-12-2002 09:21 PM
Electrical System Question ViewRVs Mechanics Corner - Engines, Transmission & More... 2 03-16-2002 08:39 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:11 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.