Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-30-2009, 07:01 AM   #1
2 Rivet Member
 
Clyde-2's Avatar
 
1972 27' Overlander
Bonita , Texas
Join Date: Aug 2009
Posts: 68
Blog Entries: 15
Elec. System Check Points ??

Where are all the major fuse check points on my 72 ? It still has the Univolt in it. Have already found the two 20amp breakers in the bathroom and the fuses inside the Univolt as well as the inline fuse next to the Univolt. Are there any others ? I haven't plugged into 110v yet as I don't want to burn the thing down until I check continuity throughout the trailer. I would however like to at least run the 12v lights but can't get juice to them. All fuses in Univolt are good. Need some trouble shooting help. Thanks. Mike
__________________

__________________
Link to my restoration blog:

http://www.airforums.com/forums/blog...7-clyde-2.html
Clyde-2 is offline   Reply With Quote
Old 08-30-2009, 08:11 AM   #2
Rivet Master
 
Ganglin's Avatar
 
1971 27' Overlander
Central , Ohio
Join Date: Jun 2006
Posts: 2,365
Images: 13
Did you check the inline fuse on the battery cable.
__________________

__________________
Ganglin is offline   Reply With Quote
Old 08-30-2009, 10:31 AM   #3
Rivet Master
 
Mexray's Avatar
 
1978 28' Ambassador
Morada , California
Join Date: Jan 2006
Posts: 1,583
you should have a 12v fuse panel for all the 12v stuff in your trailer - usually located nearby the Univolt...

There should be two fuses for the 12v battery circuit in that panel - check them - if your battery is good, and the fuses are good, you should be able to power your 12v lights without plugging into shore power 110vac...
__________________
Ray & Pat; Morada, CA
Mexray is offline   Reply With Quote
Old 08-30-2009, 06:30 PM   #4
2 Rivet Member
 
Clyde-2's Avatar
 
1972 27' Overlander
Bonita , Texas
Join Date: Aug 2009
Posts: 68
Blog Entries: 15
Thanks guys.....found the 2 fuses for the pos & neg batt cables. All fuses have been checked for continuity and are good. After spraying some PB blaster on connections and some sand paper, 12v stuff is working now. Not sure what I did, but it worked. 25 years tends to corrode things up.
__________________
Link to my restoration blog:

http://www.airforums.com/forums/blog...7-clyde-2.html
Clyde-2 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Reputation Points? Annemac Forum Admin, News and Member Account Info 1 07-11-2008 07:24 PM
jacking points emanon25 Jacks, Stabilizers, Lifting and Leveling 6 04-25-2006 04:10 PM
Karma points! RichardT Forum Admin, News and Member Account Info 43 08-18-2005 05:02 PM
How to check charging system (69 Safari) Bob Boucneau Electrical - Systems, Generators, Batteries & Solar 2 07-14-2003 11:48 PM
Check , Check and Re-Check a new refer saga. thenewkid64 Refrigerators 13 06-24-2002 10:54 AM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.