Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-28-2010, 01:25 PM   #1
1 Rivet Member
 
Currently Looking...
Loveland , Colorado
Join Date: Jul 2010
Posts: 11
2007 Safari 25FB SE - Fridge won't start

We recently purchased this unit and are working to get everything prepared for the first trip. All is well except for the refrigerator. I can't get it to turn on!
I have checked all the 120v breakers and the 12v fuses and they seem to be okay. The trailer is parked inside and is plugged into a 30 amp service.
All other appliances and lights work fine.
Am I missing something obvious or do I need to make a trip to the service center?

Thanks in advance for any input.
__________________

__________________
Jimdee07 is offline   Reply With Quote
Old 10-28-2010, 02:47 PM   #2
Rivet Master
 
2005 19' Safari
GLENDALE , AZ
Join Date: Aug 2004
Posts: 2,441
Need a little more information:

* Which doesn't work, 110 VAC, propane or both?

* Do the indicator lights and panel buttons seem to work, just not getting cold inside?

* Does it sound like the propane burner is trying to start (clicking sound)?

* Is the propane turned on?
__________________

__________________
Phoenix is offline   Reply With Quote
Old 10-28-2010, 04:37 PM   #3
1 Rivet Member
 
Currently Looking...
Loveland , Colorado
Join Date: Jul 2010
Posts: 11
The fridge does not work on either 110 or propane.

The indicator panel does not light up at all.

I don't hear the propane burner trying to light.

Both propane bottles are on.

As I mentioned, all other systems work fine. Water heater, water pump, stove top, microwave, range hood, tv, radio, ac, and lights.

We are fairly new to Airstreams, but have had several motorhomes over the years.
__________________
Jimdee07 is offline   Reply With Quote
Old 10-28-2010, 04:50 PM   #4
Wise Elder
 
Jammer's Avatar
 
2010 30' Classic
Vintage Kin Owner
South of the river , Minnesota
Join Date: Dec 2009
Posts: 4,119
Check the 12v breakers. I'm not sure where they are on a FB.

Check the 12v power block from the outside access door for the fridge, with a test light. It should light up bright.

If that's ok you may have a controller board fuse that's blown.
__________________
Jammer is offline   Reply With Quote
Old 10-28-2010, 05:58 PM   #5
4 Rivet Member
 
deauxrite's Avatar
 
2007 27' Safari FB SE
Full Timers just passing through , Arizona for a couple of weeks and then on to Utah!
Join Date: Jun 2005
Posts: 325
Had the same problem with my 07 Safari. It turned out to be the circuit board. Once replaced by the dealer, all is well.
__________________
Living life on the Road
deauxrite is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Airstream Safari 25FB Special Edition 26', Loaded! eBay Watch Airstreams on eBay 0 04-29-2009 07:10 PM
First trip report (2007 International 25FB) newroswell Member Introductions 2 03-11-2009 04:27 PM
New 2007 International Ocean Breeze 25FB Colonial Airstream Commercial Listings 0 12-15-2006 08:39 AM
Let's start with the Fridge.... GT1963 Refrigerators 6 03-03-2004 10:01 PM
Fridge won't start Astrodokk Airstream Motorhome Forums 7 07-27-2003 07:24 AM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.