Airstream Forums

Airstream Forums (https://www.airforums.com/forums/)
-   Mechanics Corner - Engines, Transmission & More... (https://www.airforums.com/forums/f159/)
-   -   Top air Pump Froze up, cooked the belt (https://www.airforums.com/forums/f159/top-air-pump-froze-up-cooked-the-belt-79081.html)

John H. 06-29-2011 06:53 AM

Top air Pump Froze up, cooked the belt
 
and ruined the v drive pully on the top air pump

So after ordering a new one. they are much Lighter than the original. and a new drive belt.

I re read the Post on the Polished A.S. for sale. and talked to a mechanic that has a contract with the school system to maintain buses.
He advised to do as Polished 345 did

Remove it ALL
so I removed ALL of the Mounting brackets for the top Pump. the hoses to the top and Bottom Pump.
the Two charcoal filters and the air control valves. or whatever they are. WOW, now I can see, maintain and Replace radiator hoses and other parts never before seen.
the coach Runs great. So now, before this weekend I will remove the Bottom Pump complete with mounting hardware and replace the serpentine drive belt with a new, shorter one.

So If anyone is Interested in a complete Set. Only the drive pully for the top pump. and new hoses will be required for You to supply.

John

97sx 06-29-2011 01:51 PM

Do you have a part number for the shorter belt?

I just installed some headers and plan to rip out all that junk also.

Keyair 07-01-2011 12:11 PM

That sucks John, but the good news is that you wont have to deal with this again...
I wish California would exempt mine from smog tests, then I could do the same..:(

John H. 07-02-2011 06:47 AM

Quote:

Originally Posted by 97sx (Post 1011214)
Do you have a part number for the shorter belt?

I just installed some headers and plan to rip out all that junk also.

soon I hope

after removing the top pump and ALL the hoses , filters and Crap, even the ones to the bottom pump. I ran the unit for some time.

so last evening I started removing the bottom pump. One Less , Something ? to go Wrong. on the road.
so off came the alternator and after the lower pump is off today. and I mount a new Alternator.
I will cut the original belt to size and take it to the Parts store for a new one the correct size. then I will post the Part Number for the retrofit serpentine belt.

John H. 07-02-2011 06:53 AM

Quote:

Originally Posted by Keyair (Post 1012102)
That sucks John, but the good news is that you wont have to deal with this again...
I wish California would exempt mine from smog tests, then I could do the same..:(

I was fortunate that the top Pump froze when I tried to start the engine. and NOT running down the road.
a bad fire could have been the result.

so I just cut the belt. the top Pump has its own, select belt, not running anything else. started the engine and went on my way.

John H. 07-02-2011 12:10 PM

Quote:

Originally Posted by 97sx (Post 1011214)
Do you have a part number for the shorter belt?

I just installed some headers and plan to rip out all that junk also.

20mm

John H. 07-02-2011 12:23 PM

UPDATE on Project.

I have now removed the lower Pump. and cut off some of the Lower pump mounting bracket with a saw Zaw from above.
I also removed the Lower pump from above and the job was painless after removing the alternator. I also seem to be getting
1. additional Volt. 13.5 reading now with the new unit. a 105 I think . same as I removed. I assume.

Note , remove the drive pully 1.st . a small ratchet, socket set works well.

then the Two mounting Nuts

I mounted a new alternator that I carry for a spare.

then I found a 20mm Belt at NAPA

I sent Sharon in to NAPA for a spare Belt and told her to get an 18mm

as it will have more top end adjustment in case there is some stretch. ? IF, NO stretch. the 20mm will work fine.

This is Like having a new engine, Lighter, and I can SEE ALL and get to ALL Much easier.
so, Two less turning parts to drive and 1 less belt to maintain. work around.
about 30 Lbs worth of Power, gas robbing JUNK. Now Removed
anyone Want this Stuff ????

or to the Trash it will GO

OHHH Happy Day

John H. 07-06-2011 08:28 AM

NAPA belt Number, NO air pump
 
060532

20mmx1367mmOC


13/16 x 53-7/8 OC

NO guarantee this will work for YOU , your application
but it is a start.

97sx 07-06-2011 11:29 AM

Thanks for the info John!

I plan to get started on this tonight.

John H. 07-09-2011 05:56 AM

So how is your Project going 97sx

well I hope

choctawmel 07-12-2011 06:52 PM

Quote:

Originally Posted by John Haggard (Post 1012438)
UPDATE on Project.

I have now removed the lower Pump. and cut off some of the Lower pump mounting bracket with a saw Zaw from above.
I also removed the Lower pump from above and the job was painless after removing the alternator. I also seem to be getting
1. additional Volt. 13.5 reading now with the new unit. a 105 I think . same as I removed. I assume.

Note , remove the drive pully 1.st . a small ratchet, socket set works well.

then the Two mounting Nuts

I mounted a new alternator that I carry for a spare.

then I found a 20mm Belt at NAPA

I sent Sharon in to NAPA for a spare Belt and told her to get an 18mm

as it will have more top end adjustment in case there is some stretch. ? IF, NO stretch. the 20mm will work fine.

This is Like having a new engine, Lighter, and I can SEE ALL and get to ALL Much easier.
so, Two less turning parts to drive and 1 less belt to maintain. work around.
about 30 Lbs worth of Power, gas robbing JUNK. Now Removed
anyone Want this Stuff ????

or to the Trash it will GO

OHHH Happy Day

don't trash it! your never know want our government will do. I did the same many years ago, but it's all on the top shelf just in case.

John H. 07-14-2011 04:12 AM

yes, I have it all.

but before I have to re install. ???? if


I will replace the engine 1. st
maybe with a Jasper RV model or something similar.

Keyair 07-14-2011 12:02 PM

Whats wrong with the Motor John?

John H. 07-14-2011 01:17 PM

Quote:

Originally Posted by Keyair (Post 1017925)
Whats wrong with the Motor John?

Nothing at all is wrong with the engine.

very solid and strong. Keyair

I was just saying that if the government made us re install the air pump system. at some time.
I would replace the engine 1st.

John H. 07-14-2011 01:23 PM

a quote from another Poster. and why it is nice to have access to more engine service ease.

quote

Posted: 05/23/03 11:26pm Link | Print | Notify Moderator Daboss,

Pay attention to JR3's item #5. I replaced all my hoses in 1997 and missed the waterpump bypass hose. Found it last year when changing my top airpump. It was the original (1988) and was mush.

Keyair 07-14-2011 02:05 PM

Oh, OK, got it!:D

pwhittle 07-14-2011 08:53 PM

Mine let go a couple weeks ago. I got to go back to the hose rack at the Advance Auto and pick one with the right bends that I cut one end off and I think I can cut another one off the other end in another 29 years.

Paul


All times are GMT -6. The time now is 12:28 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.