Airstream Forums

Airstream Forums (https://www.airforums.com/forums/)
-   Lights - Interior & Exterior (https://www.airforums.com/forums/f447/)
-   -   Passenger Side lights not working (https://www.airforums.com/forums/f447/passenger-side-lights-not-working-33886.html)

GKurtz 07-03-2007 05:43 PM

Passenger Side lights not working
 
Hi

I have a 2006 Safari (under Warrenty) that the passenger side lights (break, tail and running) lights do not work. The truck is providing power to these circuits, but nothing is happening.

This is under warrenty and the place where I bought it (Great American RV in Fife, Wa) will fix it, but if this is something simple and I can avoid a trip to Fife, let me know

thecatsandi 07-03-2007 05:52 PM

If it was just the running and tail lights I would suspect a bad feed. Since it is the brake ligths too. bad ground. Not sure how those are grounded. You are going to have to remove on of the lights to see how. THis means breaking the sealant. Leave it to the dealer.....

Welcome to the forums.

Jim Clark 07-03-2007 08:37 PM

Quote:

Originally Posted by GKurtz
Hi

I have a 2006 Safari (under Warrenty) that the passenger side lights (break, tail and running) lights do not work. The truck is providing power to these circuits, but nothing is happening.

This is under warrenty and the place where I bought it (Great American RV in Fife, Wa) will fix it, but if this is something simple and I can avoid a trip to Fife, let me know

If it is a SS look at the connections located inside of the refer outside access door and be sure they are pushed together tight. Good luck Jim.

vswingfield 07-03-2007 08:40 PM

Welcome
 
Hi GKurtz,

Welcome to the forum. I'm sure you will find it a great resoruce.

Vaughan


All times are GMT -6. The time now is 05:33 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.