Airstream Forums

Airstream Forums (https://www.airforums.com/forums/)
-   2011 - 2015 International (https://www.airforums.com/forums/f514/)
-   -   New SRM batteries do not appear to be charging (https://www.airforums.com/forums/f514/new-srm-batteries-do-not-appear-to-be-charging-187450.html)

CanoninD 09-23-2018 09:15 AM

New SRM batteries do not appear to be charging
 
Hi there. Very new here. Been using my camper at a seasonal site and am getting ready to move out in a month.

I had two new batteries installed and the SeeLevel ll still reads 13.6

The camper is still on shore power so I thought they should be charging.

Does something need to be reset since the old batteries were probably dead?

Thanks so much.

Caffeinated 09-23-2018 09:22 AM

If you are on shore power the 13.6 you are seeing is the voltage coming from your converter/charger, not your actual battery voltage. And it is probably charging your batteries.

If you want to know your batteries state, you'll need a multimeter, and you'll need to disconect from shore power for a few hours to let the batteries stabilize. Then measure the voltage at the battery posts.

Mike

CanoninD 09-23-2018 09:28 AM

Thank you so much!

pcskier 09-23-2018 11:19 AM

As mentioned, the 13.6V reading is what's coming off the charger. If you unplug from shore power, you should see that drop to 12.7 or so. And as advised, let batteries 'rest' a couple hours to get a true reading.

However...make sure your battery use/store switch is in "USE" position. If in 'store', they will not be charging.


All times are GMT -6. The time now is 10:06 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.