Airstream Forums

Airstream Forums (https://www.airforums.com/forums/)
-   1965 - 1969 Overlander (https://www.airforums.com/forums/f363/)
-   -   No interior lighting (https://www.airforums.com/forums/f363/no-interior-lighting-169671.html)

ALANSD 07-11-2017 11:28 AM

No interior lighting
 
My wife tried to turn on one of the ceiling lights. She turned the switch the wrong way and all the lights went out.
The wall sockets still work and the exterior light being 12v still does as well.

I saw one AGS40 Fuse in the outside back access panel that is cloudy but not sure its blown.
I tripped and reset the two breakers in the bathroom, and no change.

I will have to seek out the glass fuse as although I have many extras, there is none like the one that I took out. All are smaller.
Though I do have a box of very heavy duty 50amp fuses, not sure why.

The filament in the fuse looks ok, but again the fuse was cloudy..any ideas?

Any other spots to check for fuses? I know of none. :blink:

Frye's electronics locally carries a lot of fuses, hopefully they will have these.

Just was there buying some for my old Fender amp...

ALANSD 08-12-2017 11:53 AM

I replaced the fuse I though might be bad. No change. The Univolt is humming so I know it is on, but there is no 12v power. I traced the white wire that comes off it, I don't see any fuses in addition to the main fuse box in the access panel at rear end.
My manual says there is a 40 amp fuse somewhere...Anyone know where?

I have a bunch of large fuses that came with the trailer, no idea where they go yet.

AirMiles 08-12-2017 12:15 PM

Quote:

Originally Posted by ALANSD (Post 1992672)
I replaced the fuse I though might be bad. No change. The Univolt is humming so I know it is on, but there is no 12v power. I traced the white wire that comes off it, I don't see any fuses in addition to the main fuse box in the access panel at rear end.
My manual says there is a 40 amp fuse somewhere...Anyone know where?

I have a bunch of large fuses that came with the trailer, no idea where they go yet.

This happened to me last time out. I thought it was the switch, so I pulled the switch to test it. What I found was an inline automotive large size 10A fuse in a rubber protector on the line within a few inches of the switch. The closest replacement I had was a spare 7.5A mini-fuse. I plugged in the smaller fuse and the lights work again.

I need to get some spare large 10A flat automotive fuses for the next time this happens.

Hope this helps.

ALANSD 08-12-2017 12:38 PM

good tip, I will pull the switch and the light it is on.

ALANSD 08-14-2017 06:24 AM

1 Attachment(s)
Pulled two of the ceiling lights, did not find a fuse inline. I found only a red capped connector.
I cleaned all the fuse box parts and replaced all the fuses with new ones. Luckily I have a large box of spares.
I am sure not that it is the Univolt fuses that are suspect. It is going to be pita to acces these as the unit is under the bathroom closet and likely too far to reach from the access panel at rear. Some contortion may be necessary to unscrew the cover.
Found a good photo that will help.

TG Twinkie 08-14-2017 07:14 AM

Do you have 12+ volts at the fuse panel in the UNIVOLT?
Just because it is humming doesn't mean it is working.
The 40 amp fuse is usually wired into the negative side and mounted on the skin. If there is one.
Have you tried connecting a battery charger in parallel to the Univolt just to see if things work?

TG Twinkie 08-14-2017 07:17 AM

It looks like the wire at the left end of the shunt has come loose.

TG Twinkie 08-14-2017 07:23 AM

Also noticed what looks like a fuse holder on the floor left of the Univolt
It is in the black lead which is the negative side of the 12 volt system.
The missing fuse at the top right in the Fuse panel and the addition of a circuit breaker on top of the Univolt tells me someone has made changes.

ALANSD 08-14-2017 07:49 AM

sorry- that univolt is not mine. Old Forums photo. I have two circuits with 40 amp fuses one has been pulled for some time, it is for a second battery under the bed. The other fuse is fresh.
I was able to open up the side panel on the Univolt, it has the wires going in and out, looks original. No fuses visible. I also don't see any other panels to open on the unit. Shined a light in and around and could not see fuses. WTF?

I have not put a battery charger on anywhere. Don't have a battery in the trailer right now..
I have a box of 50 amp large glass tube BUSS fuses. Where the heck do they go? Came with the drawer full of parts.

Also there are brown square connectors at the bottom of the panel fuse box. Not sure what these are..

TG Twinkie 08-14-2017 08:18 AM

You don't need a battery to use the charger.
Simply connect the charger to the + and - buss in the Univolt.
Pics would be nice. The Brown items may be circuit breakers, the 12 volt style.

ALANSD 08-14-2017 09:22 AM

3 Attachment(s)
if these brown boxes are circuit breakers are they still available?
The missing 40 amp Buss type has been out for years. Its for the extra battery.

The Univolt is shown open ...for what its worth

uncle_bob 08-14-2017 09:26 AM

Hi

Head over to Home Depot and spend $20 on a multimeter. Run through the system tracking the 12V. It's *way* easier than guessing about this or that ....

Bob

ALANSD 08-14-2017 09:44 AM

I ve got one already, I have a few cars I work on around here... Will try it and see where the power stops.

Hey by the way I love Carlisle. Been to the import show there a few times. My brother lives in Lancaster.

TG Twinkie 08-14-2017 10:39 AM

Those are circuit breakers.
Have you lost all 12 volt DC?
No water pump power, fan power etc. Or is it just the lights?

ALANSD 08-14-2017 04:32 PM

yes nothing works. Only the AC circuit is on.
I will use the multi meter tomorrow. Thought this had to be a fuse the way it happened.
Could be a dead Univolt? That would make 3 Airstreams in a row I have had that needed the converter replaced.
Not getting too far ahead, but would the old fuse panel in there work with a new converter?

TG Twinkie 08-14-2017 04:45 PM

The old fuse panel will work. But for very little money you could upgrade to a blade fuse type panel.

ALANSD 08-14-2017 04:51 PM

I will sing a song in remembrance of the old UNIVOLT if it is truly dead. It served me well for 6 years and someone prior to me for 43...

uncle_bob 08-15-2017 09:24 AM

Hi

Univolts were pretty darn rugged designs. Nothing lasts forever ..... :)

Bob

ALANSD 08-15-2017 10:50 AM

haven't gotten to it yet, but if its dead. ...I think I will keep the box as a shrine to things that last.

uncle_bob 08-15-2017 12:11 PM

Quote:

Originally Posted by ALANSD (Post 1994278)
haven't gotten to it yet, but if its dead. ...I think I will keep the box as a shrine to things that last.

Hi

Most likely it has a resonator capacitor on it with PCB's in it. Be sure to put the proper HAZMAT labels on the box :)

Bob

ALANSD 08-19-2017 12:28 PM

Univolt is dead. Long live the Overlander.
Guess I will be buying a converter....soon. Thanks for all the tips. No fuse other than the panel fuses were ever found.

uncle_bob 08-19-2017 01:55 PM

Hi

If you go out and get a new converter, spend some quality time digging into this and that. There are some dirt cheap ( = avoid) models out there, some modest price / reasonable performance, and some very good units. Compared to the price of a pair of nice big AGM's, none of then are all that scary.

Bob

CBWELL 08-19-2017 02:31 PM

I have installed several Progressive Dynamics converters. The PD9245 is a good unit and quite economical. Very easy to replace the old unit with. Takes about 20 minutes to change out, and I use the old leeds from the univolt to the 12v breaker panel. Did have one fail this week after a month's use, and Progressive sent a replacement the same day. Good people to deal with. Ebay is a good place to purchase.

ALANSD 08-20-2017 06:10 AM

thanks for the tips. This will be the third one I have replaced in my Airstreams. They are relatively easy to install.

ALANSD 08-03-2018 03:19 PM

replaced the converter with major help from Mike G a fellow streamer. everything worked.

uncle_bob 08-04-2018 06:46 AM

Hi

While you are in "upgrade mode" at least consider a battery monitor. The BMV-712 is one option. There are *lots* of others ....

Bob


All times are GMT -6. The time now is 03:41 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.