Airstream Forums

Airstream Forums (https://www.airforums.com/forums/)
-   Electrical - Systems, Generators, Batteries & Solar (https://www.airforums.com/forums/f37/)
-   -   battery, water tank monitor panel failure? (https://www.airforums.com/forums/f37/battery-water-tank-monitor-panel-failure-169355.html)

Atsushi 07-05-2017 07:43 PM

battery, water tank monitor panel failure?
 
We have 2016 FC23D, and we are experiencing the first problem.

Battery+Water Tank monitor panel that normally displays numbers in voltage of battery and in percentage for tanks does not display anything (they remain dark). It was working this morning. This evening, it doesn't.

Water pump switch that is part of this panel is working.

What should/can I check?

I don't care so much about water levels, but I would like to be able to check battery level....although I still could do that with a voltage meter.

Thanks in advance,

Atsushi

SteveSueMac 07-05-2017 08:27 PM

battery, water tank monitor panel failure?
 
Hi. I'm currently having the same problem but mine is 4 years older than yours. Mine has an on/off switch for the entire panel - I'm assuming that's on for you, yes?

I'm being told (in another thread I recently started on this topic) that there could be many sources of the problem - but one person who had a similar problem found out it was the black tank sender that was killing the whole panel so he disconnected that from the panel and all is fine. I may try that this weekend or may ultimately have mine replaced with a SeeLevel (your more recent model may already have that - or is yours also a MicroPulse?).

Are you boondocking or plugged in to shore power? If the latter and you are in USE mode with your use/store switch, your batteries are going to be charged.

Atsushi 07-06-2017 06:43 AM

Quote:

Originally Posted by SteveSueMac (Post 1973147)
Hi. I'm currently having the same problem but mine is 4 years older than yours. Mine has an on/off switch for the entire panel - I'm assuming that's on for you, yes?

I'm being told (in another thread I recently started on this topic) that there could be many sources of the problem - but one person who had a similar problem found out it was the black tank sender that was killing the whole panel so he disconnected that from the panel and all is fine. I may try that this weekend or may ultimately have mine replaced with a SeeLevel (your more recent model may already have that - or is yours also a MicroPulse?).

Are you boondocking or plugged in to shore power? If the latter and you are in USE mode with your use/store switch, your batteries are going to be charged.

Thanks for your comment. I figured this out. According to SeaLevel manual, if the panel is not responsive at all, you can try disconnect the battery, wait for 10 seconds and connect it again. I tried it this morning, and that fixed it.

By the way, mine is SeeLevel II Model 709-P3. It has 4 buttons for Batt, Fresh, Grey and Black and 1 switch for Pump.

I've read on Airstream Addict FB pages that a lot of people have had problems with the panel, like inconsistent readings, etc. Before this trouble, my black water tank reading remained zero for the entire trip that we took this weekend even though we used the toilet quite a bit for 3 days. So while the panel is working, I know there is still something wrong with it.

So how do we get access to the "black tank sender?" Isn't it inside the tank? Is part of the system accessible from outside (underneath the trailer)?

Thanks!

Atsushi


All times are GMT -6. The time now is 11:12 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.