RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-14-2019, 06:38 PM   #1
2 Rivet Member
 
2019 30' Classic
LEES SUMMIT , Missouri
Join Date: Mar 2019
Posts: 41
Czone not working

Help!! My czone system stopped working and the blue lights on each of the control panels are flashing 7 times over and over. The main Czone screen lights up and lists all of the lights etc. but it will not allow me to turn on anything and won't display the status of water levels etc. Talked to the factory customer service and they have no idea what is wrong.
dechampion is offline   Reply With Quote
Old 06-14-2019, 07:19 PM   #2
Rivet Master
 
overlander63's Avatar
 
1993 21' Sovereign
Colfax , North Carolina
Join Date: Jun 2003
Posts: 21,254
Check the communication cables at the ends. One at the Czone, the other in the lower compartment next to the breaker box. If you don't find anything loose, check the fuses in the Czone fuse box in the same compartment. If everything there is good, turn off the trailer battery switch by the door, wait a minute, then turn it back on.

There is an emergency tank/voltage monitor panel under the kitchen sink, next to the shelf where the sink covers go when they're not in use.
__________________
Terry
overlander63 is offline   Reply With Quote
Old 06-14-2019, 07:31 PM   #3
Rivet Master
 
turk123's Avatar

 
2019 30' Classic
Canfield , Ohio
Join Date: Jul 2015
Posts: 2,227
Turn your battery disconnect switch off. Go into the cabinet to do it under the wardrobe. My disconnect switch by the door does not work. Yours certainly won't either.

Turning everything off will shut off the large switch where all the cables go. It will reset everything. Mine did the flashing thing once and this solved it.
__________________
x\x/x\x/x\x/x\x/x\101970\x/x\x/x\x/x\x/x\x/x\/x\x/x\x/x
2017 Airstream International Signature 27FB Twin
2019 Airstream Classic 30 Twin
turk123 is offline   Reply With Quote
Old 06-14-2019, 11:25 PM   #4
2 Rivet Member
 
2019 30' Classic
LEES SUMMIT , Missouri
Join Date: Mar 2019
Posts: 41
Thanks for the suggestions. I checked all the wiring and everything is tight. Nothing wrong with the fuses. I tried disconnecting the batteries both from the button next to the entry door and the knob in the cabinet below the wardrobe. Still no luck. There are no lights on any of the Czone components in the cabinet below the wardrobe.
dechampion is offline   Reply With Quote
Old 06-15-2019, 06:03 AM   #5
Rivet Master
 
turk123's Avatar

 
2019 30' Classic
Canfield , Ohio
Join Date: Jul 2015
Posts: 2,227
You can call Czone. I’ve talked to them once before. They did not do the programming on the system, but could help on basic operations.
__________________
x\x/x\x/x\x/x\x/x\101970\x/x\x/x\x/x\x/x\x/x\/x\x/x\x/x
2017 Airstream International Signature 27FB Twin
2019 Airstream Classic 30 Twin
turk123 is offline   Reply With Quote
Old 06-15-2019, 06:37 AM   #6
Rivet Master
 
BigSxyWhtGuy's Avatar
 
2018 30' Classic
Thousand Oaks , California
Join Date: Mar 2017
Posts: 1,028
When you did a power reset, did you leave the power off for 10ish minutes or just flip it all off then on again?
__________________
BigSxyWhtGuy

Follow our adventures!
@airstreamvagabond on Instagram and YouTube
BigSxyWhtGuy is offline   Reply With Quote
Old 06-15-2019, 11:15 AM   #7
2 Rivet Member
 
2019 30' Classic
LEES SUMMIT , Missouri
Join Date: Mar 2019
Posts: 41
I left the power off about 3 minutes each time.
dechampion is offline   Reply With Quote
Old 06-15-2019, 11:18 AM   #8
2 Rivet Member
 
2019 30' Classic
LEES SUMMIT , Missouri
Join Date: Mar 2019
Posts: 41
Did you have a similar problem?
Thanks
dechampion is offline   Reply With Quote
Old 06-15-2019, 11:43 AM   #9
2 Rivet Member
 
2019 30' Classic
LEES SUMMIT , Missouri
Join Date: Mar 2019
Posts: 41
In the interest of trying everything, I disconnected the batteries again (using the knob in the cabinet below the wardrobe) and left it off for 11 minutes before turning it back on. Still nothing. Fortunately, I already have a 2-day appointment scheduled for late August to have the Jackson Center Airstream factory fix everything else wrong with this 4-month-old "Rolls Royce of travel trailers". I've added replacement of the Czone system to the list. Unfortunately, with the Czone not working, I pretty much am stuck with the equivalent of a hard shell tent for the summer (prime camping season). Thanks for the suggestions, everyone.
dechampion is offline   Reply With Quote
Old 06-15-2019, 02:25 PM   #10
Rivet Master
 
BigSxyWhtGuy's Avatar
 
2018 30' Classic
Thousand Oaks , California
Join Date: Mar 2017
Posts: 1,028
Long time to wait, you may be able to get into a local dealer quickly for a fix under warranty?

Unfortunately I have firefly but usually that prolonged power reset does the trick. Sorry you’re dealing with this!
__________________
BigSxyWhtGuy

Follow our adventures!
@airstreamvagabond on Instagram and YouTube
BigSxyWhtGuy is offline   Reply With Quote
Old 06-15-2019, 07:22 PM   #11
Rivet Master
 
turk123's Avatar

 
2019 30' Classic
Canfield , Ohio
Join Date: Jul 2015
Posts: 2,227
Inside the cabinet under the wardrobe is the Czone switch with all the cables going to it. I assume you said you had no blinking green lights correct?

My trailer is in storage so I can not check, but I believe the Czone box is not fastened down. If not, I would pull it out and see if it is getting power or has been disconnected. If you have power to the panel, the problem lies with this box.
__________________
x\x/x\x/x\x/x\x/x\101970\x/x\x/x\x/x\x/x\x/x\/x\x/x\x/x
2017 Airstream International Signature 27FB Twin
2019 Airstream Classic 30 Twin
turk123 is offline   Reply With Quote
Old 06-15-2019, 10:28 PM   #12
2 Rivet Member
 
2019 30' Classic
LEES SUMMIT , Missouri
Join Date: Mar 2019
Posts: 41
Quote:
Originally Posted by turk123 View Post
Inside the cabinet under the wardrobe is the Czone switch with all the cables going to it. I assume you said you had no blinking green lights correct?

My trailer is in storage so I can not check, but I believe the Czone box is not fastened down. If not, I would pull it out and see if it is getting power or has been disconnected. If you have power to the panel, the problem lies with this box.
Correct. There are two czone boxes beneath the wardrobe and neither has any lights lit. The cables are connected to the boxes.
dechampion is offline   Reply With Quote
Old 06-16-2019, 07:20 AM   #13
2 Rivet Member
 
2019 30' Classic
LEES SUMMIT , Missouri
Join Date: Mar 2019
Posts: 41
Quote:
Originally Posted by dechampion View Post
Correct. There are two czone boxes beneath the wardrobe and neither has any lights lit. The cables are connected to the boxes.
Fixed it !! One of the yellow cable connectors behind the circuit breaker panel came loose. Screwed them back together. Click image for larger version

Name:	20190615_220901.jpeg
Views:	54
Size:	80.3 KB
ID:	343509
dechampion is offline   Reply With Quote
Old 06-16-2019, 07:27 AM   #14
Rivet Master
 
turk123's Avatar

 
2019 30' Classic
Canfield , Ohio
Join Date: Jul 2015
Posts: 2,227
Great! . . . and good to know!

I got a feeling you are like a lot of us here. It just bugs you that you know it is something simple and staring you right in the face. You persisted and that's what matters. Great news!
__________________
x\x/x\x/x\x/x\x/x\101970\x/x\x/x\x/x\x/x\x/x\/x\x/x\x/x
2017 Airstream International Signature 27FB Twin
2019 Airstream Classic 30 Twin
turk123 is offline   Reply With Quote
Old 06-16-2019, 08:33 AM   #15
2 Rivet Member
 
2019 30' Classic
LEES SUMMIT , Missouri
Join Date: Mar 2019
Posts: 41
Quote:
Originally Posted by turk123 View Post
Great! . . . and good to know!

I got a feeling you are like a lot of us here. It just bugs you that you know it is something simple and staring you right in the face. You persisted and that's what matters. Great news!
Turk123 it was your post that caused me to look deeper and trace all of the cables back to their sources and that is when I found the disconnect. Thanks again.
dechampion is offline   Reply With Quote
Old 09-09-2020, 06:36 PM   #16
New Member
 
2020 33' Classic
Fort Pierce , FL
Join Date: Sep 2020
Posts: 4
Images: 1
Czone Flashing blue lights - 7 times

Hi everyone. We have a new 2020 Airstream Classic 33FB. The top four switches in the bedroom, by the door, and in the bathroom are flashing blue lights 7 times. Some light switches work, others don't unless you use the bypass on the CZone Controller 1. We recently installed lithium batteries and a converter. Every worked great and we are getting 14.3 output. When we left in the morning, everything worked; the lights started flashing when we set up at the new campsite.

Troubleshooting so far includes:

Checked all connections; they are tight.
Checked all fuses; they are good.
Checked power at Czone controller-14.3 at the terminals
Network light is green.
No power light on the Czone Controller 1.
All modules have a green light.
Display works: no voltage showing.
Have powered down and rebooted; same issue.

Any ideas/suggestions would be appreciated? There doesn't seem to be a lot available on the CZone.

Thanks,
S.E. Smith
2020 Airstream Classic 33FB
2013 5.7L Toyota Tundra
sesmith06 is offline   Reply With Quote
Old 10-23-2020, 07:21 AM   #17
New Member
 
2021 30RB Classic
Bristow , Virginia
Join Date: Oct 2020
Posts: 1
Quote:
Originally Posted by sesmith06 View Post
Hi everyone. We have a new 2020 Airstream Classic 33FB. The top four switches in the bedroom, by the door, and in the bathroom are flashing blue lights 7 times. Some light switches work, others don't unless you use the bypass on the CZone Controller 1. We recently installed lithium batteries and a converter. Every worked great and we are getting 14.3 output. When we left in the morning, everything worked; the lights started flashing when we set up at the new campsite.

Troubleshooting so far includes:

Checked all connections; they are tight.
Checked all fuses; they are good.
Checked power at Czone controller-14.3 at the terminals
Network light is green.
No power light on the Czone Controller 1.
All modules have a green light.
Display works: no voltage showing.
Have powered down and rebooted; same issue.

Any ideas/suggestions would be appreciated? There doesn't seem to be a lot available on the CZone.

Thanks,
S.E. Smith
2020 Airstream Classic 33FB
2013 5.7L Toyota Tundra
Same here. Did you get yours figured out? I have a 2021 Classic 30 RBQ
Lab-stream is offline   Reply With Quote
Old 10-24-2020, 05:24 AM   #18
New Member
 
2020 33' Classic
Fort Pierce , FL
Join Date: Sep 2020
Posts: 4
Images: 1
Yes, the COI was bad. We replaced the COI and everything is working again like it should. Now only two issues left. The fuse to the power footrests like to pop frequently and the water pressure to the kitchen sink and shower aren’t very good while the bathroom sink is fine. We are troubleshooting those now.

Susan
2020 33’ Airstream Classic FB
2013 5.7L Toyota Tundra
sesmith06 is offline   Reply With Quote
Old 10-24-2020, 10:29 AM   #19
2 Rivet Member
 
2016 30' Classic
Livingston , Texas
Join Date: Jan 2019
Posts: 64
Susan

Sorry so many headaches. Hope things are working better.

Just wondering what Lithiums did you install and what converter? Where did you put your batteries?

Would you share any photos?

Mike
Quote:
Originally Posted by sesmith06 View Post
Yes, the COI was bad. We replaced the COI and everything is working again like it should. Now only two issues left. The fuse to the power footrests like to pop frequently and the water pressure to the kitchen sink and shower aren’t very good while the bathroom sink is fine. We are troubleshooting those now.

Susan
2020 33’ Airstream Classic FB
2013 5.7L Toyota Tundra
Karen-Mike is offline   Reply With Quote
Old 10-26-2020, 10:03 AM   #20
New Member
 
2020 33' Classic
Fort Pierce , FL
Join Date: Sep 2020
Posts: 4
Images: 1
Lithium batteries

Here are the pictures. It took my husband about a day and a half to do everything. He also fixed some loose connections from the factory and cleaned things up a bit. We removed the couch and dining seat and placed them on the bed so it opened up the area to make it easier to work. It wasn’t hard, just a few bolts. He also cleaned up the wiring underneath the couch to give us more storage room. He now has additional storage where the old batteries were which has really come in handy. I’ve included the packing slip with info to Battle Born and what pictures I took. I’m not sure if you are interested in the washing machine, but we LOVE having one. I’ve included a photo of it as well. We had quotes from anywhere for $5000-$22,000 to put one in. We did it for under $400. Fully automatic with spin dry; electric in closet; drain hose goes under the wall and is connect to the drain under the bathroom sink. Does a wonderful job washing the clothes and can handle queen sheets/thin bedspread or a decent size load of laundry; multiple functions. I hope this helps.

Susan
2020 33’ Classic FB Queen
2013 5.7L Toyota Tundra







Attached Thumbnails
Click image for larger version

Name:	4DF049B5-964E-4EBA-8788-344472BE12DE.jpg
Views:	10
Size:	219.9 KB
ID:	381848   Click image for larger version

Name:	3EBE09E0-9F0A-4F44-972B-299013349BD0.jpg
Views:	13
Size:	348.4 KB
ID:	381849  

Click image for larger version

Name:	D8AFDCFF-E1EF-4FF4-903A-7EA234C86386.jpg
Views:	11
Size:	341.9 KB
ID:	381850   Click image for larger version

Name:	F8A92626-9ED7-4825-A078-4BAA82210951.jpg
Views:	5
Size:	230.4 KB
ID:	381851  

Click image for larger version

Name:	1AB388D5-A05A-42CC-A43E-573592A6AD2E.jpg
Views:	11
Size:	198.7 KB
ID:	381852  
sesmith06 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CZONE Display Reset? PaulR-GA 2016 - Current Classic (all lengths) 18 08-06-2020 09:10 AM
CZONE replacing fan with MaxxFan The Naker 2016 - Current Classic (all lengths) 21 03-15-2020 08:49 AM
CZone and Multiplex Interfaces In General Re-Pete 2016 - Current Classic (all lengths) 10 05-26-2019 10:11 AM
Regarding Multiplex Interface Systems such as CZone, etc. Re-Pete Electronics & Connectivity 0 04-16-2019 11:53 PM
CZone app skiphoyt Sprinter and B-van Forum 1 03-07-2019 08:42 PM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 09:29 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.