Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-13-2021, 09:28 PM   #1
2 Rivet Member
 
Mike0392's Avatar
 
2019 33' Classic
Estes Park , Colorado
Join Date: Feb 2019
Posts: 83
Alde woes

Fired up the heat on my Classic 33 and no heat. Checked the expansion tank no fluid. Got a couple of gallons from Turma and topped it up. Lots of air, burped at the towel rack, no heat. Hear pump running and fluid gurgling no heat. What the hell? Looked in every cabinet under sinks, no leaks.
Iím full timing and am going to need some heat here in Colorado.
Need some help here please
Mike0392 is offline   Reply With Quote
Old Yesterday, 07:30 AM   #2
Airstream Ambassador
 
AirstreamInc's Avatar
 
Jackson Center , Ohio
Join Date: Feb 2017
Posts: 734
Blog Entries: 1
Quote:
Originally Posted by Mike0392 View Post
Fired up the heat on my Classic 33 and no heat. Checked the expansion tank no fluid. Got a couple of gallons from Turma and topped it up. Lots of air, burped at the towel rack, no heat. Hear pump running and fluid gurgling no heat. What the hell? Looked in every cabinet under sinks, no leaks.
Iím full timing and am going to need some heat here in Colorado.
Need some help here please
Hi Mike0392,*

We're very sorry to learn about the issue you are having. Please send us a direct message with your contact information, email and the last 6 digits of your VIN so we can share it with our Customer Service and Technical Support team. We look forward to helping you get this resolved.

You can also reach Airstream Customer Service and Technical Support at*customersupport@airstream.com

Thank you.*
__________________
Official account for Airstream, Inc.
Airstream Customer Service and Technical Support can be reached at 1 (877) 596-6111, option 1.
AirstreamInc is online now   Reply With Quote
Old Yesterday, 09:08 AM   #3
Half a Rivet Short
 
2017 30' Classic
2022 Interstate 24X
Carlisle , Pennsylvania
Join Date: May 2017
Posts: 12,470
Quote:
Originally Posted by Mike0392 View Post
Fired up the heat on my Classic 33 and no heat. Checked the expansion tank no fluid. Got a couple of gallons from Turma and topped it up. Lots of air, burped at the towel rack, no heat. Hear pump running and fluid gurgling no heat. What the hell? Looked in every cabinet under sinks, no leaks.
I’m full timing and am going to need some heat here in Colorado.
Need some help here please
Hi

When did the system last work correctly?

If you put in a gallon or more of fluid *and* the system worked in the past, that's a lot of fluid. Did you purge the air at the various purge points on the system? If not, there still is more work to do. You might want to boost the speed setting on the circulation pump to get it done quicker.

The "big deal" place to look for leaks is by the main system. There's lots of pipe and stuff under there. On a 30' it's under one of the dinette seats. I suspect that's also true on a 33'.

Bob
uncle_bob is offline   Reply With Quote
Old Yesterday, 03:32 PM   #4
2 Rivet Member
 
Mike0392's Avatar
 
2019 33' Classic
Estes Park , Colorado
Join Date: Feb 2019
Posts: 83
Alde woes

Last season. I took all of the covers the bench and itís dry. Iíll get underneath this evening and look at the drain tube .
Mike0392 is offline   Reply With Quote
Old Yesterday, 04:20 PM   #5
Half a Rivet Short
 
2017 30' Classic
2022 Interstate 24X
Carlisle , Pennsylvania
Join Date: May 2017
Posts: 12,470
Quote:
Originally Posted by Mike0392 View Post
Last season. I took all of the covers the bench and itís dry. Iíll get underneath this evening and look at the drain tube .
Hi

From that I *assume* it worked correctly last season ??

When was the last time you ran it and checked the level in the tank above the toilet? There are an unfortunate lot of examples of dealers not checking fluid when delivering trailers ....

Bob
uncle_bob is offline   Reply With Quote
Old Yesterday, 08:17 PM   #6
2 Rivet Member
 
Mike0392's Avatar
 
2019 33' Classic
Estes Park , Colorado
Join Date: Feb 2019
Posts: 83
Alde woes

Itís the brass auto vent valve stuck open! Removed my Air Skirts and there was the puddle. I asked Airstream to send me a new one, letís see what happens. Bought a heater brick tonight for when the heat pump kicks out on low temperature. Hopefully they can rush it? Starting to miss forced air heat.
Mike0392 is offline   Reply With Quote
Old Today, 07:42 AM   #7
Half a Rivet Short
 
2017 30' Classic
2022 Interstate 24X
Carlisle , Pennsylvania
Join Date: May 2017
Posts: 12,470
Quote:
Originally Posted by Mike0392 View Post
Itís the brass auto vent valve stuck open! Removed my Air Skirts and there was the puddle. I asked Airstream to send me a new one, letís see what happens. Bought a heater brick tonight for when the heat pump kicks out on low temperature. Hopefully they can rush it? Starting to miss forced air heat.
Hi

That makes sense, assuming we're talking about the valve on the hydronic fluid and not the one on the water heater side. If it's the water heater vent valve .... keep looking.

Simple way to tell: Put something under the valve and see what's coming out. If it's hydronic fluid then that is the issue.

Bob
uncle_bob is offline   Reply With Quote
Reply

« 21 Classic AC issue | Top | - »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alde overheat red hot and empty alde tank Alreddawg19 General Repair Forum 2 Yesterday 08:19 PM
First Alde 3010 boiler to Alde 3020 boiler and Alde flow upgrade Sparr 2016 - Current Classic (all lengths) 64 08-15-2021 06:36 AM
Alde woes Mike0392 2016 - Current Classic (all lengths) 7 04-06-2020 10:11 AM
ALDE HEATING SYSTEM FAILURE- Alde glycol discoloration and vent discharge JimskyD 2016 - Current Classic (all lengths) 50 05-25-2018 07:48 AM
Problem with safety valve popping between Alde flow and Alde paul.kukstis 2016 - Current Classic (all lengths) 7 04-08-2018 06:09 AM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 01:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.