RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-27-2017, 11:29 AM   #1
3 Rivet Member
 
TRIPPPIN's Avatar
 
2012 25' FB Eddie Bauer
Southwestern Ontario , Ontario Canada
Join Date: Mar 2007
Posts: 241
Images: 6
Send a message via MSN to TRIPPPIN Send a message via Yahoo to TRIPPPIN
Subwoofer works except for TV sound - help

I just noticed the subwoofer does not work with the TV sound coming through the Sony Audio unit and Collins subwoofer supplied with my 2012 25 FB Eddie Bauer. The sub works with blue ray player and radio. I checked the Sony XA 300 and the connections but I can't figure why it won't work on the TV.

I upgraded the TV to a 32" Vizio that had the RCA audio out like the old TV and moved the old Samsung to the bedroom. I also added a HDMI switcher to control those cables. I can't see why any of my changes would cause this.

Any ideas are appreciated, the sound on the TV really needs the base of the sub.
TRIPPPIN is offline   Reply With Quote
Old 02-27-2017, 11:47 AM   #2
Rivet Master
 
Mollysdad's Avatar

 
2017 26' Flying Cloud
Tampa , Florida
Join Date: Feb 2017
Posts: 5,224
Blog Entries: 1
Make sure the output on the TV is selected in the Menu.
As I recall there's some choices. Fixed volume, adjustable volume. Also digital or analog.
At home, I have the powered speakers fed from the TV, so no matter the source, I have audio. The subwoofer is then looped through the speakers.
Since your setup works with the DVD, is your subwoofer fed from the DVD player?

Sony XA 300 is an audio aux device, looks like it allows you to put several signals into a radio/tuner/amp.
Mollysdad is offline   Reply With Quote
Old 02-27-2017, 12:27 PM   #3
3 Rivet Member
 
TRIPPPIN's Avatar
 
2012 25' FB Eddie Bauer
Southwestern Ontario , Ontario Canada
Join Date: Mar 2007
Posts: 241
Images: 6
Send a message via MSN to TRIPPPIN Send a message via Yahoo to TRIPPPIN
Quote:
Originally Posted by Mollysdad View Post
Make sure the output on the TV is selected in the Menu.
As I recall there's some choices. Fixed volume, adjustable volume. Also digital or analog.
At home, I have the powered speakers fed from the TV, so no matter the source, I have audio. The subwoofer is then looped through the speakers.
Since your setup works with the DVD, is your subwoofer fed from the DVD player?

Sony XA 300 is an audio aux device, looks like it allows you to put several signals into a radio/tuner/amp.
The subwoofer is fed direct from the Sony head unit sunwoofer outputs. The DVD and TV go through the XA300 to the Sony head unit and are activated when the Sony head unit is on CD2. I tried CD3 also but no sound at all. I have sound for the TV from all the speakers except the subwoofer. The DVD goes the same route through the XA300 and all the speakers including the Subwoofer work. Confusing to me.
TRIPPPIN is offline   Reply With Quote
Old 02-27-2017, 08:15 PM   #4
Registered User
 
2016 25' Flying Cloud
Fairfield , California
Join Date: Sep 2016
Posts: 903
Don't know about your particular tv, some need to be told to send a signal out the external audio. This might be what is happening.
Mattirs is offline   Reply With Quote
Old 02-27-2017, 08:51 PM   #5
Rivet Master
 
AStreamNerds's Avatar
 
2015 25' FB Flying Cloud
Manassas , Virginia
Join Date: Mar 2015
Posts: 562
Images: 6
Do you hear your TV audio and just not the low frequency? Depending on how the Sony is configured as well as the frequencies being sent out of the TV audio jack it may be working just as it is supposed to. If for some reason no frequencies below 160Hz are sent out of the RCA connections on TV and the low pass crossover is set to 100Hz on the Sony then you will hear nothing out of the sub. I do not have either of the units you have so I do not know how you would go about fixing this.
__________________
Our Website: https://airstreamnerds.com/

You Tube Channel "Airstream Nerds": https://www.youtube.com/airstreamnerds

Find Us on Facebook: https://www.facebook.com/AirstreamNerd/
AStreamNerds is offline   Reply With Quote
Old 03-01-2017, 08:05 AM   #6
3 Rivet Member
 
TRIPPPIN's Avatar
 
2012 25' FB Eddie Bauer
Southwestern Ontario , Ontario Canada
Join Date: Mar 2007
Posts: 241
Images: 6
Send a message via MSN to TRIPPPIN Send a message via Yahoo to TRIPPPIN
Yes I get TV audio to all the speakers just nothing from the sub. I have changed the frequency ranges several times and high pass settings and every combination but still the sub only works from the radio. I am beginning to think the RCA audio input to the Sony Media Player DSX-S300btx only processes right and left channel and no signals to the sub from the RCA audio input. this comes with xa-300 aux input selector setup from factory. Cannot bypass the XA-300 either.
TRIPPPIN is offline   Reply With Quote
Old 03-01-2017, 09:19 AM   #7
Rivet Master
 
wulfraat's Avatar
 
2017 30' International
Broomfield , Colorado
Join Date: Apr 2009
Posts: 2,602
Images: 1
Your wiring is fine if you are getting low end on radio / DVD input. I just dismantled / rewired one of these systems and they are pretty basic. The audio signal from the xa-300 aux to the head unit is full range, it does not bypass / crossover low frequency.

Likely, your head unit is set to "stereo" mode or has an EQ profile that cuts out base for CD Aux 2 input (TV) ... which likely only outputs audio on L/R speakers. Mess with your settings there is likely a surround sound or sub woofer or eq on/off setting by channel.

In the end I ditched my Sony head unit and upgraded to a Pioneer Double DIN touch screen unit ... with Polk speakers the sound is night and day

http://www.airforums.com/forums/f450...de-161787.html
wulfraat is offline   Reply With Quote
Old 03-01-2017, 10:37 AM   #8
4 Rivet Member
 
2007 31' Classic
Gulf Breeze , Florida
Join Date: Jan 2016
Posts: 490
Images: 1
My sub woofer makes a low hum that can be annoying. Any ideas how to remedy this?
trumpetguy is offline   Reply With Quote
Old 03-01-2017, 11:00 AM   #9
Rivet Master
 
wulfraat's Avatar
 
2017 30' International
Broomfield , Colorado
Join Date: Apr 2009
Posts: 2,602
Images: 1
Quote:
Originally Posted by trumpetguy View Post
My sub woofer makes a low hum that can be annoying. Any ideas how to remedy this?
Yes, you need to install a ground loop isolator on the line. Common issue. $10 fix.

https://www.crutchfield.com/p_127SNI...c&awug=9019609
wulfraat is offline   Reply With Quote
Old 03-01-2017, 01:38 PM   #10
4 Rivet Member
 
2007 31' Classic
Gulf Breeze , Florida
Join Date: Jan 2016
Posts: 490
Images: 1
Thanks. So much knowledge on these forums.
trumpetguy is offline   Reply With Quote
Old 03-01-2017, 01:43 PM   #11
4 Rivet Member
 
2007 31' Classic
Gulf Breeze , Florida
Join Date: Jan 2016
Posts: 490
Images: 1
I ordered that part just now. It looks plug and play easy.
trumpetguy is offline   Reply With Quote
Old 03-05-2017, 07:30 AM   #12
3 Rivet Member
 
TRIPPPIN's Avatar
 
2012 25' FB Eddie Bauer
Southwestern Ontario , Ontario Canada
Join Date: Mar 2007
Posts: 241
Images: 6
Send a message via MSN to TRIPPPIN Send a message via Yahoo to TRIPPPIN
I gave up. The Sony is either not capable of sending a signal to the subwoofer for Aux in, or it is defective. I just ordered a 110 volt ac Yamaha 5.1 surround system with speakers that I will use instead of the Sony. It will be separated completely and I will leave the Sony and the factory speakers in place so their won't be holes to fill. It could be used occasionally for boon-docking. The most difficult part for the 5.1 system is running all new speaker wires. I ran the wires so the center speakers will be above the TV, front left and right speakers will be wall mounted midships on both sides of the trailer pointed to the listening area in the rear and the rear speakers under the cabinet pointing forward.
TRIPPPIN is offline   Reply With Quote
Old 03-05-2017, 08:30 AM   #13
Rivet Master
 
switz's Avatar

 
2014 31' Classic
2015 23' International
2013 25' FB International
Apache Junction , Arizona
Join Date: Sep 2012
Posts: 5,622
Images: 8
Also consider putting a on/off switch in the 12Vdc power to the sub-woofer. It is powered all the time which will drain the battery when in storage.
__________________
WBCCI Life Member 5123, AIR 70341, 4CU, WD9EMC

TV - 2012 Dodge 2500 4x4 Cummins HO, automatic, Centramatics, Kelderman level ride airbag suspension, bed shell

2014 31' Classic model 30 twin beds, 50 amp service, 900 watt solar system, Centramatics, Tuson TPMS, disc brakes, 16" tires & wheels
switz is offline   Reply With Quote
Old 03-05-2017, 09:05 AM   #14
Rivet Master
 
wulfraat's Avatar
 
2017 30' International
Broomfield , Colorado
Join Date: Apr 2009
Posts: 2,602
Images: 1
Subwoofer works except for TV sound - help

Quote:
Originally Posted by switz View Post
Also consider putting a on/off switch in the 12Vdc power to the sub-woofer. It is powered all the time which will drain the battery when in storage.


Although the subwoofer has power available to it 24/7 via hot and ground lines, it has a 3rd blue/white signaling line (low voltage remote turn on trigger) that runs from the sub to the Sony head unit. This line acts as an on/off switch for the sub based on the state of the head unit.

If the Sony head unit is off, no voltage is sent to the sub on the blue/white control wire and the sub remains powered off.

When you turn on the head unit it energizes the remote sub line and the sub turns on.

So in short, the sub should only be on and drawing power when the head unit is turned on.
wulfraat is offline   Reply With Quote
Old 03-22-2017, 01:14 PM   #15
4 Rivet Member
 
2016 30' Flying Cloud
Oviedo , Florida
Join Date: Jan 2005
Posts: 264
Images: 1
The analog audio out from many of the TV's (which AS uses to feed back to the AUX input of the head unit) has the bass filtered out so as to not overload the built in speakers in the TV. I had a similar issue after upgrading my subwoofer (not "no bass" but very weak bass) and ended up using a small, USB powered D/A converter connected to the TV optical digital output (you need to select "External Speakers" in the TV audio menu). That restored full bandwidth sound.

Might want to check that.
__________________
Keith & Barb
2016 30' Flying Cloud
2016 Ram 2500 diesel
Southeastern Camping Unit, WBCCI #1675
khollister is offline   Reply With Quote
Old 03-23-2017, 07:52 AM   #16
3 Rivet Member
 
TRIPPPIN's Avatar
 
2012 25' FB Eddie Bauer
Southwestern Ontario , Ontario Canada
Join Date: Mar 2007
Posts: 241
Images: 6
Send a message via MSN to TRIPPPIN Send a message via Yahoo to TRIPPPIN
Thanks for that idea. I gave up and installed a Yamaha YHT 1810 residential 5.1 system with HDMI switching, speakers and subwoofer. I didn't like the Airstream speakers or their placement in the overhead. The new matching speakers are small and directed to the listening area. Running the wires was a PIA. It was worth it now it sounds awesome! I left the sony in place but wont use it unless we don't have shore power. I removed the 12v sub and wouldn't have used it anyway on battery power.
TRIPPPIN is offline   Reply With Quote
Old 11-13-2018, 05:06 PM   #17
2 Rivet Member
 
2004 25' International CCD
2012 25' International
slaton , Texas
Join Date: Dec 2011
Posts: 42
sub woofer gone south

This woofer is in a 2012 International, 25' Serenity.. I have been searching the forums on sub -woofers and see quite a few major projects have been done with audio , video , etc. very impressive!!!! you guys are great!!! i'm not that technical but would like to ask some advice from some of you pros. Problem is that I found that the red RCA pin was broken off in the sub-woofer female . I cannot get it out, and have pretty much destroyed the female recept in trying. So, probably cannot get the current woofer fixed. does anyone have any suggestions on a good replacement? say $100 range. something that is easy to adapt to the current wiring and not too hard for a novice. I guess 1st step is getting the wiring diagram from Airstream (woofer is the Collins IC100, standard from factory ) Is wattage an issue? does the woofer work with all audio stuff, ie. TV, radio, CD's, etc.? Also probably need to replace that radio that I cannot operate!!!!!!!!!!!!! suggestions......

do I even need a sub-woofer? never noticed it was broken till I removed the bench seat to make room for my recliner.
thanks in advance for your much needed advice
gnowlin is offline   Reply With Quote
Old 11-14-2018, 08:11 AM   #18
3 Rivet Member
 
TRIPPPIN's Avatar
 
2012 25' FB Eddie Bauer
Southwestern Ontario , Ontario Canada
Join Date: Mar 2007
Posts: 241
Images: 6
Send a message via MSN to TRIPPPIN Send a message via Yahoo to TRIPPPIN
You don't need a sub woofer. If you are happy with the sound quality leave it disconnected. If you want to replace it with a cheap alternative Bazooka has one just over $100 that for some people works with the existing wire. The small 12 volt wire Airstream supplies is your biggest limiting factor. When it comes to powered subs you need heavy guage wire to meet the wattage requirements.
TRIPPPIN is offline   Reply With Quote
Old 11-15-2018, 10:16 AM   #19
2 Rivet Member
 
2004 25' International CCD
2012 25' International
slaton , Texas
Join Date: Dec 2011
Posts: 42
Quote:
Originally Posted by TRIPPPIN View Post
You don't need a sub woofer. If you are happy with the sound quality leave it disconnected. If you want to replace it with a cheap alternative Bazooka has one just over $100 that for some people works with the existing wire. The small 12 volt wire Airstream supplies is your biggest limiting factor. When it comes to powered subs you need heavy guage wire to meet the wattage requirements.
Thank you for your input. All help is appreciated
gnowlin is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
for the pet who has everything - except an Airstream bake315 The Pet Forum 2 12-17-2019 08:17 PM
Keep Right Except To Pass?? Mackhopp Community Polls 42 04-13-2010 03:20 PM
Buzzing sound from sound system, walking on floor makes it stop. foqus Electrical - Systems, Generators, Batteries & Solar 9 08-24-2009 09:22 PM
All ext. lights working except right brake/turn grizz814 Electrical - Systems, Generators, Batteries & Solar 3 10-18-2006 01:27 PM
its thursday and to 2airishuman is my favorite goof except the others... Boondocker Off Topic Forum 9 02-17-2006 01:22 PM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 01:39 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.