Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-19-2017, 10:35 PM   #1
1 Rivet Member
 
1970 27' Overlander
Houston , Texas
Join Date: Aug 2014
Posts: 15
Pioneer Radio Install - Stereo not turning on :(

Hi Guys!

I am trying to install a new Pioneer DEH X3910BT car stereo in my 1970 Airstream Overlander. The old radio had a 12v live wire [red] and a ground wire [white]. I've tested them, and they're reading a steady 11.8 volts. But for some reason I cannot seem to get my new Pioneer radio to turn on. The stereo came with a cradle of wires, and apparently, from what I've read online, the yellow memory wire, the red power wire and the blue antenna wire need to be bundled together and connected to my live wire. So that's what I've done, and I've also connected the black ground wire to the old radio ground wire. Try as a might, I cannot get the stereo to power on...am I doing anything wrong? Any and all advice would be appreciated! Thanks guys,

Andre
__________________

aboudre1 is offline   Reply With Quote
Old 01-20-2017, 12:29 AM   #2
CRH
Rivet Master
 
1995 25' Excella
xxxxx , xxxxxx
Join Date: Apr 2015
Posts: 1,720
You don't need the blue wire. It is for a power antenna.


Perhaps you simply have a bad unit. Try connecting the power and ground directly to a battery.
CRH is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pioneer Radio / Speaker Static Landrum Electronics & Connectivity 2 09-09-2014 02:23 PM
2014 25FB FC Pioneer radio power off? btlayton 2009-2015 Flying Cloud 44 07-29-2014 10:52 AM
Pioneer Radio Woes - Can I get your thoughts? leahrumbarge Electrical - Systems, Generators, Batteries & Solar 19 06-12-2014 05:05 PM
Pioneer radio---no AM/FM reception. Sjcjr Electronics & Connectivity 5 03-30-2014 04:26 PM
anyone have pics of a custom stereo install? including subwoofer in old stream streamahead Audio, Video & TV 10 10-13-2010 09:35 PM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 12:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.