Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-22-2018, 12:02 PM   #1
1 Rivet Member
 
1968 24' Tradewind
Stilwell , Kansas
Join Date: Jan 2017
Posts: 12
Running/ Marker Light Troubleshooting

I have a 68 Tradewind. All of the running/marker lights work fine except for two. One on the front and one on the side. I have doublechecked the bulbs and they are good. There appears to be continuity between the power wire and the bulb fixture. The bulbs will not turn on however. Are there any troubleshooting tricks to finding the problem or is it easier to just replace the entire light assembly? I am surprised that there are no threads that I can find here detailing how to troubleshoot an individual running/marker light not working. Surely I am not the first to deal with this problem.
Thanks.
Stilwellian is offline   Reply With Quote
Old 07-22-2018, 12:29 PM   #2
Rivet Master
 
overlander63's Avatar

 
1993 21' Sovereign
Colfax , North Carolina
Join Date: Jun 2003
Posts: 21,236
Check for corrosion/rust on the power contact in the base, and the spring that keeps the contact pressed against the bottom of the bulb is still in good shape.
You did check to make sure the assembly is grounded, right?
__________________
Terry
overlander63 is offline   Reply With Quote
Old 07-23-2018, 09:01 AM   #3
1 Rivet Member
 
1968 24' Tradewind
Stilwell , Kansas
Join Date: Jan 2017
Posts: 12
I checked for voltage between the hot lead and the bulb receptacle..... it was soooo low compared to a check between the hot lead and the ground source as in the trailer outer skin. To troubleshoot, I ran a simple patch wire between the grounding rivet mount for the lamp base and the bulb receptacle and voila....let there be light! The connection between the ground wire and the ground source must be corroded. A little touch of solder and a little patch wire will fix the issue without having to replace the entire assembly for now. Thanks for reminding me about the ground test. I was just checking continuity. Booyah!
Stilwellian is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1968 Overlander Running Light (Marker Light) Wiring Diagram or Routing Information Bunkroom Lights - Interior & Exterior 2 08-04-2018 01:16 PM
Marker/running light issue, any help appreciated! Bella123 Land Yacht/Legacy Motorhomes 5 12-13-2016 06:18 PM
troubleshooting fantastic fan that stopped running bonginator Furnaces, Heaters, Fireplaces & Air Conditioning 2 08-05-2014 03:42 PM
Amber LED Marker running/turn light Dan@LED4RV Commercial Listings 0 07-19-2013 02:20 PM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 03:18 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.