Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-18-2017, 05:21 AM   #1
4 Rivet Member
 
2006 19' Safari SE
Hayes , Virginia
Join Date: Dec 2011
Posts: 345
Water heater red light

My water heater on my 2006 19’ Bambi, the red light remains on. Turn on gas, turn on red light switch, and she stays on on. I know this has been asked before but I cannot find it. She was working great until our last camping trip, then this problem. Appreciate any help. Thank you. Tom
mocus is offline   Reply With Quote
Old 11-18-2017, 05:28 AM   #2
Rivet Master
 
Lily&Me's Avatar

 
2007 Interstate
Normal , Illinois
Join Date: Jan 2009
Posts: 16,125
Is your water heater lighting, or is it just the red light staying on that bothers you?

Maggie
__________________
🏡 🚐 Cherish and appreciate those you love. This moment could be your last.🌹🐚
Lily&Me is offline   Reply With Quote
Old 11-18-2017, 05:40 AM   #3
4 Rivet Member
 
VaTravelers's Avatar
 
2017 28' International
Virginia Beach , Virginia
Join Date: Jul 2016
Posts: 397
Images: 1
I just went through this with my 2017 Serenity. Turns out it was the circuit board. It was not generating enough power to spark the igniter. Easily replaced.
VaTravelers is offline   Reply With Quote
Old 11-18-2017, 06:17 AM   #4
Moderator
 
moosetags's Avatar

 
2015 25' FB Flying Cloud
2012 23' FB Flying Cloud
2005 25' Safari
Santa Rosa Beach , Florida
Join Date: Jul 2006
Posts: 12,104
Images: 5
If the red light on the water heater switch stays on, it means that the there is a problem, and the unit is not lighting. Many times it is a problem with the electrics. The first thing that I would try is removing the bayonet connectors and cleaning the contacts. You can do this by pushing them on and off several times.

Brian
__________________
SuEllyn & Brian McCabe
WBCCI #3628 -- AIR #14872 -- TAC #FL-7
2015 FC 25' FB (Lucy) with HAHA
2020 Silverado 2500 (Vivian)
moosetags is online now   Reply With Quote
Old 11-18-2017, 08:53 AM   #5
4 Rivet Member
 
2006 19' Safari SE
Hayes , Virginia
Join Date: Dec 2011
Posts: 345
Water heater redlight

Guess I left one important statement out...The light stays on, she ignites and sounds good, but....ya might get a quart of warm water and that is it....I have a good blue flame...
mocus is offline   Reply With Quote
Old 11-18-2017, 08:58 AM   #6
Rivet Master
 
Al and Missy's Avatar

 
2002 30' Classic S/O
Melbourne Beach , Florida
Join Date: Nov 2013
Posts: 4,149
If you haven't changed anything since the time it worked, it may be the overtemp sensor. Are you sure the air has been flushed out of the heater?

Al
__________________
“You cannot reason someone out of a position they have not been reasoned into"
Al, K5TAN and Missy, N4RGO WBCCI 1322
2002 Classic 30 Slideout -S/OS #004
2013 Dodge 2500 Laramie 4x4 Megacab Cummins
Al and Missy is offline   Reply With Quote
Old 11-18-2017, 08:58 AM   #7
Rivet Master
 
Currently Looking...
Gainesville , Florida
Join Date: Jul 2005
Posts: 7,059
Blog Entries: 2
It's waterlogged. It needs the air bubble renewed.
xrvr is offline   Reply With Quote
Old 11-18-2017, 09:10 AM   #8
Rivet Master
 
Lily&Me's Avatar

 
2007 Interstate
Normal , Illinois
Join Date: Jan 2009
Posts: 16,125
Quote:
Originally Posted by mocus View Post
Guess I left one important statement out...The light stays on, she ignites and sounds good, but....ya might get a quart of warm water and that is it....I have a good blue flame...
That’s good information to provide, gives the situation a whole new look.

Maggie
__________________
🏡 🚐 Cherish and appreciate those you love. This moment could be your last.🌹🐚
Lily&Me is offline   Reply With Quote
Old 11-18-2017, 09:28 AM   #9
4 Rivet Member
 
2006 19' Safari SE
Hayes , Virginia
Join Date: Dec 2011
Posts: 345
Just cleaned contacts/connectors with contacteen(sp), slid them in/out, flipped switch and still getting picture-perfect flame and light stays on. Everything gas is working except red light on heater....
mocus is offline   Reply With Quote
Old 11-18-2017, 09:38 AM   #10
4 Rivet Member
 
2006 19' Safari SE
Hayes , Virginia
Join Date: Dec 2011
Posts: 345
Quote:
Originally Posted by Al and Missy View Post
If you haven't changed anything since the time it worked, it may be the overtemp sensor. Are you sure the air has been flushed out of the heater?


Al
Is the over temp sensor the round thermostat? I can change that easy enough
mocus is offline   Reply With Quote
Old 11-18-2017, 09:39 AM   #11
Rivet Master
 
Mollysdad's Avatar

 
2017 26' Flying Cloud
Tampa , Florida
Join Date: Feb 2017
Posts: 5,030
Blog Entries: 1
Quote:
Originally Posted by mocus View Post
Just cleaned contacts/connectors with contacteen(sp), slid them in/out, flipped switch and still getting picture-perfect flame and light stays on. Everything gas is working except red light on heater....
That would make me worry there's no water in the tank.
Mollysdad is offline   Reply With Quote
Old 11-18-2017, 11:12 AM   #12
4 Rivet Member
 
2006 19' Safari SE
Hayes , Virginia
Join Date: Dec 2011
Posts: 345
I just drained it yesterday when I was monkeying around with it. And like I say, I turned on the hot water valve and let it run just to make sure.
mocus is offline   Reply With Quote
Old 11-18-2017, 11:40 AM   #13
Rivet Master
 
waninae39's Avatar

 
2017 22' Sport
NCR , Ontario
Join Date: Feb 2017
Posts: 2,220
same issue

it was a bad circuit board.

i'm now waiting 7 weeks to get a wuarantee refund from the water heater OEM
waninae39 is offline   Reply With Quote
Old 11-18-2017, 11:42 AM   #14
Rivet Master
 
Al and Missy's Avatar

 
2002 30' Classic S/O
Melbourne Beach , Florida
Join Date: Nov 2013
Posts: 4,149
Quote:
Originally Posted by mocus View Post
Is the over temp sensor the round thermostat? I can change that easy enough
If yours is like mine, there are two, one is the normal thermostat, the other is the emergency cutoff.

Without knowing your particular heater, I can't say. I bought a service kit on Amazon and it had both.

You may find this useful:
http://manuals.adventurerv.net/Atwoo...nuals-2007.pdf

Al
__________________
“You cannot reason someone out of a position they have not been reasoned into"
Al, K5TAN and Missy, N4RGO WBCCI 1322
2002 Classic 30 Slideout -S/OS #004
2013 Dodge 2500 Laramie 4x4 Megacab Cummins
Al and Missy is offline   Reply With Quote
Old 11-18-2017, 04:56 PM   #15
Rivet Master
 
1996 25' Excella
Tillsonburg , Ontario
Join Date: Aug 2014
Posts: 1,123
Over temp T'stat cycles on and off, unless they have changed the operation; it does not open and stay that way. You just get really hot water. The operating and over temp T'stats are wired in series so the controller doen't see the difference at least on older As models
OP discovered what I thought was the problem....faulty board, but at least he got hot water. Occasionally a heater board problem is just a bad ground...something the owner's manual says to check be fore replacing the board.
JCW
JCWDCW is offline   Reply With Quote
Old 11-19-2017, 06:42 AM   #16
4 Rivet Member
 
2006 19' Safari SE
Hayes , Virginia
Join Date: Dec 2011
Posts: 345
Red face

Thank you, mine is just like that. Camper sales up the road so, will get those two things in the morning. Thanks all for the assist........
mocus is offline   Reply With Quote
Old 03-04-2019, 11:16 PM   #17
1 Rivet Member
 
Cayenne-airs's Avatar
 
2016 23' Flying Cloud
Eugene , Oregon
Join Date: Mar 2019
Posts: 9
Hi-I don't think this issue is covered. I recently got the trailer, never used the gas heating option. When leaving the electric heat option on, it heats the water and then the red light comes on? then I turn off the electric water heater button- after a while I turn it on again, heats the water and red light comes on and stays on.

ideas? thanks
Cayenne-airs is offline   Reply With Quote
Old 03-05-2019, 01:04 PM   #18
Rivet Master
 
billrector's Avatar
 
2017 27' Flying Cloud
Fort Worth , Texas
Join Date: Sep 2017
Posts: 739
Quote:
Originally Posted by Cayenne-airs View Post
Hi-I don't think this issue is covered. I recently got the trailer, never used the gas heating option. When leaving the electric heat option on, it heats the water and then the red light comes on? then I turn off the electric water heater button- after a while I turn it on again, heats the water and red light comes on and stays on.



ideas? thanks


The red light is an error. That light is not suppose to come on.
billrector is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water Heater Red Light On The Colonel Water Heaters, Filters & Pumps 35 04-28-2018 09:36 AM
Water Heater Red Light on in Electric Mode Tom Larson Water Heaters, Filters & Pumps 3 12-05-2016 05:32 PM
red light on water heater aeriqua Water Heaters, Filters & Pumps 12 04-24-2015 02:36 PM
Red! Red! Red! Can Anyone Tell Me What This is About Now? Fly at Night Batteries, Univolts, Converters & Inverters 23 11-06-2011 01:18 PM
Atwood Heater - Red light stays on! Moonstruck Furnaces, Heaters, Fireplaces & Air Conditioning 4 10-06-2009 03:29 PM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 01:10 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.