RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-01-2020, 10:43 AM   #1
New Member
 
2021 33FB Classic
OVERLAND PARK , KS
Join Date: Nov 2020
Posts: 1
Jstone

Hello Gentlefolks of the Airstream World. I've a minor issue. I say it is minor because I can survive a short time without "Hot Water". However, after having taken possession less than a week ago and after waiting months to have my Classic 33' built I need a hot shower........
Is there something I am missing? the water will actually get warm, but not hot. My Glycol temperature has been up to 168 and the water temperature as high, but no hot shower. The Galley sink gets a short burst of hot then quickly turns to barely warm.
Any help or suggestions would be greatly appreciated............
JSTONE is offline   Reply With Quote
Old 11-01-2020, 10:50 AM   #2
Rivet Master
 
overlander63's Avatar
 
1993 21' Sovereign
Colfax , North Carolina
Join Date: Jun 2003
Posts: 21,254
Sounds like the bypass valve on the Alde is turned the wrong way.
__________________
Terry
overlander63 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 02:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.