Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-10-2016, 02:40 PM   #1
PSU1981
 
PSU1981's Avatar
 
2015 27' Flying Cloud
Conroe , Texas
Join Date: May 2015
Posts: 278
Lights Not working in hood over stove

While camping this past weekend both lights quit working over the stove? Find it kinda hard both burned out same time. Any ideas?

PSU1981
2015 27FB Flying Cloud
Spring, Tx
PSU1981 is offline   Reply With Quote
Old 02-10-2016, 02:49 PM   #2
Rivet Master
 
2015 30' Classic
Pleasanton , California
Join Date: Jan 2015
Posts: 745
Did the fan stop working too?

I had an issue where the plastic slide piece that you move to turn on and off the lights separated from the actual switch causing the same symptoms. I simply had the dealer repair it.
__________________
Al, K6IV
2015 30' Classic, "Chez Nu"
2014 RAM 2500 w/Cummins Diesel
ProPride Hitch, 400 W Solar
alano is offline   Reply With Quote
Old 02-10-2016, 02:50 PM   #3
Rivet Master

 
2007 22' International CCD
Corona , California
Join Date: Jul 2013
Posts: 9,043
Actually it's possible both bulbs went out at the same time. Or the switch went out

First thing to check: Still have power to the fan in the hood?

Then check bulbs with a VOM, then use VOM to look for power on the bulb sockets.

That should get you there.


Sent from my pocket Internet using Airstream Forums
__________________
Rich, KE4GNK/AE, Overkill Engineering Dept.
'The Silver HamShack' ('07 International 22FB CCD 75th Anniversary)
Multiple Yaesu Ham Radios inside and many antennae sprouting from roof, ProPride hitch, Prodigy P2 controller.
2012 shortbed CrewMax 4x4 Toyota Tacoma TV with more antennae on it.
rmkrum is offline   Reply With Quote
Old 02-11-2016, 08:26 AM   #4
PSU1981
 
PSU1981's Avatar
 
2015 27' Flying Cloud
Conroe , Texas
Join Date: May 2015
Posts: 278
Fan still works
PSU1981 is offline   Reply With Quote
Old 02-11-2016, 08:28 AM   #5
PSU1981
 
PSU1981's Avatar
 
2015 27' Flying Cloud
Conroe , Texas
Join Date: May 2015
Posts: 278
What is a VOM - volt meter?

How do I use it?
PSU1981 is offline   Reply With Quote
Old 02-11-2016, 08:40 AM   #6
Rivet Master
 
2015 30' Classic
Pleasanton , California
Join Date: Jan 2015
Posts: 745
VOM stands for Volt Ohm Meter. Select DC volts and insert each probe into each lamp receptacle. If you measure approximately 12 V then you know your bulbs are bad. If you measure 0 V, then you should take your 2015 back to the dealer for service.
__________________
Al, K6IV
2015 30' Classic, "Chez Nu"
2014 RAM 2500 w/Cummins Diesel
ProPride Hitch, 400 W Solar
alano is offline   Reply With Quote
Old 02-11-2016, 09:46 AM   #7
PSU1981
 
PSU1981's Avatar
 
2015 27' Flying Cloud
Conroe , Texas
Join Date: May 2015
Posts: 278
Ok - thanks!!!
PSU1981 is offline   Reply With Quote
Old 02-11-2016, 09:59 AM   #8
Rivet Master
 
AnnArborBob's Avatar
 
2014 27' FB Eddie Bauer
Chelsea , Michigan
Join Date: May 2010
Posts: 1,792
Images: 12
There is also a separate inline fuse in the fan assembly. Not sure it if protects only the lights or the fan as well but you might want to look at that before you get to the more complicated diagnostics.
__________________
Bob Martel
WBCCI# 5766
AnnArborBob is offline   Reply With Quote
Old 02-11-2016, 10:04 AM   #9
Rivet Master
 
AnnArborBob's Avatar
 
2014 27' FB Eddie Bauer
Chelsea , Michigan
Join Date: May 2010
Posts: 1,792
Images: 12
Range Exhaust fuse

The fuse can be accessed under the grease screen. It's in that little black box at the back of the compartment. It's behind the small round black cover. As I said earlier, I'm not sure if the fuse protects the lights only or the fan as well. Since your fan works, this may not be the culprit but it's easy enough to check.
Attached Thumbnails
Click image for larger version

Name:	IMG_4006.jpg
Views:	109
Size:	198.9 KB
ID:	257153  
__________________
Bob Martel
WBCCI# 5766
AnnArborBob is offline   Reply With Quote
Old 02-11-2016, 10:23 AM   #10
Rivet Master
 
2015 30' Classic
Pleasanton , California
Join Date: Jan 2015
Posts: 745
If you do find out your bulbs are bad, consider changing them with LED replacements from LED4RV.com. Seems quite wasteful that AS didn't fit these with LEDs as well.
__________________
Al, K6IV
2015 30' Classic, "Chez Nu"
2014 RAM 2500 w/Cummins Diesel
ProPride Hitch, 400 W Solar
alano is offline   Reply With Quote
Old 02-11-2016, 10:38 AM   #11
1 Rivet Member
 
Join Date: Jul 2015
Posts: 16
PSU1981, Your AS is much newer than mine so what I have to suggest may be worth nothing. I had the same problem in my '72 Sovereign. When I discovered that the light over my sink stopped working and bulb replacement didn't solve the problem, I assumed there was a broken wire somewhere inside the interior wall of the unit. Not wanting to trace that out, I got the idea of splicing into the wire for the exhaust fan which did work. That solved my problem although it may not be the solution for yours. Anyway, for what it is worth......
Philip498 is offline   Reply With Quote
Old 02-11-2016, 10:57 AM   #12
Rivet Master
 
interstateflyer's Avatar
 
2017 25' International
Currently Looking...
Currently Looking...
Los Osos , California
Join Date: Jun 2004
Posts: 916
Images: 7
Our 2014 International's fan was DOA from the factory. They'd forgotten to install the fuse.
__________________
2017 Airstream International Serenity 25FB
2016 RAM 2500 Crew Cab Cummins 6.7 Diesel
interstateflyer is offline   Reply With Quote
Old 02-11-2016, 11:56 AM   #13
shadedsilver
 
2014 27' FB International
Bisbee , Arizona
Join Date: Feb 2015
Posts: 13
Images: 6
Both our hood lights burned out at same time in our 2014. The dealer replaced them under warranty.
shadedsilver is offline   Reply With Quote
Old 02-11-2016, 01:58 PM   #14
PSU1981
 
PSU1981's Avatar
 
2015 27' Flying Cloud
Conroe , Texas
Join Date: May 2015
Posts: 278
Thanks everyone. Does anyone know if the inline fuse is for both the fan & the lights?
PSU1981 is offline   Reply With Quote
Old 02-11-2016, 02:44 PM   #15
Rivet Master
 
2015 30' Classic
Pleasanton , California
Join Date: Jan 2015
Posts: 745
Looks so from the schematic provided by AnnArborBob!

Another thing you can do is to pop down to Home Depot/Lowes and see if a replacement bulb works
__________________
Al, K6IV
2015 30' Classic, "Chez Nu"
2014 RAM 2500 w/Cummins Diesel
ProPride Hitch, 400 W Solar
alano is offline   Reply With Quote
Old 02-11-2016, 11:04 PM   #16
2 Rivet Member
 
2022 20' Basecamp
2013 23' FB Flying Cloud
2001 19' Bambi
Fort Jones , California
Join Date: Nov 2009
Posts: 31
This is a "slow burn fuse" so when you replace it make sure that is what you get (available at radio shack). I have had this issue in my 2013 23'FB generally if I am cooking something on the range have the lights on and run the fan....probably exacerbated by the heat from the range. Lights just quit. One way to avoid this is not to run fan and lights simultaneously. Make sure you get a slow burn fuse to replace the burned out one.
Jack West is offline   Reply With Quote
Old 02-11-2016, 11:08 PM   #17
2 Rivet Member
 
2022 20' Basecamp
2013 23' FB Flying Cloud
2001 19' Bambi
Fort Jones , California
Join Date: Nov 2009
Posts: 31
I believe the fuse is just for the lights. Replace wit a slow burn type fuse.
Jack West is offline   Reply With Quote
Old 02-12-2016, 07:55 AM   #18
PSU1981
 
PSU1981's Avatar
 
2015 27' Flying Cloud
Conroe , Texas
Join Date: May 2015
Posts: 278
Since there are very few Radio Shacks around anymore - where else may I find the slow burn fuse & what are the specs I am looking for with the fuse?

Thanks again!!!
PSU1981 is offline   Reply With Quote
Old 02-12-2016, 12:53 PM   #19
Rivet Master

 
2007 22' International CCD
Corona , California
Join Date: Jul 2013
Posts: 9,043
Look for a 'slow blow' fuse at an auto supply store, a home center, or one of the few Radio Shacks left. Yo may be able to get them online as well.


Sent from my pocket Internet using Airstream Forums
__________________
Rich, KE4GNK/AE, Overkill Engineering Dept.
'The Silver HamShack' ('07 International 22FB CCD 75th Anniversary)
Multiple Yaesu Ham Radios inside and many antennae sprouting from roof, ProPride hitch, Prodigy P2 controller.
2012 shortbed CrewMax 4x4 Toyota Tacoma TV with more antennae on it.
rmkrum is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why not LED lights in the stove hood? LivLoveLaugh Lights - Interior & Exterior 34 08-13-2017 09:39 AM
Stove Hood Lights Burned Out Ljsydney Stoves, Ovens & Microwaves 2 04-14-2015 09:32 AM
Over the stove vent and light hood DJW General Interior Topics 1 06-04-2014 08:46 AM
Range hood fan not working Natestravels Stoves, Ovens & Microwaves 5 03-22-2014 01:03 PM
Hood/hood lights and water heater stopped working!!! Thomas_G Electrical - Systems, Generators, Batteries & Solar 1 06-17-2013 12:49 PM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 02:08 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.