Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-16-2022, 10:29 AM   #1
New Member
 
2016 27' Flying Cloud
2016 Interstate Lounge Ext
San diego , California
Join Date: Jan 2022
Posts: 4
Furnace and blower not working

I have a 2016 27 Flying Cloud signature that I just bought. The furnace and blower are not working. Does anyone have any suggestions on how I can troubleshoot.
Rstellers is offline   Reply With Quote
Old 01-16-2022, 10:39 AM   #2
3 Rivet Member
 
2020 19' Caravel
Ammon , Idaho
Join Date: Oct 2017
Posts: 186
I would start by verifying power is available.
Is the thermostat working/in the correct mode?
Find the manual and check voltage.
Does the thermostat start the AC unit?
OutdoorIdaho is offline   Reply With Quote
Old 01-16-2022, 10:46 AM   #3
New Member
 
2016 27' Flying Cloud
2016 Interstate Lounge Ext
San diego , California
Join Date: Jan 2022
Posts: 4
Thermostat is working. Voltage is at 12.5. I’ll check the AC and let you know.
Rstellers is offline   Reply With Quote
Old 01-16-2022, 02:11 PM   #4
New Member
 
2016 27' Flying Cloud
2016 Interstate Lounge Ext
San diego , California
Join Date: Jan 2022
Posts: 4
AC is working. I’ll check the voltage with a multi meter at the furnace panel. Checked all the DC circuits and they are good.
Let me know if you have any other thoughts.
Rstellers is offline   Reply With Quote
Old 01-16-2022, 02:20 PM   #5
Site Team
 
GCinSC2's Avatar

 
2007 30' Classic S/O
Somewhere , South Carolina
Join Date: Apr 2010
Posts: 5,770
Rstellers,

A go to resource for me anyway the document library at My RV Works has several service manuals for Atwood furnaces. https://myrvworks.com/wp-content/upl...ting-Guide.pdf

Darren at My RV works has complied a gold mine of manuals.

The furnace has a sequence of events to start it up and they are frequently very diagnosable just by reviewing against what step does the furnace stop at or the sound it makes etc.

If you can post the model info that can help a bit too. And have you found the CHECK light on the board yet?

Keep the info coming and take a look at those service manuals and download.

Does the stove light up?

Gary
__________________
S/OS #001 2005 Dodge Ram 2500 5.9L 6 Speed
16" Michelins, Hi Spec Wheels, Max Brake, Dexter 4 Piston Disc Brakes, Carslile Actuator, Equal-I-Zer, Dill TPMS. Campfire cook. BMV-712. DEMCO 21K Lb Cast Iron coupler
GCinSC2 is offline   Reply With Quote
Old 01-16-2022, 02:45 PM   #6
New Member
 
2016 27' Flying Cloud
2016 Interstate Lounge Ext
San diego , California
Join Date: Jan 2022
Posts: 4
Awesome. I’ll check the manual and post the model asap.
Yes the stove does work and I lit it to bleed any air from the line.

I don’t hear any sounds at all, no ignition or blower whatsoever, so I think it may be electrical.
Rstellers is offline   Reply With Quote
Old 01-16-2022, 07:38 PM   #7
Site Team
 
richard5933's Avatar

 
1994 25' Excella
Waukesha , Wisconsin
Join Date: Sep 2020
Posts: 2,222
Images: 4
Do you have a manual thermostat on this? If so, have you checked the slightly hidden on/off switch tucked away on it? Confounded me for a while till I discovered that.
__________________
Richard
11018
1994 Excella 25 Follow the build on Gertie!
1999 Suburban LS 2500 w/7.4L V8
1974 GMC 4108a - Custom Coach Land Cruiser (Sold)
richard5933 is offline   Reply With Quote
Old 01-17-2022, 09:30 AM   #8
3 Rivet Member
 
2017 27' International
Currently Looking...
Antes Fort , Pennsylvania
Join Date: Jul 2016
Posts: 154
I've been fooled a few times by a working furnace because the interior temperature was already what I wanted with the furnace on. Duh! Also, it can take almost a minute sometimes for the furnace to start. Don't know why but it does that.
alphamale49 is offline   Reply With Quote
Old 01-17-2022, 09:50 AM   #9
Rivet Master
 
CruizinDux's Avatar
 
2014 20' Flying Cloud
Washington , Missouri
Join Date: Mar 2014
Posts: 2,377
It's a long shot but check the thermostat manual for a hard re-reboot.

I've had this solve a strange idiosyncrasy in mine. After not returning the fan speed to auto form a temp setting on low, my AC would turn on a send cold air into the trailer simultaneously with the intended propane furnace firing. Returning the fan speed back to auto did not solve the dual firing, but the hard boot of the stat did. Go figure
__________________
WashMoBob
CruizinDux is offline   Reply With Quote
Old 01-17-2022, 07:12 PM   #10
:SPACE A" S/O 11 Air19745
 
guskmg's Avatar
 
2006 34' Classic S/O
Fort Worth , Texas
Join Date: Feb 2007
Posts: 1,696
You need to answer a few questions:
Does anything happen when you turn on the furnace with temp set above the inside of the trailer temp? Could be a bad thermostat.
Does the furnace fan start then shutdown? Faulty sail switch.
Is your house voltage above 10.5 volts? I takes more voltage to open the gas valve.
Do you have propane and is it on? Will a stove burner light?
Is the switch under the outside cover on? It is a simple on-off switch.
If all the above are OK, then I would suspect tha circuit board is faulty.
you might consider calling a mobile tech that has experience with your heater brand.
guskmg
guskmg is offline   Reply With Quote
Old 01-17-2022, 07:56 PM   #11
Rivet Master
 
CruizinDux's Avatar
 
2014 20' Flying Cloud
Washington , Missouri
Join Date: Mar 2014
Posts: 2,377
Great advice from guskmg.

Here are a couple of sail switch....error light threads

https://www.airforums.com/forums/f28...se-183642.html

https://www.airforums.com/forums/f54...127845-82.html
Post 1577 & 1623

Good luck
__________________
WashMoBob
CruizinDux is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Front interior light not working, middle and rear working? jonnyo Lights - Interior & Exterior 5 01-06-2020 11:25 AM
Electic Jack not working - fuse good - manual not working ryandanz Jacks, Stabilizers, Lifting and Leveling 20 04-24-2016 10:04 AM
Dometic heater zone 2 not working on furnace, not hot on HP sfgirl General Repair Forum 13 11-06-2015 01:21 PM
Burner and Blower Won't Start For Furnace heyhello Furnaces, Heaters, Fireplaces & Air Conditioning 14 05-31-2015 04:59 PM
Hydro Flame furnace blower quit working won't start nsteel Furnaces, Heaters, Fireplaces & Air Conditioning 3 01-04-2010 03:27 PM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 03:46 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.