Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-05-2013, 01:02 PM   #1
voy
New Member
 
campton , New Hampshire
Join Date: Jul 2013
Posts: 1
Roof top airconditioner problem

My 600 Series PENGUIN Duo-Therm by Domestic roof top airconditioner mounted on my 2003 Bambi behaves rather strange. I didn't use it for a while and now when I turned it on it worked for a while (a minute or so), but only on the high setting, and then the fan stops. I can restart it by turning the nob to low settings and then back to high (again it works for a minute or so). Similar situation with the fan alone. What is wrong and how to correct it.
Thank you
voy
voy is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 03:30 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.