Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-16-2020, 05:24 PM   #1
3 Rivet Member
 
2004 30' Classic
Hillsborough , New Jersey
Join Date: Apr 2009
Posts: 195
Blog Entries: 1
furnace issues

My furnace turns on for about 15 seconds then shuts off and goes through this sequence 3 time when the red light blinks indicating the problem.
I thought that maybe something got wet after a heavy rain. I took a hair dryer and in less than 1 minute the furnace stayed on!!

Anybody have an explanation what is going on with the furnace?
wolf146
wolf146 is offline   Reply With Quote
Old 10-16-2020, 05:49 PM   #2
Rivet Master
 
2018 25' International
Slidell , Louisiana
Join Date: Sep 2017
Posts: 2,233
You didn't say what the code was but it sounds like ignition fail to light. It could be an issue with the controller board due to humidity or wetness or it could be a poor connection on the flame sensor that the heat improved.
__________________
Brian
BayouBiker is online now   Reply With Quote
Old 10-16-2020, 06:39 PM   #3
Rivet Master
 
2002 19' Bambi
Lafayette , California
Join Date: May 2005
Posts: 1,100
It could also be a stuck sail switch. We have replaced our sail switch more than once. Now, if the three-try failure to light occurs, I simply bang on the side of the furnace where the sail switch is located and everything works normally. The vibration appears to unstick it.

Took me several times of taking the furnace out and re-installing before I arrived at my solution. Fortunately, I have easy access to the side of the furnace.

Tim
Tim A. is offline   Reply With Quote
Old 10-17-2020, 12:22 AM   #4
Rivet Master
 
2018 25' International
Slidell , Louisiana
Join Date: Sep 2017
Posts: 2,233
The ignition wont even try to light if the sail switch were the issue. Also the Sail switch is a lockout and the system will not retry.
__________________
Brian
BayouBiker is online now   Reply With Quote
Old 10-17-2020, 11:44 AM   #5
Rivet Master
 
2002 19' Bambi
Lafayette , California
Join Date: May 2005
Posts: 1,100
Quote:
Originally Posted by BayouBiker View Post
The ignition wont even try to light if the sail switch were the issue. Also the Sail switch is a lockout and the system will not retry.
My furnace does try three times when the sail switch is stuck and that has been the case since the furnace was new in 2002 with both stock control boards (2 of them) and with the Dinosaur board installed some 14-15 years ago (still going strong). Each try has the blower on for about 30 seconds followed by a distinct click. The cycle repeats three times before the blower turns off if there is no ignition. I have always interpreted the click to be an attempt at piezo-electric ignition. If the gas does ignite, there is the familiar rumble of the flame immediately after the click.

Of course, newer furnaces with different control boards may function differently.

Tim
Tim A. is offline   Reply With Quote
Old 10-17-2020, 03:22 PM   #6
Rivet Master
 
2018 25' International
Slidell , Louisiana
Join Date: Sep 2017
Posts: 2,233
okay my bad I was going off memory, thanks for the correction.
__________________
Brian
BayouBiker is online now   Reply With Quote
Old 10-17-2020, 03:42 PM   #7
3 Rivet Member
 
2004 30' Classic
Hillsborough , New Jersey
Join Date: Apr 2009
Posts: 195
Blog Entries: 1
furnace issue

Thanks guys for all the information.

I checked the thermostat and saw that there was a spider web on the circuit board. i used a toothbrush to get it off and the furnace starts after one attempt!! I also followed the technique someone mentioned of setting the thermostat about 5 degrees above the trailer temp.

I checked the burner head and saw that the mesh is cracked. The heat still goes on but I bought a new burner head which arrived today. I'll put it on when I need to or have the initiative to do it!!!!

Wolf
wolf146 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Infamous Suburb.NT-22 "recall" furnace issues! fotochop Furnaces, Heaters, Fireplaces & Air Conditioning 7 07-22-2012 07:42 PM
New Member / Furnace issues BigMerc 1974 - 1979 Sovereign 15 10-21-2010 06:04 PM
Wall Furnace issues wolfpack 1960 - 1964 Overlander 0 08-19-2010 06:11 PM
Furnace Issues on 25' Tradewind seeflash Furnaces, Heaters, Fireplaces & Air Conditioning 3 05-16-2009 05:54 AM
'69 AS Sovereign Furnace Issues Engtech05 Furnaces, Heaters, Fireplaces & Air Conditioning 12 03-16-2009 07:23 AM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 09:34 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.