Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-22-2020, 02:24 PM   #1
1 Rivet Member
 
1988 25' Excella
Memphis , Tennessee
Join Date: Oct 2019
Posts: 13
Electrical issue

So I set up my camper and everything worked fine had the ac goin went to bed, got up went to work the next day still everything fine went to bed woke up no ac. The pole tests fine and my outlets read 115. The fan setting will come on the ac but when I go to cool nothin. Its like I have enough to charge my phone and small stuff but not enough juice to do anything else. I do have a brand new battery. Sorry I tried searching but couldn’t really find the answer and electrics confuses me. Also 3 mobile repair people have replied “we don’t work on airstreams”
slawnugget is offline   Reply With Quote
Old 09-22-2020, 03:22 PM   #2
4 Rivet Member
 
2019 27' International
Western NC , North Carolina
Join Date: Jun 2019
Posts: 401
Images: 1
Blog Entries: 1
First thing I’d check is the a/c breakers for the unit(s). I would flip them off and back on to insure they are reset.
__________________
2019 International Serenity 27 FBQ “TC Escape”

2019 Ford F-350 Platinum
JonDNC is offline   Reply With Quote
Old 09-22-2020, 03:35 PM   #3
1 Rivet Member
 
1988 25' Excella
Memphis , Tennessee
Join Date: Oct 2019
Posts: 13
Yeah I’ve tried that several times, not sure where to go from there. I do finally have someone coming to look. I just need to get it sorted before I role to night shift.
slawnugget is offline   Reply With Quote
Old 09-22-2020, 03:37 PM   #4
Rivet Master
 
57Vintage's Avatar

 
1958 26' Overlander
Battle Ground , Washington
Join Date: Jun 2013
Posts: 544
Images: 22
Like JonDNC said check the easy stuff first. If you have to any electrical checks inside the unit itself I found this You Tube video helpful in giving me an idea of what to do. I'm not an expert with electrical, but it helped me do some basics easily. He gets a little technical, but pay attention to the actual tests he performs.

__________________
Harold & Rebecca

Our thread:
https://www.airforums.com/forums/f97...er-172124.html
57Vintage is offline   Reply With Quote
Old 09-22-2020, 03:55 PM   #5
1 Rivet Member
 
1988 25' Excella
Memphis , Tennessee
Join Date: Oct 2019
Posts: 13
Great I’ll check the video out. I do hope it’s just the ac and not an electrical issue. I do need want to do some electrical upgrades but this was a last minute job I wasn’t even planning on pulling the camper to so I didn’t get to check or do any upgrades I was planning. I really do enjoy the amount of knowledge in this forum.
slawnugget is offline   Reply With Quote
Old 09-22-2020, 04:12 PM   #6
Rivet Master
 
CBWELL's Avatar
 
1994 34' Excella
Warren , Manitoba
Join Date: Apr 2006
Posts: 736
You need 13+volts to run the electronic board in the A/C unit. Confirm that your converter is charging your battery, and that you have 13+ volts DC power to the unit. Your fridge also requires 13+volts to operate correctly on shore power.
__________________
ACI #7394
2012 GMC 2500 HD Duramax Denali
1976 31' Gone but fondly remembered
1976 22' Argosy
Hensley Hitch
CBWELL is offline   Reply With Quote
Old 09-22-2020, 06:15 PM   #7
1 Rivet Member
 
1988 25' Excella
Memphis , Tennessee
Join Date: Oct 2019
Posts: 13
Ok he said all my power was good but the compressor is toast. So he’s putting a new one in tomorrow while I’m at work.
slawnugget is offline   Reply With Quote
Old 09-23-2020, 12:45 PM   #8
1 Rivet Member
 
1988 25' Excella
Memphis , Tennessee
Join Date: Oct 2019
Posts: 13
Ok I think I’m fixed and the issue was electrical. Neutral was bonded at the hot water heater. So a bad instal of the hot water heater from when I worked in Mississippi cost me my ac and coulda burnt me down.
slawnugget is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Furnace issue turns out to be AS issue 92landyacht Land Yacht/Legacy Motorhomes 16 01-20-2016 10:19 PM
Electrical issue? jornvango General Repair Forum 7 11-25-2012 07:55 AM
Electrical issue vicn2000 Electrical - Systems, Generators, Batteries & Solar 3 04-23-2012 06:14 AM
Help - electrical issue! mastercaster Batteries, Univolts, Converters & Inverters 21 04-09-2012 01:56 AM
2006 Safari Electrical issue Viper Batteries, Univolts, Converters & Inverters 7 08-17-2010 08:04 AM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 08:36 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.