RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-30-2020, 01:44 PM   #1
New Member
 
2019 30' Classic
Currently Looking...
Carpinteria , California
Join Date: Oct 2020
Posts: 2
Alde heating system

We have a 2019 30' Classic.. When I turn on the radiant heat, with electric only the heater doesn't heat. I set the load protector for 30 amps equal to the service provided. Also in the service section on control panes it shows the circulating motor idle. The glycol and water temp do rise but very slow. After 2 to 3 hours the temp has only risen 5 to 10 degrees. We don' run the heater at night and turn it on at 5 in the morning. It's been about 45 to 50 degrees outside. I tried another time turning on the gas also. In the service section in control panel the circ. pump is running 2 to 3 thousand rpm. within ten minutes you can feel the heat. the glycol and water temps start rising right a way. Is just that electric only may take many hours to heat.
Avo Rancher is offline   Reply With Quote
Old 10-30-2020, 02:20 PM   #2
2 Rivet Member
 
2019 30' Classic
Norcross , Georgia
Join Date: Jul 2018
Posts: 47
You may want to check that the hot water heat setting is also on. If that's turned off the heating doesn't seem to be as good either.
PaulR-GA is offline   Reply With Quote
Old 10-30-2020, 02:22 PM   #3
2 Rivet Member
 
2019 30' Classic
Norcross , Georgia
Join Date: Jul 2018
Posts: 47
We've found the programmable night setting works really well even on electric--but it takes about an hour to get from 60 to 65 degrees so we set it to start an hour before we get up. Good luck!
PaulR-GA is offline   Reply With Quote
Old 10-31-2020, 08:21 AM   #4
2 Rivet Member
 
New Hope , PA
Join Date: Aug 2019
Posts: 34
I had a similar problem with our Alde (in our Bowlus). Heat with propane worked fine. No heat with 120V.

Turns out the Alde wasn't getting 120V. (The pump and panel work off 12V so the electronics will work even if no 120V.) In my case the electrical failure was from the Alde getting inadvertently unplugged But it could have just as easily been a GFCI tripping on the outlet or a breaker tripping.

I would start by checking out the electrical circuit. An easy way to see if the Alde is receiving 120V is that a "plug" icon will appear on the screen when connected to 120V.
__________________
2018 Bowlus Road Chief (24')
TV 2016 Tesla Model X
tinpoodle.blogspot.com
idoco is offline   Reply With Quote
Old 10-31-2020, 08:48 AM   #5
Rivet Master
 
turk123's Avatar

 
2019 30' Classic
Canfield , Ohio
Join Date: Jul 2015
Posts: 2,226
I just came from Jackson Center and had my Alde heater repaired on the "electric" side. If you are plugged into 30 amp, you will not get that much heat out of the unit. With 50 amp you can expect 129-degree glycol in two to three hours. Not enough to heat for your 30' trailer when it's 40 degrees outside. If you add the propane into the mix, it will heat very quickly to 165 degrees.

What I've found is to use both (electric priority with the propane button pushed to "green" on the first panel). It conserves propane tremendously! Very efficient and will last weeks on 80 lbs of propane (two tanks).

By the way, my problem that prompted the trip to JC, was that the electric was not working at all. What they found was one pump (Alde flow) was unplugged. When you turned on the electric heat, it would heat without the pump running. The system would either blow the breaker or just plain shut down (I have not been able to tell if a breaker is tripped). The propane would work fine. Took the Airstream tech all of 10 minutes to find it! I don't care what anyone says, the techs at the Airstream factory service center are on top of it!
__________________
x\x/x\x/x\x/x\x/x\101970\x/x\x/x\x/x\x/x\x/x\/x\x/x\x/x
2017 Airstream International Signature 27FB Twin
2019 Airstream Classic 30 Twin
turk123 is offline   Reply With Quote
Old 10-31-2020, 02:41 PM   #6
2 Rivet Member
 
2020 33' Classic
Sarasota , Florida
Join Date: Aug 2013
Posts: 79
Quote:
Originally Posted by turk123 View Post
I just came from Jackson Center and had my Alde heater repaired on the "electric" side. If you are plugged into 30 amp, you will not get that much heat out of the unit. With 50 amp you can expect 129-degree glycol in two to three hours. Not enough to heat for your 30' trailer when it's 40 degrees outside. If you add the propane into the mix, it will heat very quickly to 165 degrees.



What I've found is to use both (electric priority with the propane button pushed to "green" on the first panel). It conserves propane tremendously! Very efficient and will last weeks on 80 lbs of propane (two tanks).



By the way, my problem that prompted the trip to JC, was that the electric was not working at all. What they found was one pump (Alde flow) was unplugged. When you turned on the electric heat, it would heat without the pump running. The system would either blow the breaker or just plain shut down (I have not been able to tell if a breaker is tripped). The propane would work fine. Took the Airstream tech all of 10 minutes to find it! I don't care what anyone says, the techs at the Airstream factory service center are on top of it!


I had the same issue with my Alde system not heating quickly. I spent an hour going through the poorly written manual and figured everything out. I am currently plugged in to 50amp and I made minor adjustments to the settings on the panel. One important thing to know is that you need to set the correct day and time and activate the components of the system. I have never had to use propane in conjunction with the system yet but I have tested it and it does in fact work!! On the panel there is a day time setting and a nigh time setting. For my night time setting I set the temp for 65 degrees because we have found that any temp greater roasts us! I adjust or turn off my daytime setting depending on the outside ambient temp. I also keep my glycol alcohol tank within the factory recommended parameters at all times. We have been in 30 degree temps and I have used the floor warmer and towel bar warmer in our 2020 33 Classic and itís MUY BUENO!!! I suggest taking a few minutes to learn and understand how to use the control panel and what each icon represents and does. Then you will be SUPER HAPPY and you should never use propane except for your fridge or stove. Hope this helps...
Gigler is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
First Alde 3010 boiler to Alde 3020 boiler and Alde flow upgrade Sparr 2016 - Current Classic (all lengths) 56 06-08-2020 02:55 PM
Alde Floor Heating System Re-Pete Furnaces, Heaters, Fireplaces & Air Conditioning 0 04-14-2020 08:54 AM
ALDE HEATING SYSTEM FAILURE- Alde glycol discoloration and vent discharge JimskyD 2016 - Current Classic (all lengths) 50 05-25-2018 08:48 AM
Alde European central heating system ? nickclifford Furnaces, Heaters, Fireplaces & Air Conditioning 16 10-10-2017 08:37 AM
alde heating system old vet General Repair Forum 1 01-23-2017 11:05 AM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 08:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.