Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-08-2023, 03:24 PM   #1
New Member
 
Madison , Tennessee
Join Date: Oct 2023
Posts: 2
2024 Rangeline, Timberline gas system not working.

Hey folks. Just picked up my new rangeline last week and of course stuff is broken.

My gas powered heating system isnít working. Everything on the panel side looks like it should be working, no error codes.

When I turn the system on the fuel pump under the car doesnít turn on. The fans run but only cold air comes on. I set it to 90 and waiting for 20 mins for it to start but it never comes on, temps donít change.

There is a weird bug however. The tank temp reads between 180-250 even after a cold night with the system off. That has to be an error in the temp sensor, but no error code for it.

Iíve disconnected the house battery, flipped the 20amp fuse to off for the timberline system, waited 30 mins, and still no luck.

Anyone have any ideas?
Jetmatt is offline   Reply With Quote
Old 10-08-2023, 05:30 PM   #2
Rivet Master
 
1988 32' Excella
Robbinsville , New Jersey
Join Date: May 2012
Posts: 3,322
How much fuel is in the tank?
Some systems that pull fuel out of a vehicles tank are set to stop when tank is around 1/4, so you don't get stranded.
Wazbro is offline   Reply With Quote
Old 10-09-2023, 08:29 AM   #3
New Member
 
Madison , Tennessee
Join Date: Oct 2023
Posts: 2
Quote:
Originally Posted by Wazbro View Post
How much fuel is in the tank?
Some systems that pull fuel out of a vehicles tank are set to stop when tank is around 1/4, so you don't get stranded.
It's full, the gas tap is about 1/4 of the tank up from the bottom.

It's looking more and more like a faulty temp sensor reading is causing the system to think it doesn't need to turn on. Frustrating on a 2 week old Airstream.
Jetmatt is offline   Reply With Quote
Old 10-09-2023, 05:52 PM   #4
Rivet Master
 
1988 32' Excella
Robbinsville , New Jersey
Join Date: May 2012
Posts: 3,322
Quote:
Originally Posted by Jetmatt View Post
It's full, the gas tap is about 1/4 of the tank up from the bottom.

It's looking more and more like a faulty temp sensor reading is causing the system to think it doesn't need to turn on. Frustrating on a 2 week old Airstream.
I was thinking that was most likely. Fuel was the the only good thing I could think of.
Wazbro is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rangeline force is not with us DarthVander Sprinter and B-van Forum 13 06-13-2024 08:35 PM
Rangeline Electrical Upgrades - How easy? zeekwad Batteries, Univolts, Converters & Inverters 1 05-14-2023 03:25 PM
Timberline Lodge Thiss Boondocking 12 06-10-2018 11:34 PM
Electic Jack not working - fuse good - manual not working ryandanz Jacks, Stabilizers, Lifting and Leveling 20 04-24-2016 10:04 AM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 12:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.