Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-09-2021, 05:54 PM   #1
1 Rivet Member
 
2021 30RB Classic
New Braunfels , Texas
Join Date: Dec 2020
Posts: 8
Power Sofa and TVís not working on 2021 Classic

Bear with me, this is my first ever post. This is our first long trip in our new 2021 Classic 30 from Texas to Virginia. All was working fine last night at our stop in Nashville but now in Blountville, TN the power sofa, the USBís between the sofaís recline switches and both front are rear TVs are not functioning. Assume something worked loose on I40 today. All circuits breakers look good. Any suggestions on where to look?

Thanks,
Jim
Chuga27 is offline   Reply With Quote
Old 05-09-2021, 06:15 PM   #2
2 Rivet Member
 
Ginophiles's Avatar
 
2017 30' International
Paradise , California
Join Date: Aug 2020
Posts: 93
Bummer. Each model seems to be wired a little different, but...On our '17 30' Inter, we kept tripping the GFCI circuit on a trip last month. On our model, that meant outlet, except the 2 in the bedroom. So TV and even the refer wouldn't work.

I suspected a loose wire so started pulling outlets to check. Turns out AS uses a special outlet that the wires are clamped into. Seemed pretty secure even though we had bounced along bad parts of I5 and 210.

Mine was a bad GFCI breaker. Replaced that and it's been fine.

Double check the breakers and see if the labeling tells you what outlets are on which breaker, it should. If it looks like the problem outlets are on the same circuit try shutting it all the way off and then back on.

If it appears that there are other outlets on the same circuit and some are still working, then it could be a lose wire in one of the outlets. In other words, power is getting from the circuit breaker to some of the outlets, but is getting interrupted on it's way to the rest of the outlets.
Ginophiles is offline   Reply With Quote
Old 05-09-2021, 06:58 PM   #3
1 Rivet Member
 
2021 30RB Classic
New Braunfels , Texas
Join Date: Dec 2020
Posts: 8
According to the manual Circuit 7 is a 15 amp circuit that controls multiple devices like the sofa, TVs and blue ray. Appears everything on this circuit is dead. Breaker acts normal. Iíll call Airstream Tech Support in the morning and see what they have to say.

Thanks,
Jim
Chuga27 is offline   Reply With Quote
Old 05-10-2021, 04:59 AM   #4
Rivet Master
 
turk123's Avatar

 
2019 30' Classic
Canfield , Ohio
Join Date: Jul 2015
Posts: 2,379
Are you plugged into shore power? The sofa is not a DC voltage device. I assume that is why you are checking breakers.

If you pull the top of the sofa up (the vent for the heat towards the back center) you will see where it is plugged into an AC outlet. If it is like mine, it has one plug for the left side and one plug for the right. Forget about the USB ports as they are constantly winking out and they are not fast chargers anyway. The circuitry for them is accessible when you pull the covers off the left and right arms. I've fixed mine a dozen times and Jackson center has fixed the right one twice.
__________________
x\x/x\x/x\x/x\x/x\101970\x/x\x/x\x/x\x/x\x/x\/x\x/x\x/x
2017 Airstream International Signature 27FB Twin
2019 Airstream Classic 30 Twin


Link to our shared album: https://photos.app.goo.gl/wACfGg1KcroVLP5m6
turk123 is offline   Reply With Quote
Old 05-10-2021, 05:13 AM   #5
Rivet Master
 
2014 20' Flying Cloud
Long Island , New York
Join Date: Jun 2015
Posts: 17,062
Quote:
Originally Posted by Chuga27 View Post
According to the manual Circuit 7 is a 15 amp circuit that controls multiple devices like the sofa, TVs and blue ray. Appears everything on this circuit is dead. Breaker acts normal. I’ll call Airstream Tech Support in the morning and see what they have to say.

Thanks,
Jim
Good advice so far, good luck. Assuming you are on shore power, are all the other 120-volt and 12-volt DC functions good? If you are not on shore power please advise.
__________________
Let the music lift you up . . .

OTRA15 is online now   Reply With Quote
Old 05-10-2021, 06:50 AM   #6
1 Rivet Member
 
2021 30RB Classic
New Braunfels , Texas
Join Date: Dec 2020
Posts: 8
Yes, plugged into shore power and yes have checked the plug behind the sofa which I found secure. All the electrical outlets controlled by Circuit 7 are dead which includes both front and rear TVs. Weíll see what AS tech service has to say but at least my problem isnít devastating, just frustrating. I can alway run an extension cord to a working plug to power the TV temporary until this gets all sorted out. If tech support canít advise a quick fix then I have a Plan B. Weíll be passing by Ashland, VA in a couple of days where thereís an AS dealer. Can always stop in and let their techies check it out. Just a bit disappointed when we pay what we do for these expensive trailers to have a nagging problem like this happen right out of the gate. Thanks for your responses...

Jim
Chuga27 is offline   Reply With Quote
Old 05-10-2021, 06:54 AM   #7
1 Rivet Member
 
2021 30RB Classic
New Braunfels , Texas
Join Date: Dec 2020
Posts: 8
And yes, all the other 110v and 12v outlets p/devices are functioning normally..
Chuga27 is offline   Reply With Quote
Old 05-10-2021, 06:56 AM   #8
1 Rivet Member
 
2021 30RB Classic
New Braunfels , Texas
Join Date: Dec 2020
Posts: 8
devices and not p/devices. Had an iPad finger fumble....
Chuga27 is offline   Reply With Quote
Old 05-10-2021, 09:52 AM   #9
Half a Rivet Short
 
2017 30' Classic
Carlisle , Pennsylvania
Join Date: May 2017
Posts: 10,132
Hi

The common element between those outlets is that they all are inverter outlets. There is a circuit from the breakers that goes to the inverter. Inside the inverter it hits a relay. That relay decides if the load gets power from the inverter or the shore power. Either way the output of that relay goes through a breaker or fuse on the inverter before it heads off to the outlets.

One would guess that the issue is most likely the inverter not switching to shore power properly (unlikely) or the fuse / breaker on the inverter being blown / tripped (more likely).

Bob
uncle_bob is offline   Reply With Quote
Old 05-10-2021, 10:43 AM   #10
Rivet Master
 
2014 20' Flying Cloud
Long Island , New York
Join Date: Jun 2015
Posts: 17,062
Thumbs up

Good guidance Bob.
__________________
Let the music lift you up . . .

OTRA15 is online now   Reply With Quote
Old 05-10-2021, 03:16 PM   #11
Airstream Ambassador
 
AirstreamInc's Avatar
 
Jackson Center , Ohio
Join Date: Feb 2017
Posts: 708
Blog Entries: 1
Quote:
Originally Posted by Chuga27 View Post
Bear with me, this is my first ever post. This is our first long trip in our new 2021 Classic 30 from Texas to Virginia. All was working fine last night at our stop in Nashville but now in Blountville, TN the power sofa, the USBís between the sofaís recline switches and both front are rear TVs are not functioning. Assume something worked loose on I40 today. All circuits breakers look good. Any suggestions on where to look?

Thanks,
Jim

Hi Chuga27,*

Please send us a direct message with your contact information, email and the last 6 digits of your VIN so we can share it with our Customer Service and Technical Support team. We look forward to helping you get this resolved.

You can also reach Airstream Customer Service and Technical Support at*customersupport@airstream.com

Thank you.*
__________________
Official account for Airstream, Inc.
Airstream Customer Service and Technical Support can be reached at 1 (877) 596-6111, option 1.
AirstreamInc is offline   Reply With Quote
Old 05-10-2021, 03:43 PM   #12
2 Rivet Member
 
2020 30' Classic
James Island , South Carolina
Join Date: Jun 2015
Posts: 21
Uncle Bob is right. All power for the mentioned items go through the inverter. Try turning on the inverter and see if problem goes away. Just another item to eliminate.

Lou
__________________
Lou
2020 30' Classic
KC5ME is offline   Reply With Quote
Old 05-10-2021, 06:44 PM   #13
Toaster Life
 
2010 23' International
Tucson , Arizona
Join Date: Aug 2015
Posts: 193
Sorry for the all the bother you are going through with your fabulous new home. I do hope it gets sorted for you quickly. As an Airstreamer of many years I would recommend minimising the electronic gadgets and opting for mechanical whenever possible, this way you limit the hassles to the mechanical portions without adding in a layer of electronic things to go wrong, or drain your batteries.

This is just for folks looking at new rigs or thinking of upgrading from an existing one the simpler things are the less to go wrong and the easier to fix in the field.
Toasterlife is offline   Reply With Quote
Old 05-10-2021, 08:26 PM   #14
1 Rivet Member
 
2021 30RB Classic
New Braunfels , Texas
Join Date: Dec 2020
Posts: 8
Gents, thanks for all your responses. Yesterday before starting my post I pulled the drawer below the microwave to get to the inverter. I attempted to reset it but that didnít work. I spoke to Cory in tech support this morning. He didnít offer much more from what I had already done other than to check the terminal fuses on the batteries. I have no way to check them other than visual and they look good. Weíre at a campground in Natural Bridge, VA heading from here to Fredericksburg, VA Thursday morning. Weíll pass right by the Airstream dealer in Ashland, VA in route so I spoke to them today where they said to stop by and theyíd have one of there techies take a look to see what he can find. Hoping itís something quick and simple.

I now have an entry step failure. The right side step pin that holds the step in position when itís deployed is missing so it must have backed out during our 200 mile journey to Natural Bridge today. So the quality gremlins continue to bite us on our new Classic. Not to bore you guys to death, hereís what weíve dealt with since day one of delivery:

1. Missing 1/2 of sink cover at delivery. The dealer (Camper Clinic II, Buda, Tx) had to order a new one which arrived just before our departure.
2. Rear driverís side corner window shade torn at delivery. Replacement shade on order.
3. Front a/c temp sensor reading 8-10 degrees higher than rear a/c sensor causing front a/c to run continuous when on auto. Returned our new Classic to the dealer, they kept the trailer one week, called to say it was ready, I go to pick it up and nothing had been done. When asked why I was told it was ready when it wasnít, I was informed they were waiting on warranty approval from Airstream because the fix required them to order a new sensor and then pull the fridge to replace it. Lead time on the part was another 2-3 weeks. Frustrated and upset with the dealer, I took my trailer home to prepare it for the trip weíre on now. In the meantime I found a post where others had experienced the same a/c temp sensor problem with the fix being to seal off the hole through the trim behind the sensor cover to keep heat from the fridge from causing the false sensor reading. A 10 minute fix and Iím in business, problem solved. Now why didnít the dealer know about this simple fix?
4. Electrical problem that started this post
5. Step failure that occurred today
6. Vent hood above stove is drooping at the front left corner. The screw that secures that corner of the hood is missing. Appears that particular screw was never installed so Iím off to Loweís in the morning to buy an assortment of screws to carry in the trailer just in case..

So Iíll close by saying is it normal to have so many quality issues on a 6 figure Airstream? Sorry for my diatribe, I just needed to vent....

Jim
Chuga27 is offline   Reply With Quote
Old 05-11-2021, 12:13 AM   #15
Rivet Master
 
2014 20' Flying Cloud
Long Island , New York
Join Date: Jun 2015
Posts: 17,062
Thanks for the update, good luck today.

Sad to say, Airstream's quality control seems to be continuing on its years-long downhill slide IMO.

__________________
Let the music lift you up . . .

OTRA15 is online now   Reply With Quote
Old 05-12-2021, 06:50 AM   #16
Half a Rivet Short
 
2017 30' Classic
Carlisle , Pennsylvania
Join Date: May 2017
Posts: 10,132
Quote:
Originally Posted by OTRA15 View Post
Thanks for the update, good luck today.

Sad to say, Airstream's quality control seems to be continuing on its years-long downhill slide IMO.

Hi

.... errr.... I grew up listening to Airstream quality problem stories. They were from back in the 1950's. Indeed my young mind didn't capture every detail. Based on the emotion expressed, they were every bit as much of an issue back then.

Bob
uncle_bob is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Front interior light not working, middle and rear working? jonnyo Lights - Interior & Exterior 5 01-06-2020 11:25 AM
Shore power and gen power not working merrillv Flat-Front (Cutter, Clipper, XC, XL & Skydeck) Motorhomes 5 03-14-2019 09:46 AM
Electic Jack not working - fuse good - manual not working ryandanz Jacks, Stabilizers, Lifting and Leveling 20 04-24-2016 10:04 AM
Power sofa, power bed, etc. Billstream Airstream Trailer Forums 4 03-04-2016 07:07 PM
Dash Air Fan, Power window and Power Seat Stopped working alvinator Land Yacht/Legacy Motorhomes 3 07-13-2014 09:22 AM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 03:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.