Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-13-2021, 07:34 PM   #1
New Member
 
2014 25' Flying Cloud
Keswick , Virginia
Join Date: Nov 2019
Posts: 2
Electrical problem 12 v

2014 25 FB FC. Put trailer away last fall with no problems. Removed batteries and put on trickle charger. Installed batteries this evening. Not on house power. Power jack light works and jack functional. Propane detector light on. Inverter remote switch powers on. But I have no cabin light, no + water pump, no stereo, no monitor lights. What am I missing? If it were a blown fuse somewhere in the trailer would the propane leak detector light up and inverter work? Thanks for any help.
Jim
Thistledew is offline   Reply With Quote
Old 05-13-2021, 07:48 PM   #2
Site Team
 
azflycaster's Avatar

 
2002 25' Safari
Dewey , Arizona
Join Date: Mar 2005
Posts: 14,753
Images: 62
Blog Entries: 1
Use / Store switch?
__________________

Richard

Wally Byam Airstream Club 7513
azflycaster is offline   Reply With Quote
Old 05-13-2021, 08:23 PM   #3
2 Rivet Member
 
2018 30' International
Currently Looking...
Southern Pines , North Carolina
Join Date: Dec 2020
Posts: 24
Ensure all the leads are hooked up? There are two sets of main + /- cables. One for the inverter and one set for the house panel...
NC-Serenity is offline   Reply With Quote
Old 05-16-2021, 02:24 PM   #4
New Member
 
2014 25' Flying Cloud
Keswick , Virginia
Join Date: Nov 2019
Posts: 2
Problem solved but not sure exactly why. Disconnected batteries. Checked fluid levels-ok. Hooked up to shore power and removed, inspected, and re-installed all fuses. Reset breakers. Cycled Store/Use switch several times all on shore power. Then disconnected from shore power and 12 v battery system, including inverter plugs functioned normally.
Thistledew is offline   Reply With Quote
Old 05-16-2021, 02:29 PM   #5
3 Rivet Member
 
2018 27' Globetrotter
Elbert , CO
Join Date: Oct 2019
Posts: 242
Images: 3
I had a similar situation. It turned out to be a stuck relay that gets activated by the store/use switch. Toggling the switch several times unstuck it and restored our 12v utilities.
djb75 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical problem ALANSD Mechanics Corner - Engines, Transmission & More... 23 09-13-2015 07:20 PM
Electrical probs w electrical to new fridge cooling unit. Surfairstrea Batteries, Univolts, Converters & Inverters 2 05-23-2012 07:24 PM
HELP! Electrical problem FranceyS Electrical - Systems, Generators, Batteries & Solar 6 08-03-2010 02:57 PM
Electrical problem resolved davidz71 Electrical - Systems, Generators, Batteries & Solar 5 08-12-2002 08:21 PM
Problem with electrical system (1965 safari) rslaymaker Electrical - Systems, Generators, Batteries & Solar 4 06-13-2002 05:49 PM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 12:57 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.