Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-16-2017, 05:01 PM   #1
3 Rivet Member
 
2015 16' Sport
Pineola , North Carolina
Join Date: Dec 2014
Posts: 144
Converter/Charger

2015 16' Sport. 229 nights of great service. Just returned from 2 week boondocking trip and charger worked normally with gen and solar. Plugged in at home and outlets and all lights work but volt meter in trailer is only reading 12.5. Usually reads 13.6 in charge mode and 13.2 in float. All breakers and fuses in panel normal. It has the WFCO three stage charger/converter.

Any ideas greatly appreciated. Thanks.
D Greene
__________________

D Greene is offline   Reply With Quote
Old 10-16-2017, 05:21 PM   #2
Rivet Master
 
2011 22' Sport
Portland , Oregon
Join Date: Aug 2017
Posts: 601
If you put it in store mode and check the voltage at the converter/12V fuse panel what do you see?
__________________

SilverHouseDreams is offline   Reply With Quote
Old 10-16-2017, 06:28 PM   #3
3 Rivet Member
 
2015 16' Sport
Pineola , North Carolina
Join Date: Dec 2014
Posts: 144
I'll check tomorrow. Thanks.
__________________
"Certainty on any matter is not one of the human attitudes the Gods admire or tolerate."
A. Cross
D Greene is offline   Reply With Quote
Old 10-16-2017, 06:32 PM   #4
Half a Rivet Short
 
2017 30' Classic
Carlisle , Pennsylvania
Join Date: May 2017
Posts: 8,675
Hi

First step: Figure out how AS decided to do the "use/store" setup in your specific trailer. On some the converter / charger is taken off the battery in "store" mode. In others, it's hooked up to the battery regardless of the use/store setting. If yours is a disconnecting setup, your switch may be in the wrong position.

Bob
uncle_bob is offline   Reply With Quote
Old 10-16-2017, 07:11 PM   #5
3 Rivet Member
 
2015 16' Sport
Pineola , North Carolina
Join Date: Dec 2014
Posts: 144
Mine has the manual switch. In store or disconnect position there is no power to the volt meter/tank level panel at all, that is to say no display. I'm pretty sure no charge is getting to the battery. When we got home after about an hour and half drive the display indicated 12.7. After checking fuses etc. after a few hours the reading had dropped to 12.4. It was plugged into shore power for this time and switched to on or use and volt display continued to drop.
Thank you
__________________
"Certainty on any matter is not one of the human attitudes the Gods admire or tolerate."
A. Cross
D Greene is offline   Reply With Quote
Old 10-16-2017, 07:20 PM   #6
Rivet Master
 
2011 22' Sport
Portland , Oregon
Join Date: Aug 2017
Posts: 601
I also have a Sport (22FB) and appreciate the honest and obvious manual disconnect switch. Id check fuses and confirm the breakers are on, perhaps flip them off and back on to make sure. If you think you need a replacement converter I have one I can send for the cost of shipping, as I had to upgrade for my lithium batteries.
SilverHouseDreams is offline   Reply With Quote
Old 10-16-2017, 07:44 PM   #7
3 Rivet Member
 
2015 16' Sport
Pineola , North Carolina
Join Date: Dec 2014
Posts: 144
Thanks. It is a mystery. Double and triple checked all fuses I can find and all breakers off and on...twice. All connections seem sound.
__________________
"Certainty on any matter is not one of the human attitudes the Gods admire or tolerate."
A. Cross
D Greene is offline   Reply With Quote
Old 10-16-2017, 07:59 PM   #8
Rivet Master
 
2011 22' Sport
Portland , Oregon
Join Date: Aug 2017
Posts: 601
On mine there was a twist butt splice used to join the wiring for the converter and the outlets on the 3rd breaker. Perhaps it lost connection there?

You could also slide the converter out and check the voltage where the AC wires enter, and perhaps where the DC wires leave the circuit board. Not sure about troubleshooting beyond that, not sure of WFCO has a troubleshooting guide anywhere beyond that.
SilverHouseDreams is offline   Reply With Quote
Old 10-16-2017, 08:23 PM   #9
3 Rivet Member
 
2015 16' Sport
Pineola , North Carolina
Join Date: Dec 2014
Posts: 144
I plan to slide it out tomorrow and have a look see. Thanks for all the ideas.
__________________
"Certainty on any matter is not one of the human attitudes the Gods admire or tolerate."
A. Cross
D Greene is offline   Reply With Quote
Old 10-17-2017, 07:17 AM   #10
3 Rivet Member
 
2015 16' Sport
Pineola , North Carolina
Join Date: Dec 2014
Posts: 144
Well, went down this morning to pull the CH/CV and it is working perfectly. 13.6 volts at the display. Trailer hasn't been moved so a loose connection doesn't seem likely. I wonder if a ch/CV nearing the end of its life could work intermittently? Anyway thanks for your time in offering ideas.
__________________
"Certainty on any matter is not one of the human attitudes the Gods admire or tolerate."
A. Cross
D Greene is offline   Reply With Quote
Old 10-17-2017, 08:19 AM   #11
Half a Rivet Short
 
2017 30' Classic
Carlisle , Pennsylvania
Join Date: May 2017
Posts: 8,675
Hi

On my AS, when the use/ store is in the store position, absolutely everything in the trailer is shut off. No panels no nothing. The converter / charger is still hooked to the battery in that mode.

---------

If the battery is still charging, it's voltage can easily be below 13.7V. The charger will only put 30 or 50A into the battery. It might take it an hour or more to get above 13V. A battery monitor system that lets you look at current in and out of the battery is very helpful in this case.

Bob
uncle_bob is offline   Reply With Quote
Old 11-27-2017, 01:12 PM   #12
3 Rivet Member
 
2015 16' Sport
Pineola , North Carolina
Join Date: Dec 2014
Posts: 144
It occurred to me that the diagnosis and resolution of my mystery issue might be helpful to others. After some quick work with my multimeter the problem was an intermittently failing charger/converter. Replacement was quick and easy and now working perfectly.
__________________

__________________
"Certainty on any matter is not one of the human attitudes the Gods admire or tolerate."
A. Cross
D Greene is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Converter/Charger vs. Inverter/Charger moosetags Batteries, Univolts, Converters & Inverters 5 11-22-2013 10:21 PM
It's official - no converter or charger & I need advice henrydahm Electrical - Systems, Generators, Batteries & Solar 11 07-31-2006 07:31 PM
Converter/charger humming in stereo blickcd Electrical - Systems, Generators, Batteries & Solar 6 01-05-2005 07:50 PM
Converter/battery charger ARGONUT Batteries, Univolts, Converters & Inverters 0 11-23-2003 04:28 PM
Adding charger where no charger has gone before Jabba Electrical - Systems, Generators, Batteries & Solar 4 03-08-2003 09:39 AM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



All times are GMT -6. The time now is 09:14 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.