Airstream Forums

Airstream Forums (http://www.airforums.com/forums/)
-   Water Heaters, Filters & Pumps (http://www.airforums.com/forums/f445/)
-   -   Hot water heater won't light. :( (http://www.airforums.com/forums/f445/hot-water-heater-wont-light-46998.html)

sinjin 12-19-2008 09:43 AM

Hot water heater won't light. :(
 
Aloha all:

We have a 2009 28 ft International. The propane hot water heater won't light. It worked two weeks ago, now nothing. We followed the directions and turned it off and tried again after 5 minutes, still nothing. Any suggestions on what we should try next?

Thanks

sinjin

Oh, and we do have propane. Just filled both tanks and the propane heater and gas burners on the stove are both working.

cameront120 12-19-2008 09:51 AM

Is it an electric start or a regular pilot light model?

sinjin 12-19-2008 11:13 AM

It's electric start, but after driving down the road for an hour we tried it again and it started. Very weird.

romap 12-19-2008 04:11 PM

Did you get an "attempted light"? I think there are three tries before the red light comes on which requires a re-set of the switch. If you are at the water heater outside you can verify this. Mine will do several flame outs before it stays lit, but then it is fine thereon. I have yet to determine the cause, perhaps air in the gas line. Try cleaning the 12V connections on the water heater if you experience this again. Also make sure there are no insect webs/nests in the air tube, and that the air mixing sleeve is adjusted properly.

Al - K4GLU 12-19-2008 04:27 PM

This is a very common problem with late model Airstreams. The usual advice is to clean the 12V connector but in my case that didn't work. Mine would work one place and then wouldn't work the next. And over and over. Was at Jackson Center last summer and they couldn't figure out what was causing the problem. They ended up replacing several parts and it now seems to work fine but I have no idea which of the replaced parts was causing the problem.

vinstream 12-19-2008 04:40 PM

My guess is the battery may have been low... And once down the road it recharged the battery? Just a guess!
Vin...

cameront120 12-19-2008 04:53 PM

Quote:

Originally Posted by vinstream (Post 649287)
My guess is the battery may have been low... And once down the road it recharged the battery? Just a guess!
Vin...


Yep this is very likely. Anotherpossibility is too many 12 volt fixtures running at once. This is where mine gets hung up. If I have too many 12 volt lights going, the water heater won't start. Once I turn off a couple of lights, it starts right up.

vinstream 12-19-2008 06:14 PM

Yes having many 12volt items working will do the samething! There is a wand with in the heater and if there is to little air moving through the system the wand will not trip the circut and the heater will not light! On that point the samething will happen when the fan motor is on it last leg or I have found this at very high alt over 10,000 feet!
Vin...

sinjin 12-19-2008 07:13 PM

Thanks for all the replies. The battery was fully charged and we were on shore power when we couldn't get it to light, parked in the campground. We finally just heated water on the stove to do the dishes. We don't use a lot of electrical stuff when we camp.

But thanks to you guys we have some things to try if it happens again.:)

stowaways 12-19-2008 08:04 PM

And yet another theory, same thing happened to us recently. Turns out one of the wires had come loose in the switch on the wall. A couple of twists of a screw driver and we were back in business. Happy camping!

Chief 12-19-2008 08:32 PM

I have had water heater problems on two different late model trailers.....a 2007 20' Safari SE, and our current 2008 25' Safari SE.

The '07 went through two circuit boards during the six months we owned it. When one of those babies goes out, you're not getting any power to the ignitor and the only fix is replacement (simple, but not always convenient).

Our '08 had the bad habit of not igniting at the worst possible time......during or after a rainstorm. The last time it happened, I was outside (standing in water) with a hairdryer trying to dry everything off. After returning home, I cleaned each and every connector and applied some dielectric grease to the fittings. Since then, it has neve failed to ignite.

I would guess that Sinjin's problem is a loose connection, or poor ground. Cleaning/tightening all the connections may fix the problem.

Ron

Gene 12-19-2008 08:38 PM

Since you just filled both propane tanks, could you have run out of propane and not known it? Maybe the lines were air bound or maybe just one air bubble. Driving could dissolve the bubble into many little bubbles so that propane could get to the water heater. If the water heater is the last appliance to get propane, it can be the last thing to light. We've run out of propane and our furnace is the last thing, so lighting the stove brought gas closer to the furnace so it had a chance to light. You heated hot water on the stove and may have moved the gas along. I don't know where the water heater is on a 28' and tracking the lines underneath the trailer can show you what gets gas first, next and so on.

Gene

imeynstein 12-19-2008 09:31 PM

OHHHHHHH!!!!!!!!!!!!! Man!!!! I attempted to light my 1974 Sovereign only to experience a big "BOOM"....Luckily, I did not blow up!!! I removed my old Suburban and am looking for a replacement, but things are SOOO expensive and I am about ready to give up...I also need an awning, but the prices are outrageous....I am about ready to sell my 1913 home--historical--in Texarkana so I can go traveling full time...But my 1974 needs a lot of TLC...My husband tells me that my AS is 'my project', and he is 'out of it'....So, it is up to me to do it all....My AS is paid for and I feel that with today's economy, that at least I own something!!!---My husband does not share the enthusiasm that I do......So, I need as much advice as possible so I can work on my baby as much as possible while I am not working.....
HELP!!!

Silvertwinkie 12-20-2008 07:09 AM

Aloha Mr. Hand. :)

Why would you need to light the heater if the water is already hot? ;);):)

Quote:

Originally Posted by sinjin (Post 649156)
Aloha all: We have a 2009 28 ft International. The propane hot water heater won't light.


Sorry, I just couldn't pass this one up. :D


All times are GMT -6. The time now is 08:14 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.