Airstream Forums

Airstream Forums (http://www.airforums.com/forums/)
-   Refrigerators (http://www.airforums.com/forums/f425/)
-   -   I hope it's simple! (http://www.airforums.com/forums/f425/i-hope-its-simple-32902.html)

pittsf 05-31-2007 07:21 PM

I hope it's simple!
 
A '65 Safari with original gas/elec fridge, was working fine with electricity.

Left camper for about three weeks, and now won't turn on electricity.

Cord insulation was shot and so replaced cord, plugged into external supply, still not working.

Any suggestions as to troubleshooting greatly appreciated.

Tried adj thermostat, so difficult to get a multimeter under there to test how far the ac goes.

Thanks a million!

Scott S 06-19-2007 08:25 AM

If your refrig works on gas but not electric, suspect the switch. I had that go out on me (Dometic 2501). The switch needs to make several contacts in order to work.

Fyrzowt 06-19-2007 10:59 AM

Quote:

Cord insulation was shot and so replaced cord, plugged into external supply, still not working.
Was the cord just deteriorated or did it overheat? This may add more clues as to cause.
I'm going to assume that the circuit breaker was checked.
Dave

dwightdi 06-19-2007 12:31 PM

If you can borrow an amprobe you can check the amount of current the heater is drawing. One of those voltage sensing probes will tell you if the electric got to the heater without even having to get in there to touch it. Lots of excuses to buy men's toys.

pittsf 06-19-2007 04:37 PM

Thanks for the replies. The cord insulation was just deteriorated and I was afraid to trust it, and so replaced it.
Plugged it in to an external outlet to eliminate any concern about internal supply.
The switch going bad did not occur to me, but seems the most likely - I'll check that as thoroughly as I can when we get back to it.

Thanks again.


All times are GMT -6. The time now is 12:28 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.