Airstream Forums

Airstream Forums (http://www.airforums.com/forums/)
-   Airstream Motorhome Forums (http://www.airforums.com/forums/f156/)
-   -   Turn signals not working? (http://www.airforums.com/forums/f156/turn-signals-not-working-192651.html)

Michael_Wild 02-27-2019 09:47 PM

Turn signals not working?
 
2 Attachment(s)
Hazards works, brake lights work, but no love from my turn signals. Here is what I know:
- the flasher in the fuse box is not getting power.
- the grey wire in the going into the bottom left green connector on the fuse panel is not getting power
- the grey wire leads up to the steering column.
- turn signals were working earlier today, I was doing some work behind the dash and installed a new switch bank to the right of the steering column. Once I buttoned everything back up, turn signals were not working.
- I have checked all the fuses in the fuse panel and they all appear good.

Does anyone know exactly which fuse is for the signal lights?

Any other ideas?

Thanks,

Michael


Note: not sure why both pics are upside down, they are right side up on my phone.

hhendrix 02-27-2019 11:18 PM

What is your tow vehicle? I had the same issue in my 2011 F250 and discovered there is a fuse for the trailer turn signals.

bkahler 02-28-2019 05:25 AM

I believe the subject under discussion is a 1984 310 Motorhome, not a trailer tow vehicle.

What you're looking for is the GM chassis wiring diagrams for the 310. If you can't find wiring diagrams I have copies of the chassis diagrams at home that I can post later this evening or tomorrow.

Brad

bkahler 02-28-2019 06:38 AM

Michael,

If you follow this link to the GM chassis wiring diagrams and then go to Nick's post #93 you'll find links to help troubleshoot your fuse block problem.

Brad

Michael_Wild 02-28-2019 09:15 AM

Thanks Brad, I will check it out.

Michael_Wild 03-06-2019 12:17 PM

Don't be stupid, stupid
 
1 Attachment(s)
This problem was total user error on my part. Turns out in the process of testing the fuse box, I removed the turn signal fuse and neglected to replace it. Here is a diagram of the fuse box, a lot of the writing on mine is worn off so I didn't see the "Turn B U" label. Here is a pic I found on the internet in case anyone else has the same problem:
Attachment 335067


All times are GMT -6. The time now is 01:14 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.