Airstream Forums

Airstream Forums (http://www.airforums.com/forums/)
-   Furnaces, Heaters, Fireplaces & Air Conditioning (http://www.airforums.com/forums/f427/)
-   -   Furnace Won't stay lit... (http://www.airforums.com/forums/f427/furnace-wont-stay-lit-158255.html)

TomS 10-15-2016 05:44 AM

Furnace Won't stay lit...
 
We have an Atwood 8535 III in our 94 Excella . When heat is requested, it goes through the normal starting cycle, and lights off, but the flame goes out after about 20 seconds or so. Then goes through attempted restart several times, with the same result.

I've pulled and cleaned the exhaust tube, checked and cleaned all the connections.

What's next, folks? We are leaving soon for a fall trip, and I'm imagining we are going to want heat.

Thanks in advance!


Sent from my iPad using Airstream Forums

OTRA15 10-15-2016 06:30 AM

Just a guess from a lay person, but the "sail switch" in the furnace may have gone bad? This switch depends on the air flowing correctly inside the furnace, to prevent overheating in case there might be an obstruction preventing air flow. With your furnace being over 20 years old, this is a likely candidate IMO. Or the furnace's home circuit board may have gone bad? Not sure how easy either is to replace, but a mobile RV tech or a good RV shop could probably diagnose correctly.

Hopefully someone more knowledgeable will show up here soon.

We had a 25' AS in the 90's which needed a new furnace home circuit board when we sold her (at 13 years of age +/-).

Good luck!

Peter

TomS 10-15-2016 06:37 AM

I may be wrong, but I don't think the burner will ignite at all if the sail switch is bad. I had the blower assembly apart a year ago, and the sail switch seemed to be operating normally then. The furnace functioned fine then, too.

You could be right about the board, tho.

Thanks...

Any other thoughts?

What is the best way to get the burner assembly dismounted for inspection?


Sent from my iPad using Airstream Forums

OTRA15 10-15-2016 06:43 AM

I believe that some circuits allow the furnace to ignite, even with a bad sail switch, and then shut things down after a time delay. If you take things apart enough to expose the sail switch, I would put a new one in anyway maybe. No clue on dis-assembly. :huh:

TomS 10-15-2016 06:45 AM

Good point..Will check that out...


Sent from my iPad using Airstream Forums

paiceman 10-15-2016 07:09 AM

Could be your in furnace of external flow control for the propane. Had the same issue with our previous AS. We enlarged the opening of the internal and changed out the external, worked fine after that. I just can't recall the exact name of either control valve. Could look it up, but gave all the books away when we sold it and bought a 2017 Classic with a TOTALLY different baseboard hot water system. Now have to relearn everything.

Bud

OTRA15 10-15-2016 08:14 AM

PS Tom, is your battery voltage OK? If the furnace has been working well for a while, Bud's suggestion about the propane valve sizing is less likely IMO.

For a 20-year-old trailer, I would consider replacing both the board and the sail switch, and get an extra sail switch as well.

A good investment for cold weather travels . . .

Happy Trails.

Peter

bel73 10-15-2016 08:26 AM

If the flame lights then goes out it will probably be the flame sensor. If it was the sail switch you would not (better not) get a flame. It should only run for just a few seconds. If it really does run for 20 seconds or longer it could also be the over temp (high limit) switch. That would be easy to check with a meter.

TomS 10-15-2016 12:20 PM

I'm on shore power, but I will check the voltage.

Pulled the cover, cleaned and checked the sail switch with a multimeter. Seems ok.

After all this, it now shuts off the gas after about 5-7 seconds...

Should the over temp switch be normally closed or normally open?

The flame sensor is part of the igniter assembly, right? Is there an easy way to remove the igniter/burner Assyrian for visual check?

Thanks!


Sent from my iPad using Airstream Forums

TomS 10-15-2016 12:57 PM

Checked the voltage at the furnace...12.5v. The limit switch and the sail switch both check ok.

I'm down to board or flame sensor.

Thanks for all the help!


Sent from my iPad using Airstream Forums

TG Twinkie 10-15-2016 01:09 PM

Temp switch should be closed unless the plenum overheats. Normally closed; opens on over temp. You may have an obstruction in the intake or exhaust plenum causing the plenum to over heat. A temporary jumper on the temp switch and sail switch should eliminate or at least ID which, if any are the culprit.
I would suspect the flame rod or control board.
Have you checked the gas pressure?

fwjumper 10-15-2016 01:44 PM

Almost certainly NOT the sail switch or the board. I believe you said it goes into a relight mode on its own? When it does that, does the igniter spark appropriately? Do you also hear the gas valve open?
Our 34 footer has two furnaces. I had to replace the gas valves in both of them. Sometimes they would light, sometimes not. Even when they did, they would occasionally drop out after a bit.

I also thought about the limit switch, but you've checked that now. Depending on your access, you may have to get the guts out of the furnace to diagnose. They're not too hard to remove. You need to be able to see what's happening first. My guess is that either the gas valve is weak or the flame sensor drops when it gets really hot.(I've never seen this) Pulling ours out was the only way to accurately diagnose. I fully expected two different problems in each furnace. I was wrong. They both needed the valve, although they were different valves/different sized furnaces. Wishing you quick success.

bel73 10-15-2016 01:57 PM

If it shuts off within 5-7 seconds my guess is the flame sensor. If you can get to it take a look to see if it has some corrosion on it. If it seems to, take some emory paper steel wool or something to clean it up with. That will sometimes get you by in a pinch.

Good luck

ijustlee 10-15-2016 03:25 PM

It seems like the circuit board thinks there is no burner flame. Try cleaning the sensing rod with abrasive cloth and make sure that the flame is touching the rod. A lot of furnaces have a port or window so you can look at the flame and see what it's doing. Sometimes having the inspection port open changes the conditions around the sensor or the flame burns your eyebrow so you might have to hold a glass bottom up to the port and look through that. The flame should be blue with just the tips orange and the sensing rod, which is sometimes the spark electrode, needs to touch the flame. Because the rod glows red hot while the burner is on it can get a coating of oxidation which needs to be removed. If the sensing rod is clean and in the right place and the ground wire allows a good low resistance connection to the circuit board, the board might be bad.

Joohntooth 10-15-2016 08:55 PM

Furnce
 
I had the same problem in my 2014 28' FC. Turned out to be a defective fan box that was not generating enough air to engage the sail switch.

Mike1997 10-15-2016 09:01 PM

I had the exact same problem with my furnace last year. Mobile RV mechanic came out and tested the circuit board....it was bad. Replace with new model from Dinosore and its like new. Last month same thing happened with my water heater, again, another bad circuit board. This time I replaced it myself!!Guess since the originals were from 1997 they did last for awhile longer than expected :)

TomS 10-16-2016 06:03 AM

Just to follow up...

I replaced the board, and everything works normally now.

According to the tech I talked to, the other potential cause is a rusted out burner tube, which can cause the flame to go out on its own. Got a spare one now for the parts box...

Thanks to one and all for the help and tips...


Sent from my iPad using Airstream Forums

OTRA15 10-16-2016 06:47 AM

Thanks for the follow-up and the good news.

Happy Trails!

Peter

JBBeaubeaux 10-21-2016 09:27 AM

Same problem, but only when it is really cold
 
I am having the same problem, but only when it is really cold outside.

If it is not real cold and I just want to knock the chill out of the Airstream, it works fine, but when really cold, it stays on a few moments, goes off, tries again 2 more times and no longer tries to lite.

Does that help determine what the problem might be?

From reading this post, it could be any of these:
  • Defective fan box
  • Circuit board bad
  • Flame sensor
  • Flame rod
  • High limit switch
  • Rusted out burner tube
  • Sail switch

Thanks for any help!

OTRA15 10-21-2016 12:40 PM

Based on it running fine for a short time and producing heat then, I would think the circuit board may be affected by getting hotter when the furnace runs for the longer time. Most of the other items would affect any attempt to start, regardless of the length of the run time IMO.


All times are GMT -6. The time now is 10:58 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.