Airstream Forums

Airstream Forums (http://www.airforums.com/forums/)
-   Windows, Doors, Locks & Vents (http://www.airforums.com/forums/f164/)
-   -   Restoring window support rods (http://www.airforums.com/forums/f164/restoring-window-support-rods-145578.html)

TxDave 01-12-2016 03:16 PM

Restoring window support rods
 
1 Attachment(s)
Before removing the windows on my 1971 Sovereign to refurbish them I had to remove the support rods. I found the easiest way to remove the clips that hold the rods in place was to use a cut-off wheel in my Dremel. I just cut off part of the clip and used a hammer and screw driver to pop the clip off. Took about 20 minutes to remove all 8 windows.

Anyway...the support rods looked pretty bad after 45 years. I cleaned them up with a 1" belt sander from Harbor Freight using a cloth belt. As you can see from the before and after photo, this technique worked well.

I think paying attention to the small details like this is important IMHO.

cwf 01-12-2016 03:32 PM

Spray some Nyalic on it to keep it sparkly!

TxDave 01-12-2016 05:20 PM

Thanks, cwf. First I ever heard about the stuff (Nyalic). Did a google search...looks like something that would definitely be beneficial.

cwf 01-12-2016 09:55 PM

Dave,
I have a can I used to repair bad spots on our AS. Have some left if you want to test out. Of course, having the "system" they offer will give best results.

The areas I have treated have been great for over a year. No need to wax, polish, just great product!

rucos 01-13-2016 03:06 PM

I'm curious how much luck you have reinstalling the clips. Ive had several that just don't stay on long term. I get them on and all seems good then after using awhile they seem to pop off!

TxDave 01-13-2016 11:15 PM

Quote:

Originally Posted by rucos (Post 1735869)
I'm curious how much luck you have reinstalling the clips. Ive had several that just don't stay on long term. I get them on and all seems good then after using awhile they seem to pop off!

I'll let you know how that works out, rucos.

curtisjinkin 01-18-2016 02:29 PM

Thanks for the post, where do you get new clips?

cwf 01-18-2016 09:44 PM

If using "E" clips, and they fall off, usually you are using an incorrect one.

Better yet, try a "retaining clip".... McMaster-Carr
Here is a link.. Look around.. May be available at auto supply!

curtisjinkin 01-19-2016 09:03 AM

Thanks for the link! Very helpful


All times are GMT -6. The time now is 06:27 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.