Airstream Forums

Airstream Forums (http://www.airforums.com/forums/)
-   Mechanics Corner - Engines, Transmission & More... (http://www.airforums.com/forums/f159/)
-   -   Motorhome Wont start. (http://www.airforums.com/forums/f159/motorhome-won-t-start-10533.html)

jpurdy 04-06-2004 09:42 AM

Motorhome Wont start.
 
My 1981 Classic motorhome will not start.
The carburetor is not getting fuel. Decided to replace the fuel pump and the filters.
Found the inline filter at the carburetor and started looking for the other filter that is between the tank and the engine. My P30 service manual indicates all p series have an addition filter along the outside or the inside right frame rail. I looked and could not find it. I also checked the left rail. Nothing!!!
I looked at the manual and it was printed in 1990 and the oldest reference in it is for the TBI from 1985 to 1989. Did 1981s have two inline filters???

thenewkid64 04-06-2004 09:48 AM

On mine the in line filter is just inside the passenger side wheel, mounted on the frame rail. The sticker on it said AC-1 and the bottom of it unscrews. There is no other filter between it and the fuel tank. My tank is mounted under the floor under the couch on the passenger side.

If you changed the Fuel pump did you retain the little rod in place that drives the pump when you pulled the pump out? I did not know it was there, Argosy20 saved my bacon on that one. :)

swebster 04-06-2004 10:30 AM

mine is on the inside passenger side rail just behind the passenger seat. I have an additional filter between the tank and the electric pump at the tank.

If you follow your lines from the tank up the left frame rail you're bound to run into it. If you don't find one then install one!

jpurdy 04-06-2004 10:38 AM

thenewkid64

I have not replaced the pump yet. I was looking for the filters.
I'll have to crawl under again tonight as it must be there. thanks for the info on the sticker. When I went to the parts house to look up the numbers I only found the one up front listed.

swebster,
I'll do as you suggest if I do not find one tonight

thenewkid64 04-06-2004 10:46 AM

Jpurdy,

Real dumb question here......

Does the tank have fuel in it? I just hate to see you on a wild goose chase ;)

dinoburb 04-06-2004 12:13 PM

Hi,

thenewkid64's mention of the rod for the fuel pump is timely. You can put the pump back, with difficulty, without getting the rod into place. Nothing works.

Since you have not removed the pump have you simply tried to see if the pump is pumping by removing the fuel line at the carb and turning the engine over. Place the line in a coffee can and check for flow. It should be robust when the engine is turning over. Don't spill the fuel! If you've got fuel there then the problem is between the end of the fuel line and the float in the carb.

How long has it been since it was last run? Very old gas is a killer as well!

Take care,

jpurdy 04-06-2004 12:17 PM

thenewkid64
not a dumb one at all. there is fuel in it about 7 gallons.
I did call the local chevy dealer and found a part number. 854619 but none in stock.
NAPA could match up on the number and I'll pick it up on the way home.

ctdair 04-06-2004 04:55 PM

how is the gas feed to the generator , if you have one? does it have a separate fuel tank or feed from main tank? the reason I ask is if it is fed from main tank any lines going to it must be good . had experience on a dodge that had a generator and its fuel line had a pin hole and main engine fuel pump would not work just sucked air. Had second experience with dodge , no fuel changed pump still no good , it was a ambulance that had a gas fired heater(us army) its feed line had a pin hole same thing pump just sucked air until line fixed. If you have to change the pump make sure You get detailed instructions ect where to put the bolt to hold the pump rod up in place. it's a real PITA if you let the rod fall down.

overlander63 04-06-2004 07:15 PM

Quote:

Originally Posted by ctdair
make sure You get detailed instructions ect where to put the bolt to hold the pump rod up in place. it's a real PITA if you let the rod fall down.

I can attest to that. I was helping do a fuel pump a few weeks ago, the bolt was rusted/siezed in place, rather than break something, I did it the hard way, put a dab of grease on the rod, and let that hold the rod up while installing the pump. Something else to check, pull off the inlet line on the pump, and make sure it is creating a suction there.
Terry

jpurdy 04-06-2004 09:43 PM

Well I found the other inline filter. it was in the compartment with the propane tank.
wish I had thought to look there first. A PO must have moved it for easier servicing. dinoburb,
it had been run a six weeks ago I let it run for about 15 minutes and shut it down.
A couple of weeks ago I took it out to refuel and go for a ride and it quit about a mile out..and would not restart. good test of the ERS ..that worked ok.
i'll do the test when I replace the filter. I do not know when the last service was done and the last owner went on to that final rally in the sky. I guess he got a good laugh watching me hunt for that filter.
thanks for all for the advice about the rod.

jpurdy 04-06-2004 09:58 PM

dinoburb ,
I noticed that everything in your signature is vintage, even the A6.

dinoburb 04-06-2004 10:08 PM

Bingo! I'm even vintage!!! Like a fine wine (whine) I simply get better with age!

Take care,


All times are GMT -6. The time now is 05:37 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.