Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-31-2019, 08:48 PM   #1
3 Rivet Member

 
2019 30' Classic
Pleasant Garden , North Carolina
Join Date: Oct 2018
Posts: 164
Water pump question

While camping last weekend we tried to use our water pump to increase water pressure when showering. Went to the Czone panel and turned on the water pump but saw no difference. Disconnected city water and discovered that our water pump wasn't working. Any suggestions what to check first?
__________________

jlandreth is offline   Reply With Quote
Old 05-31-2019, 09:14 PM   #2
Rivet Master
 
A W Warn's Avatar

 
2000 25' Safari
1999 34' Excella
Davidson County , North Carolina
Join Date: Aug 2006
Posts: 3,717
Make sure the switches for the pump are in the on position.
Check that all of the wires are connected to the pump or to each other (complete circuit).
Use a meter to check for 12v DC power at the pump.
If there is power at the pump, start looking at the pump components (pressure switch, etc)
__________________

__________________
Alan
2014 Silverado 1500 Crew Cab 5.3L maximum trailering package
A W Warn is offline   Reply With Quote
Old 05-31-2019, 11:47 PM   #3
Rivet Master
 
2018 25' Flying Cloud
Portland , Oregon
Join Date: Oct 2017
Posts: 529
If by not working you mean you hear it come on but little water flows that could just be it needs to prime itself. That can take quite a while, it takes ours ten minutes sometimes.
daleyocum is online now   Reply With Quote
Old 05-31-2019, 11:53 PM   #4
Rivet Master
 
ROBERTSUNRUS's Avatar

 
2005 25' Safari
Salem , Oregon
Join Date: Mar 2006
Posts: 7,708
Images: 18
Blog Entries: 55
This may sound stupid, but

Hi, this may sound stupid, but it has been admitted on this forum several times. Is there any water in the fresh water tank? [and don't trust the tank monitor, they lie]
__________________
Bob

2005 Safari 25-B
"Le Petit Chateau Argent"
[ Small Silver Castle ]
2000 Navigator / 2014 F-150 Eco-Boost / Equal-i-zer / P-3
YAMAHA 2400 / AIR #12144
ROBERTSUNRUS is offline   Reply With Quote
Old 06-01-2019, 05:04 AM   #5
Rivet Master
 
2014 20' Flying Cloud
Long Island , New York
Join Date: Jun 2015
Posts: 10,444
Quote:
Originally Posted by jlandreth View Post
While camping last weekend we tried to use our water pump to increase water pressure when showering. Went to the Czone panel and turned on the water pump but saw no difference. Disconnected city water and discovered that our water pump wasn't working. Any suggestions what to check first?

Good suggestions so far. Is there water in your tank, and have you ever used the pump? If you can solve the apparent lack of 12-volt electric to the pump, be sure to open all the hot and cold faucets when you start the pump, until all air is out of the system. [incl. outdoor shower].

Good luck,

Peter

PS -- Check your 12-volt distribution panel and the circuit breakers for a tripped CB to the pump. Also . . . consult your owner's manual's troubleshooting section in the back of the book.
OTRA15 is online now   Reply With Quote
Old 06-01-2019, 05:51 AM   #6
3 Rivet Member

 
2019 30' Classic
Pleasant Garden , North Carolina
Join Date: Oct 2018
Posts: 164
Appreciate the suggestions. Water tank is full, opened all the faucets but don't hear the pump come on. It is the first time I have tried to use it. I will check connections this morning.
jlandreth is offline   Reply With Quote
Old 06-01-2019, 06:27 AM   #7
Rivet Master
 
Currently Looking...
Gainesville , Florida
Join Date: Jul 2005
Posts: 6,948
Blog Entries: 2
Is the switch on if it has one!?
xrvr is offline   Reply With Quote
Old 06-01-2019, 06:35 AM   #8
3 Rivet Member

 
2019 30' Classic
Pleasant Garden , North Carolina
Join Date: Oct 2018
Posts: 164
Update. This morning cut everything off in the trailer then turned the pump on at the Czone panel. I opened up all the faucets. I can hear the pump running but nothing comes out of any location. Is there a valve on the Classic that needs to be opened?
jlandreth is offline   Reply With Quote
Old 06-01-2019, 06:43 AM   #9
Rivet Master
 
2014 20' Flying Cloud
Long Island , New York
Join Date: Jun 2015
Posts: 10,444
Thanks for the updates.

Progress!

You might have an air leak at the plumbing connections at the pump, so you will have to find it to check them. I seem to recall that your Classic pump is buried somewhere, and will look for relevant posts when I get back home later. Look at the list of topics in this sub-forum, and you will probably find a recent thread on point.

BTW, you have to open ALL faucets hot and cold incl. exterior shower to get all air out of system to help the pump get its prime.

Oh . . . any chance your AS was winterized and the hose from the water tank to the pump was never connected again? Also there may be a winterizing feed for antifreeze at the pump which needs to be adjusted?

In any event, find the pump is the next step IMO.

Good luck,

Peter

PS — Did you reverse your Winterization?

http://www.airforums.com/forums/f540...ze-192665.html
OTRA15 is online now   Reply With Quote
Old 06-01-2019, 07:05 AM   #10
3 Rivet Member

 
2019 30' Classic
Pleasant Garden , North Carolina
Join Date: Oct 2018
Posts: 164
Thanks Peter, I will try to find the pump. I did reverse the winterization. I also had to winterize again after we used it the first time because we had about a week of sub freezing weather after our first trip. Btw, all faucets were open with the pump running but no water appeared.
jlandreth is offline   Reply With Quote
Old 06-01-2019, 07:37 AM   #11
3 Rivet Member

 
2019 30' Classic
Pleasant Garden , North Carolina
Join Date: Oct 2018
Posts: 164
Problem solved. When I dewinterized I neglected to turn the winterization valve at the pump back to normal use position. Works as it should, sorry for wasting everyone's time.
jlandreth is offline   Reply With Quote
Old 06-01-2019, 08:49 AM   #12
Rivet Master
 
SteveSueMac's Avatar

 
2012 27' Flying Cloud
W , New England
Join Date: Oct 2012
Posts: 6,826
Not a waste of time at all. Others can learn on the tuition each of us pays to the school of hard knocks. All good - glad you got it sorted out!
SteveSueMac is offline   Reply With Quote
Old 06-01-2019, 10:18 AM   #13
Rivet Master
 
Currently Looking...
Gainesville , Florida
Join Date: Jul 2005
Posts: 6,948
Blog Entries: 2
Thats how we learn!
xrvr is offline   Reply With Quote
Old 06-01-2019, 11:30 AM   #14
Rivet Master
 
2014 20' Flying Cloud
Long Island , New York
Join Date: Jun 2015
Posts: 10,444
All good . . . no worries.

OTRA! [On The Road Again!]

__________________

OTRA15 is online now   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pump doesn't turn off and it doesn't pump water either. I don't know what to do! Melimelo Fresh Water Systems 10 05-25-2018 01:39 PM
Hooked up water in winter and can't get water pump to pump water mrpettit Water Heaters, Filters & Pumps 8 05-06-2015 06:46 PM
Pump in RV Antifreeze Downstream from the Water Pump? KJRitchie Winterizing, Storage, Carports & Covers 6 01-09-2015 01:18 PM
air pump vs water pump kamo Water Heaters, Filters & Pumps 22 02-27-2008 02:01 PM
68 water pump-should the pump cycle? Boondocker Water Heaters, Filters & Pumps 8 08-06-2006 10:11 AM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:59 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.