Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-19-2012, 01:01 PM   #1
2 Rivet Member
 
Terratravels's Avatar
 
2011 27' FB Flying Cloud
2008 16' International
Dunedin , Florida
Join Date: Sep 2008
Posts: 29
Dometic CCC 2 Thermostat (12 button style)

Outside temp on control center reads 81 (here in FL) Inside temp reads 51. Fan runs but AC will not cycle on.
__________________

__________________
Terratravels is offline   Reply With Quote
Old 10-19-2012, 01:05 PM   #2
Rivet Master
 
dznf0g's Avatar

 
2007 30' Classic
Oswego , Illinois
Join Date: Jul 2010
Posts: 9,400
Images: 5
I don't own one of these, but my-bro-in-law was having all sorts of weird stuff going on a couple of weeks ago. There is a reset procedure in you manual that basically "hard boots" it. Tried that, and all was well.

It appears, per dealer, that if you get confused and confuse it by starting to press buttons at random, it goes nutso. Reboot and read how to operate the functions and set programs. Follow closely. Not very user friendly till you get the hang of it.
__________________

__________________
-Rich-

"If the women don't find you handsome, they should at least find you handy." - Red Green
dznf0g is offline   Reply With Quote
Old 10-19-2012, 01:06 PM   #3
Rivet Master
 
dznf0g's Avatar

 
2007 30' Classic
Oswego , Illinois
Join Date: Jul 2010
Posts: 9,400
Images: 5
He actually had one A/C running and one heat pump running at the same time!
__________________
-Rich-

"If the women don't find you handsome, they should at least find you handy." - Red Green
dznf0g is offline   Reply With Quote
Old 10-19-2012, 01:13 PM   #4
2 Rivet Member
 
Terratravels's Avatar
 
2011 27' FB Flying Cloud
2008 16' International
Dunedin , Florida
Join Date: Sep 2008
Posts: 29
I do not have the manual. This used unit was missing a few things. I have found the
The manual online but cannot seem to find it today. Perhaps bc I am hot! I know there's a a little voo doo hoodoo that resets it.
I have not had this particular problem before.
__________________
Terratravels is offline   Reply With Quote
Old 10-19-2012, 01:48 PM   #5
Rivet Master
 
dznf0g's Avatar

 
2007 30' Classic
Oswego , Illinois
Join Date: Jul 2010
Posts: 9,400
Images: 5
Bottom of page 18 is the reset instruction. Bookmark this page and you can print out later, when you're not hot!

I think this is your model.....


http://www.dometic.com/1f24ead8-6316...87ce6bad.fodoc
__________________
-Rich-

"If the women don't find you handsome, they should at least find you handy." - Red Green
dznf0g is offline   Reply With Quote
Old 10-19-2012, 01:49 PM   #6
Rivet Master
 
dznf0g's Avatar

 
2007 30' Classic
Oswego , Illinois
Join Date: Jul 2010
Posts: 9,400
Images: 5
Wait, that's the CCC 1. Hold on a minute I'll find it.
__________________
-Rich-

"If the women don't find you handsome, they should at least find you handy." - Red Green
dznf0g is offline   Reply With Quote
Old 10-19-2012, 01:53 PM   #7
Rivet Master
 
dznf0g's Avatar

 
2007 30' Classic
Oswego , Illinois
Join Date: Jul 2010
Posts: 9,400
Images: 5
http://bryantrv.com/docs2/docs/opera...314150.016.pdf

http://dodgenmobiletech.com/sites/de...Roof%20Air.pdf

Page 11 of the second link has the reset procedure
__________________
-Rich-

"If the women don't find you handsome, they should at least find you handy." - Red Green
dznf0g is offline   Reply With Quote
Old 10-19-2012, 07:47 PM   #8
Rivet Master
 
richinny's Avatar
 
2011 34' Classic
Westchester Cty.NY , / Miami FL
Join Date: Jul 2007
Posts: 3,122
i had an issue with the connector inside the ac getting wet.
http://www.airforums.com/forums/f427...out-94680.html
__________________
Ricky
2012 F150 Super Crew 5-1/2' bed Ecoboost 4x4 3.73 elec. lock diff. Propride hitch
give life. kidney & pancreas transplant 9/9/06
Ingrid-my unofficial '"World's Oldest Streamer" 1909-2008 R.I.P.
richinny is offline   Reply With Quote
Old 10-20-2012, 06:52 AM   #9
2 Rivet Member
 
Terratravels's Avatar
 
2011 27' FB Flying Cloud
2008 16' International
Dunedin , Florida
Join Date: Sep 2008
Posts: 29
The reset did not work this time. My inside temp shows 0. I guess there is a short in the thermostat. I left the unit off all night because sometimes that has helped the reset cycle. I did down load the manual to iBooks this time. :-)
Thanks!
__________________
Terratravels is offline   Reply With Quote
Old 10-20-2012, 08:54 AM   #10
Prairie Schooner II
 
Jim Flower's Avatar

 
2012 30' International
1997 25' Safari
1967 20' Globetrotter
Burlington , Ontario
Join Date: Jul 2009
Posts: 1,182
Quote:
Originally Posted by richinny
i had an issue with the connector inside the ac getting wet.
http://www.airforums.com/forums/f427...out-94680.html
The same fix worked on my identical problem. The telephone connector simply was not plugged in correctly when the thing was built.
__________________
Jim
Jim Flower is offline   Reply With Quote
Old 10-20-2012, 09:59 AM   #11
Rivet Master
 
richinny's Avatar
 
2011 34' Classic
Westchester Cty.NY , / Miami FL
Join Date: Jul 2007
Posts: 3,122
Quote:
Originally Posted by Jim Flower View Post
The same fix worked on my identical problem. The telephone connector simply was not plugged in correctly when the thing was built.
mine was plugged in ok but had water in it. i had to unplug the wires, paper towel the ends and blow dry the connector with a hair drier. i made a shield for the connector with some plastic food wrap.
__________________
Ricky
2012 F150 Super Crew 5-1/2' bed Ecoboost 4x4 3.73 elec. lock diff. Propride hitch
give life. kidney & pancreas transplant 9/9/06
Ingrid-my unofficial '"World's Oldest Streamer" 1909-2008 R.I.P.
richinny is offline   Reply With Quote
Old 10-20-2012, 04:34 PM   #12
Prairie Schooner II
 
Jim Flower's Avatar

 
2012 30' International
1997 25' Safari
1967 20' Globetrotter
Burlington , Ontario
Join Date: Jul 2009
Posts: 1,182
Good job on the fix. So much effort for such a small but significant problem. Hope others can benefit and save some time and money.
__________________
Jim
Jim Flower is offline   Reply With Quote
Old 10-22-2012, 07:53 AM   #13
2 Rivet Member
 
Terratravels's Avatar
 
2011 27' FB Flying Cloud
2008 16' International
Dunedin , Florida
Join Date: Sep 2008
Posts: 29
After being off for 24 hours the unit reset itself.
The inside temperature gage cycled I to the negative numbers...below zero. Interesting.
I think the trick to this unit regarding high humidity is to keep the fan on high at all times when the unit is on Cool.
I have been advised to do that in the past but I had it set on automatic as we are getting chilly nights and not so hot but still very humid days.
The trick is to not build up any condensation inside the box.
My connections inside the box look high and dry so I was pleased to try the unit "one more time" before tearing it apart only to find it was reading normal temps and cycles on and off normally.
Thanks for all the advice. I'm sure this finicky little
Unit has more in store for me. I think getting the cover off and scaring it with tools works as well as anything!
__________________

__________________
Terratravels is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:36 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.