Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-15-2013, 07:31 PM   #1
3 Rivet Member
 
2009 34' Panamerica
weyburn , Saskatchewan
Join Date: Dec 2012
Posts: 103
My Atwood 8500 furnace will not light

Was just trying out furnace on new to me 2009 airstream and furnace will not fire. It did work a couple times but today would not at all. It would start and stop fan really fast about 3 time and on fourth try fan would keep running longer but no igntion or ignition noise then shut off and light would flash on circuit board one flash every three second. The manual says light means there is limit switch/airflow problem. Where is air sucked in for furnace is it under fridge and sucked in from top of heater box. If it is there there is a crazy amount of dog hair under there from previous owner dog I take and how would I clean out intake. Thanks for any help.
__________________

Pedecanada is offline   Reply With Quote
Old 01-15-2013, 10:47 PM   #2
Rivet Master
 
TG Twinkie's Avatar
 
1974 Argosy 26
Morrill , Nebraska
Join Date: Nov 2009
Posts: 5,652
Images: 2
Blog Entries: 5
The furnace draws it's combustion air from outside. Go outside and you will see two holes in the side of the trailer where the furnace is located. One is the intake (fresh air) the other is the exhaust. Make sure neither is blocked. Mud daubers build there nests and lay eggs in the intake and exhaust ports. It may be necessary to clean out the tubes.
__________________

__________________
Knowledge: "A gift to be shared. A treasure to receive."
TG Twinkie is online now   Reply With Quote
Old 01-15-2013, 11:03 PM   #3
3 Rivet Member
 
2009 34' Panamerica
weyburn , Saskatchewan
Join Date: Dec 2012
Posts: 103
Thanks for hint I will check. It seems like there is alot of dog hair and lent under fridge like there is air moving under it for furnace or it might be caused by outside air vent being pluged.
Pedecanada is offline   Reply With Quote
Old 01-16-2013, 04:34 PM   #4
3 Rivet Member
 
2009 34' Panamerica
weyburn , Saskatchewan
Join Date: Dec 2012
Posts: 103
I did the hit left corner of heater box to dislode switch and it worked five time after no problems. This fourm is great help.
Pedecanada is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.