Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-16-2017, 07:23 PM   #1
2 Rivet Member
 
2017 30' Classic
Wellfleet , Massachusetts
Join Date: Oct 2016
Posts: 27
Picked up new 2017 Classic no shore power?

Hope some one can help. We picked up our new 30 Classic. Stayed overnight at the dealer last night and everything worked fine. Just arrived at our first stop an the way home. Plugged in our new progressive EMS-PT50X surge protector and plugged in to shore power...the surge protector displays....but no power to our trailer .... we get the following display:
E-0
L-1
123
1A
L-2
123
2A
60H

We called progressive....got voice mail....any thoughts???
__________________

__________________
Joellen is offline   Reply With Quote
Old 06-16-2017, 07:31 PM   #2
Rivet Master
 
The Colonel's Avatar
 
2017 25' Flying Cloud
Navarre , Florida
Join Date: Dec 2015
Posts: 575
Take out the sp and do you have power?
__________________

__________________
The Colonel and Southern Belle
The Colonel is offline   Reply With Quote
Old 06-16-2017, 07:37 PM   #3
4 Rivet Member
 
2012 30' Classic
Homosassa , Florida
Join Date: Nov 2010
Posts: 452
Check the breakers inside the trailer to make sure the main isn't tripped. Also, make sure you twisted the connection to the trailer before you tightened the threaded ring.
__________________
Tater is offline   Reply With Quote
Old 06-16-2017, 07:39 PM   #4
Well Preserved

 
1993 21' Sovereign
Colfax , North Carolina
Join Date: Jun 2003
Posts: 20,193
How long did you wait before panicking? They have a "pause" of up to several minutes before allowing power to flow.
You also need to make sure the use/store switch in on.
Failing everything else, unplug the surge protector, and try power without it.
__________________
Meddle not in the affairs of dragons, for you are crunchy, and taste good with ketchup.
Terry
overlander63 is offline   Reply With Quote
Old 06-16-2017, 07:44 PM   #5
2 Rivet Member
 
2017 30' Classic
Wellfleet , Massachusetts
Join Date: Oct 2016
Posts: 27
It may be working now...

So the power came on and the AC is running....but on the control panel display the DC Power is darkened....does that mean on or off?
__________________
Joellen is offline   Reply With Quote
Old 06-16-2017, 07:49 PM   #6
Rivet Master
 
Al and Missy's Avatar

 
2002 30' Classic S/O
Melbourne Beach , Florida
Join Date: Nov 2013
Posts: 2,322
From the manual - If the digital display is illuminated, reading an E 0 error code, yet
you have no power in the RV, please contact Progressive Industries Tech
Support. Please remember you must wait the 2 minutes 16 seconds (136
seconds) for the time delay countdown.

I think it is telling you that you have 123 volts on both Line 1 and Line 2, and line 1 is drawing 1 amp and line 2 is drawing 2 amps. Did you wait the delay time out? Have you checked the breakers in the trailer?

Had you used the surge protector before? Have you tried it without the surge protector?

Al
__________________

"You cannot reason someone out of a position they have not been reasoned into"

Al, K5TAN and Missy, N4RGO
2002 Classic 30 Slideout
S/OS #004
2013 Dodge 2500 Laramie 4x4 Megacab Cummins
2001 Safari 25 RB Twin (Gone, but not forgotten)
WBCCI 1322, TAC FL-39, AIR 82265

Al and Missy is offline   Reply With Quote
Old 06-16-2017, 08:44 PM   #7
Rivet Master
 
Llando88's Avatar
 
2016 30' Flying Cloud
Tampa , Florida
Join Date: Jun 2015
Posts: 655
Quote:
Originally Posted by Joellen View Post
So the power came on and the AC is running....but on the control panel display the DC Power is darkened....does that mean on or off?

If you are talking about the Progressive unit's 'control panel' display, if you have power in the coach but no rolling status displayed in the panel, you have a fault and need to contact Progressive.
__________________
2016 30' Flying Cloud / 2016 Ram 2500 Diesel 4x4

“Character is doing the right thing when nobody’s looking. There are too many people who think that the only thing that’s right is to get by, and the only thing that’s wrong is to get caught.” - J.C. Watts Jr.
Llando88 is online now   Reply With Quote
Old 06-21-2017, 03:48 PM   #8
Rivet Master
 
JFScheck's Avatar
 
Vintage Kin Owner
Rockville , Maryland
Join Date: Mar 2010
Posts: 1,474
Images: 33
Stupid question, but do you have all breakers at the power junction box enabled to ensure you are getting both phases of power to the Airstream?
__________________
John "JFScheck" Scheck
2015 Roadtrek CS Adventurous XL
2015 Mercedes Sprinter 3500 XL Chassis with Mercedes BlueTec V6 Diesel
**I Love U.S.A.**
JFScheck is offline   Reply With Quote
Old 06-21-2017, 04:25 PM   #9
Half a Rivet Short
 
2017 30' Classic
Carlisle , Pennsylvania
Join Date: May 2017
Posts: 3,527
Hi

The first E-0 means that all is well with the surge suppressor. E (any other number) is something you need to dig into. The timeout freaks me out each time I hook up. There is just enough time to go find out that nothing is working, kick this and that and then get back to see all is well with the suppressor.

Power up - there's a red button on the main panel just inside the screen door. It needs to be "on" to enable 12V to all the "stuff". Turn it off and everything dies. Just above that are the internal and external masters. Punch them both to "on" just in case.

Lighting on the various panels is controlled at the panel (bed panels) or on the master by the Alde control (area above the main TV. Alde turns on independently of the other stuff. The HVAC is run on the panel under the BluRay player. It lights up when you punch a button.

Breakers for the 12V and FireFly stuff are under the right hand wardrobe door (behind the wood panel at the floor). The main AC breakers are behind the wood panel to the left, under the wardrobe. To get to them, you open the black door that is behind the wood panel.

Hopefully you have a circuit tester. Ours is plugged into the outlet by the stove. It lights up to show you that AC is present and there are no serious issues. If you didn't get one from your dealer, stop by Home Depot or Lowes and pick one up. It's a really good way to verify that you have shore power hooked up.

So much fun !!!!

Bob
__________________

__________________
uncle_bob is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
picked up my 2017 FC 19C bunk yesterday Roguegaston 2005 and newer - Bambi all models 9 06-16-2016 10:48 PM
Shore power but no battery power RogerLG Lights - Interior & Exterior 6 09-28-2012 02:53 PM
shore power/battery power wiring NavyDavesCvl Electrical - Systems, Generators, Batteries & Solar 0 10-13-2010 07:32 PM
Power surging from shore power in my Excella 500? NVDeputy Lights - Interior & Exterior 4 10-09-2009 12:52 PM
Shore power and battery power problems jfremstad Electrical - Systems, Generators, Batteries & Solar 5 05-03-2007 09:23 AM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:41 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.