Thread Tools Search this Thread Display Modes
Old 04-03-2014, 06:57 PM   #1
SRW's Avatar
Georgetown , Texas
Join Date: Nov 2007
Posts: 291
Connect Trouble

I tow my AS with a 2013 F150 Platinum.

The truck's computer continually changes from "Connected to "Disconnected". When the truck thinks the trailer is disconnected the truck's computer stops tracking tow mileage for the trailer.

However, the trailer's lights work and more importantly the brakes work perfectly when I step on the brake pedal even when the on board computer says "Disconnected".

Even when the truck is not moving [/COLOR]the truck's computer switches fro "Connected" to "Disconnected".

The same thing occurs when the plug is held in place with a small bungee cord.

I stopped at a Camping World when I was on the road and they were unable to stop the problem from happening.

I just got back from a 2 month trip and have not yet talked to Ford or Airstream.

Any thoughts?

SRW is offline   Reply With Quote
Old 04-03-2014, 08:36 PM   #2
Rivet Master
pappy19's Avatar

2002 30' Classic S/O
Garden Valley , Idaho
Join Date: Jul 2010
Posts: 1,256
Go to a really good Ford dealer and talk to their service manager about the problem and ask if they know of any TSB's for that problem (Technical Service Bulletin) or if they have had any experience fixing such a problem. If negative, then go or call another Ford dealer. Also, if possible, hook your AS up to a different TV and see if you get the same problem. Go forward accordingly.

2008 F-250 4X4 Lariat V-10
2002 Airstream Classic 30' w/SO #2074
2007 Kubota 900 RTV
1996 Ford Bronco
2007 Lincoln LT
pappy19 is offline   Reply With Quote
Old 04-04-2014, 09:03 AM   #3
SRW's Avatar
Georgetown , Texas
Join Date: Nov 2007
Posts: 291
Thanks for the comments. You have confirmed the direction I have decided to take. I don't hold out much hope for Ford, but maybe I will be surprised.

Will probably wait until The THLU rally in May to hook up to another truck or to another trailer.
SRW is offline   Reply With Quote
Old 10-20-2014, 02:55 PM   #4
SRW's Avatar
Georgetown , Texas
Join Date: Nov 2007
Posts: 291
Smile Problem Solved: And it wasn't a compatibility issue:

My Airstream dealer did a very good job checking out the7 pin connector/open ground/ whatever and found nothing wrong with the trailer. My Ford dealer checked out the f150's female 7 pin connector and found nothing wrong.

Nonetheless, my truck a 2013 F150 continued to switch from "CONNECT" to "Disconnect". Understand that I have towed the Airstream over 7,500 miles with this truck with zero problems.

To discover which the truck or the trailer was the problem I had my neighbor's F150 2013 connected to the trailer. The result was that his truck stayed "CONNECTED" to the trailer proving (pretty much) that the problem is with my truck and not the Airstream.

With that info I got back with my dealer with both my truck and trailer (Which, by the way, they refused to look at previously.).

The dealer finally did what they should have done in the first place: They proved to themselves that the problem was indeed with the Ford and not the Airstream.

It took about two hours, but when they reprogrammed the appropriate computer module back to the base configuration the problem solved was solved.

In, fact the Ford guys were very polite, professional and while it took awhile I have little to complain about.

Allan, the tech at Camper Clinic II in Buda, TX was more then professional and for that I am appreciative. He pretty much refused to replace the trailer's 7 pin connector that would have not solved the problem and just cost me more money.

Thought you would like to know how this issue was resolved.
SRW is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
LP Quick Connect for Gas Grill Mod-Streamer LP Gas, Piping, Tanks & Regulators 13 06-10-2015 04:20 PM
New airstreamer..How I connect the power cord to test the appliances and AC yam777 Member Introductions 5 08-21-2006 08:06 PM
A new kind of quick connect 12V outlet Westfalia Electrical - Systems, Generators, Batteries & Solar 3 09-04-2005 06:26 PM
why does the heat duct connect to the black water tank jgouras Furnaces, Heaters, Fireplaces & Air Conditioning 5 08-27-2004 02:28 PM
I want to connect permanently to local sewer Jaime Esparza Waste Systems, Tanks & Totes 1 09-09-2002 08:49 AM

Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:29 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.