Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-15-2013, 09:18 PM   #1
2 Rivet Member
 
Minipad's Avatar
 
2013 23' FB International
2013 25' Flying Cloud
In the Rockies, 6700' , Colorado
Join Date: Nov 2012
Posts: 48
Odd Dometico thermostat function

I have a 2013 Flying Cloud that I just winterized about a month ago. I went to turn on the furnace and when I powered up the Dometico thermostat, it would not start the furnace. I performed a reset on the thermostat along with verifying that all breakers and fuses were good. Inside temp was 38F with the furnace temp set to 68F. I expected to hear a click in the thermostat when I powered it up, however none noted. I left the trailer with the thermostat powered up in furnace mode. I went to check it out about 2 hours later and the furnace had started. It apparently had just begun to run before I checked because the blower was still putting out cold air but then warmed within a few minutes. I am about to hit the road for some winter travel in the Utah desert and have some concerns about the reliability of the thermostat. Anyone have any thoughts on what might have happened or the reliability of the thermostat?
__________________
Minipad is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 04:14 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.