Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-13-2008, 08:18 AM   #1
cwv
1 Rivet Member
 
cwv's Avatar
 
1970 31' Sovereign
cookeville , Tennessee
Join Date: Oct 2008
Posts: 10
Images: 1
Question Need help

ok i put a new radio in my airstream and it has a loud buzzing noise thorugh the spearkers.i thank it is from the charging univolt maybe ..any ideals .thanks CW.V
__________________

__________________
cwv is offline   Reply With Quote
Old 10-13-2008, 08:24 AM   #2
Site Team
 
azflycaster's Avatar
 
1975 25' Tradewind
Dewey , Arizona
Join Date: Mar 2005
Posts: 12,127
Images: 62
Blog Entries: 1
Try it on just the battery, no shore power. I had noise from a light switch which I then replaced.
__________________

__________________

Richard

Wally Byam Airstream Club 7513
azflycaster is online now   Reply With Quote
Old 10-13-2008, 08:33 AM   #3
Rivet Master
 
Lumatic's Avatar

 
1971 25' Tradewind
1993 34' Excella
Currently Looking...
Estancia , New Mexico
Join Date: Feb 2005
Posts: 6,642
Images: 16
Blog Entries: 1
What kind of radio? Is this a replacement? Any similar problems with previous radio? Does it buzz when both the trailer is hooked up to 110 and only running on 12v? Is your 110 polarity correct? What happens with only one speaker hooked up? Did you check your speakers are not hooked up out of phase (+ an - mismatch) Are you sure you have a good ground? Can you contact the manufacturer for a troubleshooting list?
__________________
Sail on silver girl. Sail on by. Your time has come to shine.
Lumatic is offline   Reply With Quote
Old 10-13-2008, 08:34 AM   #4
cwv
1 Rivet Member
 
cwv's Avatar
 
1970 31' Sovereign
cookeville , Tennessee
Join Date: Oct 2008
Posts: 10
Images: 1
I did that and no more noise .what can i do to fix the problem
__________________
cwv is offline   Reply With Quote
Old 10-13-2008, 08:37 AM   #5
cwv
1 Rivet Member
 
cwv's Avatar
 
1970 31' Sovereign
cookeville , Tennessee
Join Date: Oct 2008
Posts: 10
Images: 1
I am new to this forum .and just wondering ,does anybody usethe chat room ...thanks
__________________
cwv is offline   Reply With Quote
Old 10-13-2008, 08:40 AM   #6
Rivet Master
 
Lumatic's Avatar

 
1971 25' Tradewind
1993 34' Excella
Currently Looking...
Estancia , New Mexico
Join Date: Feb 2005
Posts: 6,642
Images: 16
Blog Entries: 1
Quote:
Originally Posted by cwv View Post
I am new to this forum .and just wondering ,does anybody usethe chat room ...thanks
Mostly Tueday nights
__________________
Sail on silver girl. Sail on by. Your time has come to shine.
Lumatic is offline   Reply With Quote
Old 10-13-2008, 08:42 AM   #7
Rivet Master
 
Lumatic's Avatar

 
1971 25' Tradewind
1993 34' Excella
Currently Looking...
Estancia , New Mexico
Join Date: Feb 2005
Posts: 6,642
Images: 16
Blog Entries: 1
Quote:
Originally Posted by cwv View Post
I did that and no more noise .what can i do to fix the problem
Not sure what you did. Turned off a switch? Then the switch is shorted. Fix or replace.
__________________
Sail on silver girl. Sail on by. Your time has come to shine.
Lumatic is offline   Reply With Quote
Old 10-13-2008, 08:42 AM   #8
cwv
1 Rivet Member
 
cwv's Avatar
 
1970 31' Sovereign
cookeville , Tennessee
Join Date: Oct 2008
Posts: 10
Images: 1
the radio that came in it did not work ..just traded for my airstream about a week ago .pleanty of bugs to work out of it ..thanks
__________________
cwv is offline   Reply With Quote
Old 10-13-2008, 08:46 AM   #9
cwv
1 Rivet Member
 
cwv's Avatar
 
1970 31' Sovereign
cookeville , Tennessee
Join Date: Oct 2008
Posts: 10
Images: 1
sorry i unpluged it from 110 and the radio worked no noise
__________________
cwv is offline   Reply With Quote
Old 10-13-2008, 08:47 AM   #10
cwv
1 Rivet Member
 
cwv's Avatar
 
1970 31' Sovereign
cookeville , Tennessee
Join Date: Oct 2008
Posts: 10
Images: 1
good i will check tuesday nite thanks
__________________
cwv is offline   Reply With Quote
Old 10-13-2008, 08:49 AM   #11
Rivet Master
 
SteveH's Avatar
 
2005 39' Land Yacht 390 XL 396
Common Sense , Texas
Join Date: Sep 2007
Posts: 5,311
The older Uni-volt converters are notorious for causing noise in the radio. The filter capacitors go bad and that is what causes the AC noise in the radio. The best thing to do IMHO is replace the converter with a new better quality, and better filtered converter.

You might want to look at the converters offered here: Xantrex TrueCharge RV XADC
__________________

__________________
Regards,
Steve
SteveH is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.