Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-20-2013, 08:06 PM   #1
1 Rivet Member
 
Currently Looking...
Rockville Centre , New York
Join Date: Jun 2009
Posts: 14
TV not working

My winegard booster will not light when press on and no tv reception can someone tell me. If my booster is bad thank u
__________________

__________________
Josie28 is offline   Reply With Quote
Old 02-20-2013, 08:54 PM   #2
Rivet Master
 
dznf0g's Avatar

 
2007 30' Classic
Oswego , Illinois
Join Date: Jul 2010
Posts: 9,409
Images: 5
Possibly.
1) Check your fuses.
2) If fuse is ok, remove the amplifier from the wall and test for 12 volts at the back of it.
3) Check the ground wire with an ohmmeter to trailer skin.
4) If 12v is present and ohmmeter shows continuity, amp is probably bad.

I have a stock one which I removed when I upgraded to one that shows signal strength. If I can find it, you're welcome to it.
__________________

__________________
-Rich-

"If the women don't find you handsome, they should at least find you handy." - Red Green
dznf0g is offline   Reply With Quote
Old 02-20-2013, 10:35 PM   #3
4 Rivet Member
 
wolverine's Avatar
 
2005 31' Classic
Sunrise Beach , Missouri
Join Date: Jun 2007
Posts: 251
Quote:
Originally Posted by dznf0g View Post
Possibly.
1) Check your fuses.
2) If fuse is ok, remove the amplifier from the wall and test for 12 volts at the back of it.
3) Check the ground wire with an ohmmeter to trailer skin.
4) If 12v is present and ohmmeter shows continuity, amp is probably bad.

I have a stock one which I removed when I upgraded to one that shows signal strength. If I can find it, you're welcome to it.
What model amplifier did you select when you upgraded yours? Does it have the same connectors in back to attach the outside cable and the second tv cable? Sounds like this would be a good upgrade if everything connects the same.
__________________
wolverine is offline   Reply With Quote
Old 02-21-2013, 07:46 AM   #4
Rivet Master
 
dznf0g's Avatar

 
2007 30' Classic
Oswego , Illinois
Join Date: Jul 2010
Posts: 9,409
Images: 5
Hi Wolverine,

This is the one I got. It works really well...but a bit difficult to learn how to use. Not really intuitive, but does find the signal for you quickly once you get the steps down. Shop for best price...I just pulled down the first site I came across with a google search.

Sensar Pro TV Signal Meter - RVWholesalers.com RV Parts and Accessories

Edit: Yes same connections....plug and play. You do lose the 12V jack though.
__________________
-Rich-

"If the women don't find you handsome, they should at least find you handy." - Red Green
dznf0g is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'64 Dometic Fridge working fine...a relief! PA BAMBI II Refrigerators 0 11-10-2011 07:13 PM
RM2500 just stopped working TouringDan Refrigerators 6 09-25-2011 11:44 PM
light not working in 1962 Bambi (only 110 side) female.nomad Lights - Interior & Exterior 1 09-15-2011 01:53 PM
Electric working with battery not with 110 TX_DB Electrical - Systems, Generators, Batteries & Solar 11 04-24-2011 08:19 PM
License plate light not working worksology Lights - Interior & Exterior 7 04-08-2011 06:05 AM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:15 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.