Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-06-2017, 01:41 PM   #1
1 Rivet Member
 
Pendleton000's Avatar
 
Ridgefield , Washington
Join Date: Jun 2017
Posts: 9
Blu-ray player pushing no audio to TVs but does have picture.

Has anyone experienced this? I have a 2016 Airstream Pendleton edition. The Blu-ray player connects to the televisions in both the bedroom and the family room. We were watching a movie and everything was working perfectly. Both TVs were getting audio and video. Now for some reason the TVs are only getting video but no audio. I am pretty proficient with television and Blu-ray settings and have gone through both televisions' and the Blu-ray player's audio settings and everything appears to be set up correctly and all cords are connected correctly. The fact that neither TV will give sound but both will give picture would imply it's an issue with the Blu-ray player. However, as I said, they had been working perfectly fine earlier in the day. Only thing that changed was when we disconnected the power source for the Airstream and moved it to a different site. I purchased this trailer brand new in May so it's barely been touched. I have reached out to the dealer, however, without bringing it into them there isn't much they can offer in the way of a solution. It's obviously a bit of a pain to drag the trailer all the way there so at this point I'm just looking for any online suggestions. Any ideas on what could be going on?
__________________

Pendleton000 is offline   Reply With Quote
Old 07-06-2017, 01:49 PM   #2
Rivet Master
 
Mattirs's Avatar

 
2016 25' Flying Cloud
Fairfield , California
Join Date: Sep 2016
Posts: 858
Had the same exact thing happen to me but didn't have cell reception to post. The next day everything worked perfectly even though I didn't change a thing except flip the use/store switch. At the time I was dry camping and on battery power.
__________________

Mattirs is offline   Reply With Quote
Old 07-06-2017, 05:56 PM   #3
4 Rivet Member
 
tkowalyk's Avatar
 
2013 27' FB Classic
North Wales , Pennsylvania
Join Date: Mar 2007
Posts: 406
Images: 11
On my 2013 Classic, I have a Sony head unit. I need to turn the input on the Sony to CD Cartridge 2. This selection requires 2 selections - 1st is to select CD, then select Cartridge 2
__________________
Tom & Lori

2013 27 FB Classic Limited
2016 Nissan XD Turbo Diesel
WBCCI 03288 TAC PA-17
tkowalyk is offline   Reply With Quote
Old 07-06-2017, 06:09 PM   #4
1 Rivet Member
 
Pendleton000's Avatar
 
Ridgefield , Washington
Join Date: Jun 2017
Posts: 9
Quote:
Originally Posted by Mattirs View Post
Had the same exact thing happen to me but didn't have cell reception to post. The next day everything worked perfectly even though I didn't change a thing except flip the use/store switch. At the time I was dry camping and on battery power.


Thanks! I'll try that! I believe I was on "store" as I was plugged in to shore power, however, I'll try flipping back and forth a couple of times. Thanks for the response! I'm new to this. First outing last weekend!
Pendleton000 is offline   Reply With Quote
Old 07-06-2017, 06:34 PM   #5
Rivet Master
 
Llando88's Avatar
 
2016 30' Flying Cloud
Tampa , Florida
Join Date: Jun 2015
Posts: 656
Hmmm. Pretty weird.

I guess I would try to power off/reset the HDMI splitter in the electronics cabinet.

Or maybe reseat the HDMI cables on the Blue Ray?
__________________
2016 30' Flying Cloud / 2016 Ram 2500 Diesel 4x4

“Character is doing the right thing when nobody’s looking. There are too many people who think that the only thing that’s right is to get by, and the only thing that’s wrong is to get caught.” - J.C. Watts Jr.
Llando88 is offline   Reply With Quote
Old 07-06-2017, 06:36 PM   #6
1 Rivet Member
 
Pendleton000's Avatar
 
Ridgefield , Washington
Join Date: Jun 2017
Posts: 9
Great idea on the splitter. I did verify the HDMI cables were all plugged in but I will definitely try that with the splitter. Thank you!
Pendleton000 is offline   Reply With Quote
Old 07-07-2017, 12:07 AM   #7
Rivet Master
 
Llando88's Avatar
 
2016 30' Flying Cloud
Tampa , Florida
Join Date: Jun 2015
Posts: 656
Quote:
Originally Posted by Pendleton000 View Post
Great idea on the splitter. I did verify the HDMI cables were all plugged in but I will definitely try that with the splitter. Thank you!


And if that doesn't work, I'd bypass the splitter and try to drive one of the TVs directly off the BluRay with another HDMI cable.

If you have a laptop, it may have a HDMI output which you could use as another source to check if it's the TV or not.

It stinks having to do this stuff. Hope it's something simple.
__________________
2016 30' Flying Cloud / 2016 Ram 2500 Diesel 4x4

“Character is doing the right thing when nobody’s looking. There are too many people who think that the only thing that’s right is to get by, and the only thing that’s wrong is to get caught.” - J.C. Watts Jr.
Llando88 is offline   Reply With Quote
Old 07-07-2017, 03:14 PM   #8
4 Rivet Member
 
NWRVR's Avatar
 
2015 30' Classic
Sherwood , Oregon
Join Date: Mar 2015
Posts: 459
Blog Entries: 2
I had the same thing happen and found the audio out plug on the main TV was not seated completely probably due to repeatedly pulling TV out on the swing bracket to get at the antenna booster switch. Once reseated the audio worked fine.
__________________
2015 Classic 30A, Blue OX Sway Pro, 2016 F350 4x4 Ultimate Lariat crew cab SRW, LWB, 6.7 PSD, 20" wheels, Ingot Silver Metallic, DiamondBack tonneau cover, TrailFX wheel-to-wheel step bars.
Sold: 2014 25FB International Serenity
NWRVR is offline   Reply With Quote
Old 07-07-2017, 03:23 PM   #9
3 Rivet Member
 
jamieb1086's Avatar

 
2016 25' Flying Cloud
Selbyville , Delaware
Join Date: Jun 2015
Posts: 135
If you have the Clarion sound system, set it to AUX, play the disk and turn on BOTH TV's
(obviously set to HDMI 1). I have to play it on BOTH TV's to get the sound to come out the sound system speakers. Pretty funky if you ask me. The sound does come out of each TV's individual sound system, though. I have a 2016 Flying Cloud.
__________________
Jamie
2016 25' RBT Flying Cloud "Bullseye"
2016 Chevy 2500 High Country Duramax Diesel "Red Bull"
WBCCI #9026 Watchung NJ Unit
jamieb1086 is offline   Reply With Quote
Old 07-07-2017, 03:39 PM   #10
Rivet Master
 
Llando88's Avatar
 
2016 30' Flying Cloud
Tampa , Florida
Join Date: Jun 2015
Posts: 656
Quote:
Originally Posted by jamieb1086 View Post
If you have the Clarion sound system, set it to AUX, play the disk and turn on BOTH TV's
(obviously set to HDMI 1). I have to play it on BOTH TV's to get the sound to come out the sound system speakers. Pretty funky if you ask me. The sound does come out of each TV's individual sound system, though. I have a 2016 Flying Cloud.


That's pretty odd. I believe you, but pretty odd.

On my 16 FC 30J, the AUX audio to the Clarion M303 is sourced from the Dinette TV, via a couple RCA jacks.
__________________
2016 30' Flying Cloud / 2016 Ram 2500 Diesel 4x4

“Character is doing the right thing when nobody’s looking. There are too many people who think that the only thing that’s right is to get by, and the only thing that’s wrong is to get caught.” - J.C. Watts Jr.
Llando88 is offline   Reply With Quote
Old 07-07-2017, 03:45 PM   #11
Rivet Master
 
rodsterinfl's Avatar
 
2006 25' Safari
St. Augustine , Florida
Join Date: Oct 2011
Posts: 2,465
Images: 8
I believe the problem is related to HDMI handshaking protocol. I have this happen in my house all the time. I have a switcher and multi-sourcing like in the trailers and it will separate signal per se. I believe your fix to go from store to use on the power is resetting the power and confirming my theory. It all has to do with what is turned on when and also how many source. Go one at a time and try it.
__________________
WBCCI 8653/AIR 60240
2017 Ford F-150 3.5 Ecobeast Gen 2 3.55 Platinum
rodsterinfl is offline   Reply With Quote
Old 07-07-2017, 03:58 PM   #12
Rivet Master
 
AStreamNerds's Avatar
 
2015 25' FB Flying Cloud
Manassas , Virginia
Join Date: Mar 2015
Posts: 562
Images: 6
Quote:
Originally Posted by rodsterinfl View Post
I believe the problem is related to HDMI handshaking protocol. I have this happen in my house all the time. I have a switcher and multi-sourcing like in the trailers and it will separate signal per se. I believe your fix to go from store to use on the power is resetting the power and confirming my theory. It all has to do with what is turned on when and also how many source. Go one at a time and try it.
This is more likely the issue. You can correct by getting an HDMI repeater http://amzn.to/2u19NgO or even better replace the existing HDMI splitter with something that splits the signal and repeats it http://amzn.to/2uTz0WD

Good luck!
__________________
Our Website: https://airstreamnerds.com/

You Tube Channel "Airstream Nerds": https://www.youtube.com/airstreamnerds

Find Us on Facebook: https://www.facebook.com/AirstreamNerd/
AStreamNerds is offline   Reply With Quote
Old 07-07-2017, 04:08 PM   #13
1 Rivet Member
 
Pendleton000's Avatar
 
Ridgefield , Washington
Join Date: Jun 2017
Posts: 9
Thank you for the info! Heading to the lake this weekend and will try this. Thanks again!
Pendleton000 is offline   Reply With Quote
Old 07-07-2017, 05:20 PM   #14
Rivet Master
 
Llando88's Avatar
 
2016 30' Flying Cloud
Tampa , Florida
Join Date: Jun 2015
Posts: 656
Quote:
Originally Posted by AStreamNerds View Post
This is more likely the issue. You can correct by getting an HDMI repeater http://amzn.to/2u19NgO or even better replace the existing HDMI splitter with something that splits the signal and repeats it http://amzn.to/2uTz0WD



Good luck!


Thanks for this info.

I'm chasing an issue where my BluRay won't drive the splitter to either TV, but works fine direct to the TV with a separate HDMI cable.

I may look into this as a solution.
__________________
2016 30' Flying Cloud / 2016 Ram 2500 Diesel 4x4

“Character is doing the right thing when nobody’s looking. There are too many people who think that the only thing that’s right is to get by, and the only thing that’s wrong is to get caught.” - J.C. Watts Jr.
Llando88 is offline   Reply With Quote
Old 08-09-2017, 05:38 PM   #15
3 Rivet Member
 
abqdor's Avatar
 
2016 25' Flying Cloud
Albuquerque , New Mexico
Join Date: Aug 2015
Posts: 127
Same problem here, '16 25' Flying Cloud, with Samsung TV and Blue-ray player. I have picture, but no sound. Followed most of these suggestions, like turning Use/Store switch, different sequences of which device gets turned on first....and still nothing. Nothing on the TV and nothing from the Clarion receiver in Aux mode.

I wired directly between the player and TV with separate HDMI cable and sound now works.
What else could be keeping the sound from the TV and/or the Clarion? Is there a switch that I'm missing? I've gone pretty deep into the sound menus on both TV and Blu-ray and can find no combination that fixes the problem.
__________________
'17 Ford F-150 Ecoboost, max tow package
'13 GMC Yukon Denali 6.2L V8
'04 GMC Yukon SLT 5.3L V8
abqdor is offline   Reply With Quote
Old 08-09-2017, 07:57 PM   #16
Rivet Master
 
wulfraat's Avatar
 
2017 30' International
Broomfield , Colorado
Join Date: Apr 2009
Posts: 2,067
Images: 1
There is an hdmi splitter behind the DVD player (if you have 2 tvs) and that may be faulty.
wulfraat is offline   Reply With Quote
Old 08-10-2017, 12:20 PM   #17
3 Rivet Member
 
abqdor's Avatar
 
2016 25' Flying Cloud
Albuquerque , New Mexico
Join Date: Aug 2015
Posts: 127
Problem Solved

Wulfraat, you definitely sent me in the right direction as I didn't know where the splitter was hidden. The splitter is underneath the blu-ray player in the white laminate box on our 2016 25' FB Flying Cloud.

I had to remove three wood screws holding it to the rest of the cabinet in order to lift the box to reveal the splitter. After trying various HDMI cables from the player to the splitter and from the splitter to both TVs, I was still getting no sound.

Then I found this YouTube video that talked about a solution to the problem. It basically said that you need to hook up the main TV to the splitter before hooking up the second TV. In the AS, I assume the main is in the living area and the secondary is in the bedroom area.

So I turned player and TV's off and unplugged the bedroom TV at the splitter. Then I turned on the main TV, then the player and guess what, the audio was on the TV as well as through Aux on the Clarion receiver.

Then I plugged the bedroom TV back in at the splitter, turned the TV on and got sound on the bedroom TV also. I think it is related to a term called, HDMI "handshake", in which there is a certain order that things need to be energized.

Since the problem came from the factory this way, I assume they didn't follow the protocol and that's why it wasn't working. I did notice that the splitter has a 1 and 2 output and that the bedroom was on 1 and the living area was on 2, so maybe they plugged it in backwards at the factory.

BTW, the HDMI cables are color coded, so you know which one goes to which TV by matching the color at the back of each TV.

My wife thinks I'm a friggin' genius. I guess everyone is with the internet. Here's a link to the YouTube video, hope it helps:

https://youtu.be/nGj6AGDkOQA
__________________
'17 Ford F-150 Ecoboost, max tow package
'13 GMC Yukon Denali 6.2L V8
'04 GMC Yukon SLT 5.3L V8
abqdor is offline   Reply With Quote
Old 08-11-2017, 12:23 AM   #18
Rivet Master
 
wulfraat's Avatar
 
2017 30' International
Broomfield , Colorado
Join Date: Apr 2009
Posts: 2,067
Images: 1
Sweet! Nice job! Tricky solution to work out. Well done!
__________________

wulfraat is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to make my blu-ray player work wirelessly? chevl66 Computers, Internet & Satellite 23 04-24-2017 09:55 PM
Samsung Blu-Ray player m.hony Electronics & Connectivity 47 06-23-2016 01:50 PM


Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by the Airstream, Inc. or any of its affiliates. Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:25 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.