Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-09-2004, 07:07 PM   #1
Rivet Master
 
Happycampers's Avatar
 
1979 30' Argosy
Havelock , where we park it
Join Date: Jun 2003
Posts: 1,652
Univolt????help

Hello, I am having a problem with my 12 volt and don't know if it might be the univolt. All of the fuses have 12.2 volts and nothing works, when I plug into 110 everything works and the univolt hums and the battery reads 12.3 volts. What is wrong? Thaks for your help. Marvin
__________________

__________________
Marvin & Annie
Niki (fur baby)
1979 Argosy 30 (Costalotta)
WBCCI 10103
"Happiness is a warm Puppy" Charles Schulz
Happycampers is offline   Reply With Quote
Old 05-09-2004, 07:59 PM   #2
Retired Moderator
 
john hd's Avatar
 
1992 29' Excella
madison , Wisconsin
Join Date: Aug 2002
Posts: 4,644
Images: 40
marvin

there may be one more fuse you are overlooking.

the negitive lead has a fuse also.

you may want to remove the fuses and use your volt meter set to "ohms" or the omega symbol and check for zero ohms on each fuse.

that way you can be 100 percent sure it is something else!

john
__________________

__________________
you call them ferrets, i call them weasels.
john hd is offline   Reply With Quote
Old 05-09-2004, 08:02 PM   #3
3 Rivet Member
 
jjonesnc's Avatar
 
Cary , North Carolina
Join Date: Jun 2003
Posts: 156
Images: 8
Send a message via Yahoo to jjonesnc
Marvin,
Make sure your negative battery cable is not full of corrosion.... run a new ground to test with such as a jumper cable on negative (-battery) to chassis.
__________________
jjonesnc is offline   Reply With Quote
Old 05-09-2004, 10:02 PM   #4
Rivet Master
 
53flyingcloud's Avatar
 
1984 29' Sovereign
Savannah , Missouri
Join Date: Apr 2002
Posts: 3,458
Images: 17
Blog Entries: 1
Quote:
Originally Posted by happy82301
Hello, I am having a problem with my 12 volt and don't know if it might be the univolt. All of the fuses have 12.2 volts and nothing works, when I plug into 110 everything works and the univolt hums and the battery reads 12.3 volts. What is wrong? Thaks for your help. Marvin
Check your battery..it should read higher than that if it's properly charged.`
btw, just what kind of battery do you have?? I hope not an "Auto" battery`!
ciao
53FC
__________________
WBCCI 5292 AIR 807
NEU #64
New England Unit
53flyingcloud is offline   Reply With Quote
Old 05-10-2004, 04:50 AM   #5
3 Rivet Member
 
jjonesnc's Avatar
 
Cary , North Carolina
Join Date: Jun 2003
Posts: 156
Images: 8
Send a message via Yahoo to jjonesnc
Also make sure the battery has water in it
__________________
jjonesnc is offline   Reply With Quote
Old 05-10-2004, 06:01 AM   #6
Rivet Master
 
Happycampers's Avatar
 
1979 30' Argosy
Havelock , where we park it
Join Date: Jun 2003
Posts: 1,652
Re battery

Hello.. The battery is a group 72 marvin rv interstate . It is full of water and usually charged to 12.4.. Marvin
__________________
Marvin & Annie
Niki (fur baby)
1979 Argosy 30 (Costalotta)
WBCCI 10103
"Happiness is a warm Puppy" Charles Schulz
Happycampers is offline   Reply With Quote
Old 05-10-2004, 06:02 AM   #7
Rivet Master
 
Happycampers's Avatar
 
1979 30' Argosy
Havelock , where we park it
Join Date: Jun 2003
Posts: 1,652
Re battery..

This is early am and made a mistake .. it is a marine rv battery.. Marvin
__________________
Marvin & Annie
Niki (fur baby)
1979 Argosy 30 (Costalotta)
WBCCI 10103
"Happiness is a warm Puppy" Charles Schulz
Happycampers is offline   Reply With Quote
Old 05-10-2004, 12:41 PM   #8
Rivet Master
 
Happycampers's Avatar
 
1979 30' Argosy
Havelock , where we park it
Join Date: Jun 2003
Posts: 1,652
Hi, I found the problem this morning, the ground had been spliced way behind the oven and it was corroded badly. Everything works great now. Thanks ot everyone for all the help. Marvin
__________________

__________________
Marvin & Annie
Niki (fur baby)
1979 Argosy 30 (Costalotta)
WBCCI 10103
"Happiness is a warm Puppy" Charles Schulz
Happycampers is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.