Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-14-2015, 08:50 AM   #1
4 Rivet Member
 
PA BAMBI II's Avatar
 
1964 17' Bambi II
Vintage Kin Owner
Strasburg , Pennsylvania
Join Date: Mar 2010
Posts: 471
Progressive Dynamics questions

I recently got my 12 volt working including a Progressive Dynamics convertor. I have a few questions:

1) do I need to have the trailer plugged in at all times? How often should I be plugged in to keep things charged?

2) The "Charge wizard" pendant keeps blinking "normal mode" even when I am not plugged in to shore power. This seems strange to me as the convertor is receiving no power.

3) On a recent 1800 mile trip, all was working fine. I had one blip when the 12 volt light I was using sort of flashed, then went out, then came back on. The light pulsed a bit after that, but no other noticeable problems. I know this is not normal, but is it a concern?

Thanks for any light anyone can shed on this for me.

Ben
__________________

__________________
"The difference between vintage and retro is that vintage is honestly old and cool. Retro tries to be but isn't."
PA BAMBI II is offline   Reply With Quote
Old 07-14-2015, 03:47 PM   #2
Rivet Master
 
KJRitchie's Avatar

 
2008 25' Classic
Wichita Falls , Texas
Join Date: Nov 2012
Posts: 4,218
I have the PD4655 upgrade which replaced a Parallax unit. I believe the Charge Wizard flashing when not on shore power is normal. I remember seeing mine do that. Wish they would mention it in the manual.

You can leave the trailer on shore power all the time as the Charge Wizard will lower the charge to the store mode, keeps the charge around 13.2v. According to the PD website every 21 hours it will run in boost mode 14.4v for 15 minutes but the instructions don't state that.

The light issue sounds like a bad connection.

Kelvin
__________________

__________________
2008 Classic 25fb "Silver Mistress"
2015 Ram 2500 6.7L Cummins. Crew Cab, 4x4, Silver
KJRitchie is offline   Reply With Quote
Old 07-14-2015, 03:53 PM   #3
Rivet Master
 
1974 Argosy 20
2014 20' Flying Cloud
Kooskia , Idaho
Join Date: Jul 2009
Posts: 4,591
Yes, the flashing light is normal even when not connected.

Kevin has the answers in post #2 above
__________________
idroba is offline   Reply With Quote
Old 07-14-2015, 03:56 PM   #4
cwf
Rivet Master
 
cwf's Avatar
 
1999 34' Excella
Currently Looking...
Hillsboro , Texas
Join Date: Feb 2013
Posts: 5,933
Images: 2
Was the light incandescent, fluorescent or LED?

First thought is "reseat the bulb".. If it changes when you wiggle the bulb that would mean you are affecting the problem area.

A loose wire is also possible, just like the switch contacts. May be try switching on/ off several tilmes will "scrub" the contacts...
__________________
Peace and Blessings..
Channing
WBCCI# 30676
cwf is online now   Reply With Quote
Old 07-15-2015, 07:31 AM   #5
4 Rivet Member
 
PA BAMBI II's Avatar
 
1964 17' Bambi II
Vintage Kin Owner
Strasburg , Pennsylvania
Join Date: Mar 2010
Posts: 471
Thanks to each of you for excellent responses! I will plug the trailer in while it is home.

The light that flickered is an original unit to the Bambi II and it has an incandescent bulb- probably original. All connections are solid, but I will look into cleaning the socket for a better bulb-to-socket connection.

Appreciate your help and comments!

Ben
__________________
"The difference between vintage and retro is that vintage is honestly old and cool. Retro tries to be but isn't."
PA BAMBI II is offline   Reply With Quote
Old 07-15-2015, 09:02 AM   #6
Rivet Master
 
KJRitchie's Avatar

 
2008 25' Classic
Wichita Falls , Texas
Join Date: Nov 2012
Posts: 4,218
Replace the bulb from another light. See if the problem travels with the bulb.

Kelvin
__________________

__________________
2008 Classic 25fb "Silver Mistress"
2015 Ram 2500 6.7L Cummins. Crew Cab, 4x4, Silver
KJRitchie is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Progressive Dynamics 4045 install help sup3rsh0cker Batteries, Univolts, Converters & Inverters 5 05-06-2012 07:16 PM
Progressive Dynamics 4045 Converter soldiermedic Batteries, Univolts, Converters & Inverters 18 07-15-2011 07:10 AM
Progressive Dynamics Inteli-Power 4060 Power Center 68 Overlander Commercial Listings 0 01-22-2011 12:24 AM
Bad PROGRESSIVE DYNAMICS INTELI POWER 45A mountainman1 Batteries, Univolts, Converters & Inverters 5 09-08-2010 06:54 AM
New Progressive Dynamics convertor, AGM battery, and Pendant questions wacnstac Batteries, Univolts, Converters & Inverters 16 05-09-2007 10:12 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:14 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.