Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-16-2015, 05:45 PM   #1
New Member
 
Dallas , Texas
Join Date: Apr 2014
Posts: 1
Power to Load Center but nowhere else?

I bought a 2000 AS and power worked fine at the former owner's house but when I got it home I got power at the 50 amp load center but no where else, i.e., plugs, lights, slideouts, etc. It has a 50 AMP load center, all breakers test ok, I get 120 current at every breaker but why is it not getting to all of the rest of the electrical devices. I have looked everywhere for some major off/on switch but found none. It does have an inverter/converter and I wonder if that needs to be tested?
__________________

__________________
gofigbruce is offline   Reply With Quote
Old 10-16-2015, 06:10 PM   #2
Rivet Master
 
tjdonahoe's Avatar
 
2013 31' Classic
billings , Montana
Join Date: Feb 2010
Posts: 1,844
Are breakers turned on?
__________________

__________________
tjdonahoe is offline   Reply With Quote
Old 10-16-2015, 07:09 PM   #3
Rivet Master
 
1974 Argosy 20
2014 20' Flying Cloud
Kooskia , Idaho
Join Date: Jul 2009
Posts: 4,591
Are you measuring the power between the hot line and the ground rather than the hot line and the neutral? If so, it would look like there is power at the breakers, but if the neutral was open it would not get to the circuits. Check that you are actually measuring between the breaker and the neutral bar, not the ground bar.

Look for an open neutral line.
__________________
idroba is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No brakes, but everything else works... what's wrong? groshko Brakes & Brake Controllers 5 08-07-2010 06:51 PM
1/2 ton tires- load C to load E John Tires 75 03-20-2009 10:15 AM
Load bearing or not load bearing? Petethefeet Ribs, Skins & Rivets 3 04-27-2008 08:36 AM
Help and advise she died in the middle of nowhere saxonsraven Airstream Motorhome Forums 7 07-29-2003 08:10 AM
Wires to nowhere Craig Electrical - Systems, Generators, Batteries & Solar 3 10-01-2002 08:03 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.