Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-27-2011, 10:52 AM   #1
1 Rivet Member
 
1973 31' Sovereign
Montalba , Texas
Join Date: Mar 2008
Posts: 14
Need help with control panel

I have changed out my converter and fuse panel. i have no power at control panel i have found a gray wire that is hot but do not know where it connects to in the control panel. no other electrical issues .can anyone help.
__________________

__________________
mkcox is offline   Reply With Quote
Old 02-27-2011, 10:58 AM   #2
Site Team
 
azflycaster's Avatar
 
1975 25' Tradewind
Dewey , Arizona
Join Date: Mar 2005
Posts: 12,127
Images: 62
Blog Entries: 1
Is the control panel dead or is it just the power on indicator that is not working?
__________________

__________________

Richard

Wally Byam Airstream Club 7513
azflycaster is online now   Reply With Quote
Old 02-27-2011, 11:28 AM   #3
Rivet Master
 
DanielB's Avatar
 
1974 31' Excella 500
Charleston , South Carolina
Join Date: Nov 2010
Posts: 1,073
Blog Entries: 8
This may help, may not.
Attached is the control panel section from the 75 Service manual.

It shows the blue and white from the tv attached to the control panel and otherwise just the wiring harness. Or, I could have missed something.
Attached Files
File Type: pdf ControlPanel.pdf (1.52 MB, 66 views)
__________________
As I grow older, I pay less attention to what men say. I just watch what they do.
- Andrew Carnegie
DanielB is offline   Reply With Quote
Old 02-27-2011, 01:01 PM   #4
x
 
XXXX , XXXX
Join Date: Jun 2010
Posts: 2,601
Control Panel Wiring

The grey wire should attach to the main harness connector just beside the larger white wire ans above the red wire. On the other side of the main harness connector the grey wire has a bullet connector attached to it and connects to a white wire for the power on light. I have attached a wiribg diagram for the control panel and some pictures of the main harness connector. I am holding the grey wire with one finger. The first pic shows the harness from the trailer, the second shows the harness for the control panel and the third shows the bullet connector and the power on light.
Attached Thumbnails
Click image for larger version

Name:	2-27-2011 1;53;33 PM.jpg
Views:	100
Size:	261.6 KB
ID:	123207   Click image for larger version

Name:	Control Panel Wiring 003.jpg
Views:	79
Size:	170.2 KB
ID:	123208  

Click image for larger version

Name:	Control Panel Wiring 004.jpg
Views:	76
Size:	175.0 KB
ID:	123209   Click image for larger version

Name:	Control Panel Wiring 005.jpg
Views:	82
Size:	156.2 KB
ID:	123210  

__________________
wasagachris is offline   Reply With Quote
Old 02-27-2011, 01:45 PM   #5
1 Rivet Member
 
1973 31' Sovereign
Montalba , Texas
Join Date: Mar 2008
Posts: 14
Quote:
Originally Posted by azflycaster View Post
Is the control panel dead or is it just the power on indicator that is not working?
control panel and indicator not working
__________________
mkcox is offline   Reply With Quote
Old 02-27-2011, 02:10 PM   #6
1 Rivet Member
 
1973 31' Sovereign
Montalba , Texas
Join Date: Mar 2008
Posts: 14
i have connected the gray wire the way it shows and connected black wire to ground the way andy suggested in early post. the light come on but when electric power is disconnected the stays on. and i have on power at panel ie radio and no other functions at panel
__________________
mkcox is offline   Reply With Quote
Old 02-27-2011, 02:35 PM   #7
Site Team
 
azflycaster's Avatar
 
1975 25' Tradewind
Dewey , Arizona
Join Date: Mar 2005
Posts: 12,127
Images: 62
Blog Entries: 1
The original univolt had a separate line that powered the power on light. It was isolated from the battery and only operated from the 12 volt line from the univolt. With another converter the light will not function correctly.

My control panel (75) has a separate fuse located at the panel. I am not sure if it was the same in 73.
__________________

Richard

Wally Byam Airstream Club 7513
azflycaster is online now   Reply With Quote
Old 02-27-2011, 02:52 PM   #8
1 Rivet Member
 
1973 31' Sovereign
Montalba , Texas
Join Date: Mar 2008
Posts: 14
yes i have a fuse in the panel and it is good
__________________
mkcox is offline   Reply With Quote
Old 02-27-2011, 02:53 PM   #9
Site Team
 
azflycaster's Avatar
 
1975 25' Tradewind
Dewey , Arizona
Join Date: Mar 2005
Posts: 12,127
Images: 62
Blog Entries: 1
Quote:
Originally Posted by mkcox View Post
yes i have a fuse in the panel and it is good
Do you have 12 volts at the fuse?
__________________

Richard

Wally Byam Airstream Club 7513
azflycaster is online now   Reply With Quote
Old 02-27-2011, 03:09 PM   #10
1 Rivet Member
 
1973 31' Sovereign
Montalba , Texas
Join Date: Mar 2008
Posts: 14
no 12 volts at fuse
__________________
mkcox is offline   Reply With Quote
Old 02-27-2011, 03:27 PM   #11
Site Team
 
azflycaster's Avatar
 
1975 25' Tradewind
Dewey , Arizona
Join Date: Mar 2005
Posts: 12,127
Images: 62
Blog Entries: 1
On my 75 TW the power to the CP is on circuit number 5. I would go back to the new fuse panel and verify that each circuit is connected and that the fuses are all still good.

Also see if any other 12 volt items are not working. Check all the lights and motor including the jack and water pump. I suspect that the entire circuit is dead.
__________________

Richard

Wally Byam Airstream Club 7513
azflycaster is online now   Reply With Quote
Old 02-27-2011, 03:35 PM   #12
1 Rivet Member
 
1973 31' Sovereign
Montalba , Texas
Join Date: Mar 2008
Posts: 14
yes i have 12 volts at panel now
__________________
mkcox is offline   Reply With Quote
Old 02-27-2011, 03:36 PM   #13
Site Team
 
azflycaster's Avatar
 
1975 25' Tradewind
Dewey , Arizona
Join Date: Mar 2005
Posts: 12,127
Images: 62
Blog Entries: 1
What changed?
__________________

Richard

Wally Byam Airstream Club 7513
azflycaster is online now   Reply With Quote
Old 02-27-2011, 03:42 PM   #14
1 Rivet Member
 
1973 31' Sovereign
Montalba , Texas
Join Date: Mar 2008
Posts: 14
i connected the wire from car battery and i have power to the jack and to panel but the water pump and holding tanks will not light up
__________________

__________________
mkcox is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Solar Panel Prices Dropping tbro Generators & Solar Power 11 03-30-2011 09:21 PM
monitor panel on a 70 overlander rayandre Electrical - Systems, Generators, Batteries & Solar 4 02-14-2011 07:09 AM
How to repair the control panel? DougZ General Repair Forum 1 01-10-2011 06:52 PM
Panel indicator light for water pump and Water heater DJW Water Heaters, Filters & Pumps 3 01-05-2011 08:01 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:14 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.