Thread Tools Search this Thread Display Modes
Old 04-09-2010, 12:32 PM   #1
3 Rivet Member
1986 34.5' Airstream 345
Tyler , Texas
Join Date: Jun 2007
Posts: 110
More electrical problems in 345

On a recent trip to the bayou country my water pump stopped. My first thought was that I had blown a 12v fuse. Unable to locate any 12v fuses even after several forum posts I tried to do a little trouble shooting. So here is the problem!I pulled the switch in the bath of the 345 to get access to the 3 prong rear. One wire should be my hot, one my neutral and the third to the water pump. RIGHT?I removed the pump and hooked it diretly to a 12v supply and it worked. When the pump is connected in the coach the hot side of the switch is hot but no power to the pump. I remove the pump and leave the hot and neutral disconnected I do not have a hot at the switch. If I connect the hot and neutral to each other at the pump I have a hot and the switch seems to work properly.
I'm at wits end!

pjude is offline   Reply With Quote
Old 04-09-2010, 01:36 PM   #2
Rivet Master
DaveFL's Avatar
2000 31' Land Yacht
Central , Florida
Join Date: Aug 2007
Posts: 1,472
Images: 15
My water pump is wired with a second switch in the galley control center, if it had a problem bathroom switch wouldn't work. does the light on the switch light up. if switch lights, check continuity to pump or without meter you can touch positive to pump wire and see if pump runs, if it doesn't check ground at pump.
When you connect hot to neutral at pump you should have blown fuse.
DaveFL is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical problems on '89 airstream 345 mater4 General Motorhome Topics 7 09-25-2009 09:39 PM
Electrical problems hampstead38 1967 Overlander 0 10-18-2008 04:23 PM
electrical problems mattie Electrical - Systems, Generators, Batteries & Solar 4 06-08-2008 07:13 AM
Electrical Problems Bob Baker Electrical - Systems, Generators, Batteries & Solar 4 06-20-2003 11:31 PM
Electrical problems... DbackFan Electrical - Systems, Generators, Batteries & Solar 9 02-13-2003 10:44 PM

Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:23 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.