Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-27-2016, 08:37 PM   #1
New Member
 
Currently Looking...
Currently Looking...
Happy Valley , Oregon
Join Date: Sep 2015
Posts: 2
Inverter Not Working

We have a 2006 Bambi 19' with a 600 watt stock inverter that came with it. Last dry camping trip I plugged my coffeemaker into one of the inverter outlets and it blew the power to all the inverter outlets. We tested the battery and it has power, but when the battery is connected to the inverter, no power comes out of the inverter. The inverter has an AC pass through plug in and when we use it to plug the inverter into AC, it powers the outlets. We cannot find any information in the manual regarding if there's an overload switch or a fuse for the inverter. Seems to us that if AC will power the inverter, part of the inverter must be working, but can't get the DC to convert to AC with the battery. Can anyone help?
__________________

__________________
Kate Lansing is offline   Reply With Quote
Old 01-27-2016, 09:32 PM   #2
Rivet Master
 
2015 30' Classic
Pleasanton , California
Join Date: Jan 2015
Posts: 619
Is the inverter a WFCO model WF-600T? If so, there should be an in-line fuse in the position connection from the inverter to the battery.

We switched to a kettle and french press for coffee.
__________________

__________________
Al, K6IV
2015 30' Classic, "Chez Nu"
2014 RAM 2500 w/Cummins Diesel
ProPride Hitch, 400 W Solar
alano is offline   Reply With Quote
Old 01-27-2016, 11:05 PM   #3
Fuil-Timers
 
DreamStreamr's Avatar

 
2005 25' International CCD
Everywhere , North America
Join Date: Aug 2005
Posts: 631
Images: 38
Send a message via Skype™ to DreamStreamr
Agree with Al, my inverter has a fuse between battery and inverter. But also, there may be a circuit breaker between the inverter and the receptacles circuit. Sounds as though one or the other is blown. Isn't your coffee maker way more than 600 watts?
__________________
Living the Dream

Jim Cocke,
International President
WBCCI Wally Byam Airstream Club
dreamstreamr.com
dreamstreamr.wordpress.com
DreamStreamr is offline   Reply With Quote
Old 01-28-2016, 01:29 AM   #4
Rivet Master
 
richinny's Avatar
 
2011 34' Classic
Westchester Cty.NY , / Miami FL
Join Date: Jul 2007
Posts: 3,122
check the fuses inside the converter. http://www.airforums.com/forums/f449...ml#post1566059
__________________
Ricky
2012 F150 Super Crew 5-1/2' bed Ecoboost 4x4 3.73 elec. lock diff. Propride hitch
give life. kidney & pancreas transplant 9/9/06
Ingrid-my unofficial '"World's Oldest Streamer" 1909-2008 R.I.P.
richinny is offline   Reply With Quote
Old 01-28-2016, 06:04 AM   #5
Rivet Master
 
rodsterinfl's Avatar

 
2006 25' Safari
Fort Myers , Florida
Join Date: Oct 2011
Posts: 2,431
Images: 8
Most likely one or the other mentioned. 1) blown fuse/open breaker or 2) burned up inverter.

I had a third party 1000 watt inverter 1.5 years old that quit working. I had used it for my 850 watt coffee maker while camping the last time before my discovery of failure. When I reviewed the manual it said that the 1000 watt inverter was good for 900 watts continuous and 1000 watts for five minutes. The ONLY other thing is that we thought the GFCI breaker might have failed since we could not set it. When we took it apart to find out we voided the warranty. Anyway, further inspection found that it was fried inside as I was apparently too close to maxing the continuous?? I threw it out and got a bigger different brand. Hope it is the fuse!
__________________
WBCCI 8653/AIR 60240
2017 Ford F-150 3.5 Ecobeast Gen 2 3.55 Platinum
rodsterinfl is online now   Reply With Quote
Old 01-28-2016, 09:44 AM   #6
New Member
 
Currently Looking...
Currently Looking...
Happy Valley , Oregon
Join Date: Sep 2015
Posts: 2
Thanks, everyone. We'll report back after inspection. And yes, will never use a small appliance again when boondocking, no matter what the wattage...
__________________
Kate Lansing is offline   Reply With Quote
Old 01-28-2016, 10:18 AM   #7
Rivet Master
 
richw46's Avatar
 
2006 23' Safari SE
Lexington , Kentucky
Join Date: Dec 2012
Posts: 2,175
Images: 6
It's the 2 internal 35 amp fuses
Disconnect the batteries before removing the inverter or you'll risk blowing the inline fuse that is expensive and difficult to get to. Ask me how I know. I think I had owned the AS for a week. The PO told me she was trying to run the vacuum cleaner off the inverter and thought she burned it up but it was just the fuses.

I believe there are 6 screws to open up the inverter, you'll see the 2 35 amp fuses right there, easy to get to. Swap 'em out, close it up and reinstall, reconnect the batteries and you're good to go.
__________________
-Rich

Rich & Yvonne
2006 Safari SE -Dora-
2004 4Runner SE

richw46 is offline   Reply With Quote
Old 01-28-2016, 07:24 PM   #8
Jman
 
2006 19' International CCD
Happy Valley , Oregon
Join Date: Oct 2015
Posts: 1
Kate and I are grateful for the info folks. I took the 600w inverter out, pulled the top and replaced the two 35A fuses. Fired right up after putting back!
__________________
JohnL1211 is offline   Reply With Quote
Old 01-29-2016, 09:03 PM   #9
Rivet Master
 
richinny's Avatar
 
2011 34' Classic
Westchester Cty.NY , / Miami FL
Join Date: Jul 2007
Posts: 3,122
thanks for the follow-up!
__________________
Ricky
2012 F150 Super Crew 5-1/2' bed Ecoboost 4x4 3.73 elec. lock diff. Propride hitch
give life. kidney & pancreas transplant 9/9/06
Ingrid-my unofficial '"World's Oldest Streamer" 1909-2008 R.I.P.
richinny is offline   Reply With Quote
Old 02-01-2016, 06:15 PM   #10
Rivet Master
 
rodsterinfl's Avatar

 
2006 25' Safari
Fort Myers , Florida
Join Date: Oct 2011
Posts: 2,431
Images: 8
Great! Glad to hear it was only fuses.
__________________

__________________
WBCCI 8653/AIR 60240
2017 Ford F-150 3.5 Ecobeast Gen 2 3.55 Platinum
rodsterinfl is online now   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Inverter not working Coaster Batteries, Univolts, Converters & Inverters 12 01-10-2015 02:42 PM
1000W Inverter not working even with full battery corymac Airstream Trailer Forums 9 12-16-2014 08:25 PM
Inverter not working btowntincan Batteries, Univolts, Converters & Inverters 4 07-08-2014 05:27 PM
Inverter not working? susans69 Electrical - Systems, Generators, Batteries & Solar 3 05-18-2012 11:05 PM
Inverter outlets not working FinnSwede Batteries, Univolts, Converters & Inverters 10 11-16-2011 04:14 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.