Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-19-2012, 05:58 PM   #1
3 Rivet Member
 
1980 20' Caravelle
Currently Looking...
Coeur d alene , Idaho
Join Date: Mar 2005
Posts: 156
Good Battery-No 12 volt Lights?

1980 Caravelle, Napa charged my battery, inside panel says battery is GOOD, Checked all fuses--look fine! No interior 12v power for lights or water pump. What do I check next? Heading to fish Kamp Sunday--Bummer! Don
__________________

__________________
glacierrunne is offline   Reply With Quote
Old 10-19-2012, 06:10 PM   #2
Rivet Master
 
SteveH's Avatar
 
2005 39' Land Yacht 390 XL 396
Common Sense , Texas
Join Date: Sep 2007
Posts: 5,311
I had a '75 model that developed an open circuit on the battery distribution/fuse panel at a bolt that carried the power from one side of the board to the other, and had the same symtoms as yours. You need a 12 volt meter, or trouble light to test where you do have 12 volts, and where you do not. It's really a pretty simple system to trace out.
__________________

__________________
SteveH is offline   Reply With Quote
Old 10-19-2012, 06:35 PM   #3
Rivet Master
 
Jim Foster's Avatar
 
1965 17' Caravel
1983 27' Excella
Walnut Grove/Laguna Woods , California
Join Date: Jun 2004
Posts: 1,615
Send a message via Yahoo to Jim Foster
On more than one occasion I have had fusses that looked good, but were blown in a way that did not show. Use an test light and make sure there is power on both ends if the fuse when it is in place. Also, over time, oxidation can form between the fuse and the holder "clips". Don't know just how that happens. but it does.

Also, check to be sure your battery is grounded to the frame well. I had that ground connection go away on our Caravel a number of years ago.
__________________
Past President, El Camino Real Unit WBCCI#6620
Street Rod Builder (see avatar)
Kite flier (check out links below)
http://www.youtube.com/my_videos?feature=mhee
https://www.youtube.com/watch?v=6y1_U2XQ0bI
Jim Foster is offline   Reply With Quote
Old 10-19-2012, 06:38 PM   #4
Rivet Master
 
1988 32' Excella
Robbinsville , New Jersey
Join Date: May 2012
Posts: 1,010
I have seen were the fuse clip is connected there was corrosion and a bad connection.
__________________
Wazbro is offline   Reply With Quote
Old 10-19-2012, 07:27 PM   #5
Rivet Master
 
Shacksman's Avatar
 
1960 28' Ambassador
Vintage Kin Owner
1998 25' Safari
Avonton , Ontario
Join Date: Sep 2005
Posts: 1,213
Best guess is a bad ground connection. Even if it looks good, where it joins the body, take it apart and clean the connection.
__________________
Doug & Terry
VAC - TAC ON-1
60 Ambassador Int.
98 Safari
1950 Spartan
1966 Globetrotter
Shacksman is offline   Reply With Quote
Old 10-19-2012, 07:34 PM   #6
Rivet Master
 
Jim Foster's Avatar
 
1965 17' Caravel
1983 27' Excella
Walnut Grove/Laguna Woods , California
Join Date: Jun 2004
Posts: 1,615
Send a message via Yahoo to Jim Foster
For a quick check of your battery ground connection, use a plain old jumper cable and connect from your battery negative to a good, paint free area on the frame of your trailer.
__________________
Past President, El Camino Real Unit WBCCI#6620
Street Rod Builder (see avatar)
Kite flier (check out links below)
http://www.youtube.com/my_videos?feature=mhee
https://www.youtube.com/watch?v=6y1_U2XQ0bI
Jim Foster is offline   Reply With Quote
Old 10-20-2012, 10:59 AM   #7
3 Rivet Member
 
1980 20' Caravelle
Currently Looking...
Coeur d alene , Idaho
Join Date: Mar 2005
Posts: 156
I have a 12 volt meter--I'll start checking--thanks for all the help!!! Don
__________________

__________________
glacierrunne is offline   Reply With Quote
Reply

Tags
12 volt


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery question Ofdtruckie Batteries, Univolts, Converters & Inverters 19 11-14-2011 06:19 PM
Should interior lights work with no battery but with Tow Vehicle connected bocotim Electrical - Systems, Generators, Batteries & Solar 12 11-03-2011 11:06 AM
How long can my battery cable be - and what gauge wire? robwok Electrical - Systems, Generators, Batteries & Solar 3 10-20-2011 10:52 AM
CTEK Battery Chargers wayneskid Electrical - Systems, Generators, Batteries & Solar 1 07-09-2011 01:13 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.