Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-12-2008, 11:11 PM   #1
2 Rivet Member
 
MacStreamer's Avatar
 
1998 28' Excella
Great Northwest , Washington
Join Date: Jun 2004
Posts: 37
Images: 16
Electrical Management System - "The Brain"

Greeting,
We have a 1998 28' Excella. Just wondering if anyone knows any thing about the
"Electrical Management System" w/ smart surge made by Progressive Industries.
We are having issues with it. I am not sure if the "brain" came installed from the
factory or if the previous owner installed it. In other words, for al I know all trailers
have this in them. =P It is located in the very back overhead compartments over
one of our twin beds. My husband calls it "The Brain" because it is deciding when
we should have power or not.

Our problem we are having is that it shuts every thing down when we try to turn on
the AC. No matter if we try to hook up power here at home or at a camp site, when we
turn on the AC the "brain" shuts it all down. Before it shuts it all down and after it flashed
the same code. 120 0A 60H EO

EO on the side chart says that is "Normal". No other error codes pop up.
You would think after it shuts down it would flash one of the error codes.

But, we can, just turn this "brain" off, and the AC works just fine. We have no
book for it and are not sure if it is even anything we need..

So again we can turn the "brain" off and use the AC. But are wondering if that
is a good idea. And if so, what might we do to fix it from tripping everything off.

I tried searching the forums but can't seem to find any info on out issue.


Have a great night!

Dana
__________________

__________________
Macintosh + Airstream = Think Different
MacStreamer is offline   Reply With Quote
Old 07-12-2008, 11:23 PM   #2
Site Team
 
azflycaster's Avatar
 
1975 25' Tradewind
Dewey , Arizona
Join Date: Mar 2005
Posts: 12,127
Images: 62
Blog Entries: 1
I googled and found this:
http://www.viprv.com/ems/HW50COperation_InstallPDF.pdf
It might help. Based on what the unit is supposed to do, I would guess that the Air Conditioner is pulling the input voltage down below a safe level and the "Brain" is reacting to this condition. If your unit is the same as the one in the link, you should be able to pull the previous error code to determine the fault.
__________________

__________________

Richard

Wally Byam Airstream Club 7513
azflycaster is offline   Reply With Quote
Old 07-12-2008, 11:34 PM   #3
_
 
. , .
Join Date: Dec 2004
Posts: 8,812
progressive industries has made 'intelligent' surge protectors for a good while.

a/s has never used them as oem gear, so a dealer OR owner installed it.

go to their website and contact them for tech support.

IF the protector is hardwired disconnecting it takes more effort, but

that is exactly what i'd do, disconnect it.

buy/use a simple voltage meter and watch what happens to the voltage WHEN the a/c kicks on...

u may need to have an rv tech disconnect and rewire without the "brain" but very likely the unit is the issue and it's out of warranty...

cheers
2air'
__________________
all of the true things that i am about to tell you are shameless lies. l.b.j.

we are here on earth to fart around. don't let anybody tell you any different. k.v.
2airishuman is offline   Reply With Quote
Old 07-13-2008, 02:44 AM   #4
Rivet Master
 
richinny's Avatar
 
2011 34' Classic
Westchester Cty.NY , / Miami FL
Join Date: Jul 2007
Posts: 3,122
or it could be working and there is a poor connection somewhere.

check those voltages!
__________________
Ricky
2012 F150 Super Crew 5-1/2' bed Ecoboost 4x4 3.73 elec. lock diff. Propride hitch
give life. kidney & pancreas transplant 9/9/06
Ingrid-my unofficial '"World's Oldest Streamer" 1909-2008 R.I.P.
richinny is offline   Reply With Quote
Old 07-13-2008, 12:02 PM   #5
2 Rivet Member
 
MacStreamer's Avatar
 
1998 28' Excella
Great Northwest , Washington
Join Date: Jun 2004
Posts: 37
Images: 16
Thanks all,
Heading out now to test it with a "simple voltage meter". I also found their contact info
on the link to the PDF Richard posted, so we might give them a call today.

Thanks again! =) Dana
__________________
Macintosh + Airstream = Think Different
MacStreamer is offline   Reply With Quote
Old 07-13-2008, 01:00 PM   #6
Rivet Master
 
davidz71's Avatar
 
1986 25' Sovereign
Southern Middle , Tennessee
Join Date: Mar 2002
Posts: 3,150
Images: 23
Quote:
Originally Posted by MacStreamer View Post
...Our problem we are having is that it shuts every thing down when we try to turn on
the AC. No matter if we try to hook up power here at home or at a camp site, when we
turn on the AC the "brain" shuts it all down....
Dana
I sure hope your connection at home is to a 30 amp circuit rather than using a dogbone adapter to a 15 amp house receptacle. What condition is your 30 amp RV plug in? Are any blades in the RV plug head loose?
__________________
Craig

AIR #0078
'01 2500hd ext. cab, 8.1 litre gas, 5 sp. Allison auto
3.73 rear end
Mag-Hytec rear diff cover
Amsoil Dual by-pass oil filtration system
Amsoil synthetics all around
265 watt AM Solar, Inc. system
davidz71 is offline   Reply With Quote
Old 07-14-2008, 12:10 AM   #7
2 Rivet Member
 
MacStreamer's Avatar
 
1998 28' Excella
Great Northwest , Washington
Join Date: Jun 2004
Posts: 37
Images: 16
Craig, We are using a heavy duty electrical cord here at home. But it also happens at camp sites where we plug into. One time when we first got there it tripped it even though we only turned on one light. So we ran our power to the site next to us, a family member's site, and it worked fine. It seems to trip with we are not getting enough power. When you say blades, do you mean the prongs? I will check in the morning.

The error chart is below. When the AC is not turned on the Code is showing E0 "Normal condition". And when we turn on the AC and it trips it all off it still shows "E0". I would think when it trips it would show a different code the E0. I was going to call them tomorrow. Monday.

ErrorCodeChart
E-0--Normal condition
E-1--Reversepolaritycondition(hot andneutral wiresreversed)
E-2--OpenGround(nogroundwireconnection)
E-3--Line1VoltageHigh(line1voltageabove132)
E-4--Line1VoltageLow(line1voltagebelow104)
E-5--Line2VoltageHigh(line2voltageabove132)
E-6--Line2VoltageLow(line2voltagebelow104)
E-7--LineFrequencyHigh(linefrequencyabove69cyclespersec ond)
E-8--LineFrequencyLow(linefrequencybelow51cyclesperseco nd)
E-9--DataLinkDown(remotedisplaynot gettinginformation)
E-10 Replacethesurgeprotectormodule

=) Thanks for the suggestions.
Dana
__________________
Macintosh + Airstream = Think Different
MacStreamer is offline   Reply With Quote
Old 07-14-2008, 08:59 PM   #8
Rivet Master
 
davidz71's Avatar
 
1986 25' Sovereign
Southern Middle , Tennessee
Join Date: Mar 2002
Posts: 3,150
Images: 23
Quote:
Originally Posted by MacStreamer View Post
Craig, We are using a heavy duty electrical cord here at home. But it also happens at camp sites where we plug into. One time when we first got there it tripped it even though we only turned on one light. So we ran our power to the site next to us, a family member's site, and it worked fine. It seems to trip with we are not getting enough power. When you say blades, do you mean the prongs? I will check in the morning.
Dana
Dana,
Yes, you should have 2 blades and a round prong in the 30 amp RV power head. I had a problem with a short in the plug head of my '77 Excella that drove me crazy. Sometimes it worked fine and at other times it didn't. I replaced the plug and had no further problem.
__________________

__________________
Craig

AIR #0078
'01 2500hd ext. cab, 8.1 litre gas, 5 sp. Allison auto
3.73 rear end
Mag-Hytec rear diff cover
Amsoil Dual by-pass oil filtration system
Amsoil synthetics all around
265 watt AM Solar, Inc. system
davidz71 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Product review: Chestnut Hill Sound - "George" iPod system ostream Audio, Video & TV 0 08-08-2007 12:23 PM
67 refrigerator, electrical operation: "repair" (no karma) eubank Refrigerators 4 10-22-2006 10:11 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.