Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-14-2010, 06:15 PM   #1
3 Rivet Member
 
shepherd57's Avatar
 
1985 32.5' Airstream 325
Lindsay , Ontario
Join Date: Aug 2010
Posts: 180
Images: 3
Elec troubles

I was changing the light bulbs in the control center when the power wire from the stove fan touched the the panel. Now I don't have any interior lights and no power at the control panel when on shore power and the engine won't turn over. If I turn to accessories I have interior lights. I also have 110 when on shore power.

I can't seem to find a blown fuse and the inverter is still humming and I have 12 volt power at the fuse block after the inverter.

How can a tiny spark kill everything that was working fine before.
__________________

__________________
shepherd57 is offline   Reply With Quote
Old 11-14-2010, 06:25 PM   #2
4 Rivet Member
 
Gypsy Jo's Avatar
 
1977 28' Argosy 28
Bullhead City , Arizona
Join Date: Mar 2009
Posts: 393
Images: 3
Blog Entries: 1
On my control panel I have a fuse in the side.Do you have one there?
__________________

__________________
Gypsy Jo
1977 Argosy 28' Motor Home
Gypsy Jo is offline   Reply With Quote
Old 11-14-2010, 06:45 PM   #3
3 Rivet Member
 
shepherd57's Avatar
 
1985 32.5' Airstream 325
Lindsay , Ontario
Join Date: Aug 2010
Posts: 180
Images: 3
the only one is a 15 amp inline and it is good I have no power coming to the control panel
__________________
shepherd57 is offline   Reply With Quote
Old 11-14-2010, 06:53 PM   #4
4 Rivet Member
 
Gypsy Jo's Avatar
 
1977 28' Argosy 28
Bullhead City , Arizona
Join Date: Mar 2009
Posts: 393
Images: 3
Blog Entries: 1
The schematic I have shows 2 wires from the control panel. One goes to the vehicle junction box and the other one to the solenoid on the 12 volt distribution panel . You might have messed up that solenoid because it is hooked to the engine battery.Not an expert just giving ideas.
__________________
Gypsy Jo
1977 Argosy 28' Motor Home
Gypsy Jo is offline   Reply With Quote
Old 11-14-2010, 06:59 PM   #5
3 Rivet Member
 
shepherd57's Avatar
 
1985 32.5' Airstream 325
Lindsay , Ontario
Join Date: Aug 2010
Posts: 180
Images: 3
Is there a color code for those wires and where do I look for that solenoid
__________________
shepherd57 is offline   Reply With Quote
Old 11-14-2010, 07:15 PM   #6
4 Rivet Member
 
Gypsy Jo's Avatar
 
1977 28' Argosy 28
Bullhead City , Arizona
Join Date: Mar 2009
Posts: 393
Images: 3
Blog Entries: 1
The distribution panel on my 28' is under the passenger side chair .It has a drop down door that was under the carpet the solenoid is there.Doesn't show a color code in the book.
__________________
Gypsy Jo
1977 Argosy 28' Motor Home
Gypsy Jo is offline   Reply With Quote
Old 11-14-2010, 07:54 PM   #7
3 Rivet Member
 
shepherd57's Avatar
 
1985 32.5' Airstream 325
Lindsay , Ontario
Join Date: Aug 2010
Posts: 180
Images: 3
Is that a square plastic piece with 2 sets of points inside it
__________________
shepherd57 is offline   Reply With Quote
Old 11-14-2010, 08:12 PM   #8
4 Rivet Member
 
Gypsy Jo's Avatar
 
1977 28' Argosy 28
Bullhead City , Arizona
Join Date: Mar 2009
Posts: 393
Images: 3
Blog Entries: 1
No the solenoid is round with 2 large posts and 2 small posts.I don't have any way to show you the schematic or a pic right now.If you search the forums there is info on where to find an owners manual.That would give you a better idea of what you are looking at.
__________________
Gypsy Jo
1977 Argosy 28' Motor Home
Gypsy Jo is offline   Reply With Quote
Old 11-15-2010, 10:31 AM   #9
3 Rivet Member
 
shepherd57's Avatar
 
1985 32.5' Airstream 325
Lindsay , Ontario
Join Date: Aug 2010
Posts: 180
Images: 3
I don't have a solenoid that I can find. I now have the engine running I had the neutral switch disconnected. I have 12 volt power with the key on acc and in the run position.

I don't have 12 volt when when connected to shore power.

I have a Magnetek 950-2-4 converter 50amp

Dose anyone know if there are any fuse-able links in these systems that could be the problem.

Can I test the converter to see if it is putting out 12 volts
__________________

__________________
shepherd57 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Elec troubles shepherd57 Argosy Motorhomes 5 11-15-2010 05:44 PM
awning troubles poncho/cisco Awnings 3 11-09-2008 09:41 AM
Still having water troubles.... swinginping Classic Motorhomes 1 03-07-2008 05:46 PM
Awning Troubles Alaska1966 Awnings 1 08-01-2007 11:51 AM
Water troubles... Sneakinup Fresh Water Systems 5 01-10-2004 09:54 PM





All times are GMT -6. The time now is 12:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.
Modal Click