Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-08-2009, 11:00 AM   #15
4 Rivet Member
 
wannaroam's Avatar
 
1978 31' Excella 500
1961 26' Overlander
Harmony , Pennsylvania
Join Date: Sep 2006
Posts: 312
Images: 36
The wall receptacle is a 3 prong, and other things plugged in there work normally.

We bought this converter 2 yrs and 6 weeks ago. We didn't get it installed until about a year and a half ago, and only began using the trailer last fall, as we were rebuilding almost everything. We never boondocked until last month and that was when we realized that the batteries weren't charging. Of course, it is now 6 weeks out of warranty as luck would have it. I suspect that this unit never worked - we noticed that with two new batteries the status lights never read higher than "good". After boondocking and losing all battery charge my husband manually charged the batteries up from the tv battery and finally it read as a full charge.

I am most disappointed in the person we bought this from. We called him several times over three days, and emailed him (per his request) and never got a reply by either method, all we could ever get was a recorded message when we called. Finally my husband got the Parallax company on the line and explained to them what was going on and they called the dealer, who called us right back. But with an attitude. And of course we were told it is out of warranty, period.

All of you know it takes a long time to get a unit refurbished and on the road. I just wish we would have realized that this wasn't working 6 weeks ago. We now appear to be stuck for a $225.

Does anyone else have any other ideas? If it is a bad ground could we/should we attempt to fix that ourselves? Or send it to the factory to see if it can be fixed?
__________________

__________________
wannaroam is offline   Reply With Quote
Old 08-08-2009, 11:20 AM   #16
2 Rivet Member
 
1965 26' Overlander
Renton , Washington
Join Date: Jul 2009
Posts: 47
you are positive that the 120 ac wiring is hooked up correctly at the converter? and the wires from the converter to the battery are hooked up correctly? can you post any pictures of these connections?
__________________

__________________
nate3172 is offline   Reply With Quote
Old 08-08-2009, 11:23 AM   #17
4 Rivet Member
 
wannaroam's Avatar
 
1978 31' Excella 500
1961 26' Overlander
Harmony , Pennsylvania
Join Date: Sep 2006
Posts: 312
Images: 36
I will try to see if I can get pix. Hubby took it down last week and boxed it up in the hopes that we would be able to send it back.
__________________
wannaroam is offline   Reply With Quote
Old 08-08-2009, 01:16 PM   #18
Rivet Master
 
richinny's Avatar
 
2011 34' Classic
Westchester Cty.NY , / Miami FL
Join Date: Jul 2007
Posts: 3,122
i'd also verify that the polarity is correct at the outlet it is plugged into and that any fuses on the unit test good.
__________________
Ricky
2012 F150 Super Crew 5-1/2' bed Ecoboost 4x4 3.73 elec. lock diff. Propride hitch
give life. kidney & pancreas transplant 9/9/06
Ingrid-my unofficial '"World's Oldest Streamer" 1909-2008 R.I.P.
richinny is offline   Reply With Quote
Old 08-08-2009, 07:24 PM   #19
4 Rivet Member
 
wannaroam's Avatar
 
1978 31' Excella 500
1961 26' Overlander
Harmony , Pennsylvania
Join Date: Sep 2006
Posts: 312
Images: 36
Can I ask: the outlet has to be wired correctly (correct polarity) since anything else plugged into it works.
Right??
__________________
wannaroam is offline   Reply With Quote
Old 08-08-2009, 08:26 PM   #20
Rivet Master
 
richinny's Avatar
 
2011 34' Classic
Westchester Cty.NY , / Miami FL
Join Date: Jul 2007
Posts: 3,122
NO, NOT CORRECT. many things can work with reversed polarity, others will not work. the circuit tester can be a lifesaver which is why everyone will tell you to get one and use it! when you have a problem, you have to verify everything step by step.
__________________
Ricky
2012 F150 Super Crew 5-1/2' bed Ecoboost 4x4 3.73 elec. lock diff. Propride hitch
give life. kidney & pancreas transplant 9/9/06
Ingrid-my unofficial '"World's Oldest Streamer" 1909-2008 R.I.P.
richinny is offline   Reply With Quote
Old 08-09-2009, 12:43 PM   #21
4 Rivet Member
 
wannaroam's Avatar
 
1978 31' Excella 500
1961 26' Overlander
Harmony , Pennsylvania
Join Date: Sep 2006
Posts: 312
Images: 36
We do have a circuit tester (and have used it). He hasn't put the converter back into the AS yet.
If he plugs the converter into the wall at the house, and checks it with the circuit tester on the positive and negative of the converter should it show some voltage? Because it doesn't if it should.

I apologize for not getting pix yet; am having some trouble with my digital camera too. (And with getting hubby to put unit back in the AS)
__________________
wannaroam is offline   Reply With Quote
Old 08-09-2009, 01:21 PM   #22
Rivet Master
 
richinny's Avatar
 
2011 34' Classic
Westchester Cty.NY , / Miami FL
Join Date: Jul 2007
Posts: 3,122
yes, you should have 12v dc output (or a little higher) observe the correct polarity on the hookup. those units might have internal fuses that should be checked.
__________________
Ricky
2012 F150 Super Crew 5-1/2' bed Ecoboost 4x4 3.73 elec. lock diff. Propride hitch
give life. kidney & pancreas transplant 9/9/06
Ingrid-my unofficial '"World's Oldest Streamer" 1909-2008 R.I.P.
richinny is offline   Reply With Quote
Old 08-09-2009, 02:26 PM   #23
4 Rivet Member
 
wannaroam's Avatar
 
1978 31' Excella 500
1961 26' Overlander
Harmony , Pennsylvania
Join Date: Sep 2006
Posts: 312
Images: 36
We did check internal fuses; that was one of the original problems - it kept blowing fuses inside the converter itself.

And again - it shows no voltage when plugged in inside the house.
__________________
wannaroam is offline   Reply With Quote
Old 08-09-2009, 02:39 PM   #24
Rivet Master
 
richinny's Avatar
 
2011 34' Classic
Westchester Cty.NY , / Miami FL
Join Date: Jul 2007
Posts: 3,122
no voltage is not good. did it trip the house gfci?
__________________
Ricky
2012 F150 Super Crew 5-1/2' bed Ecoboost 4x4 3.73 elec. lock diff. Propride hitch
give life. kidney & pancreas transplant 9/9/06
Ingrid-my unofficial '"World's Oldest Streamer" 1909-2008 R.I.P.
richinny is offline   Reply With Quote
Old 08-09-2009, 03:40 PM   #25
4 Rivet Member
 
wannaroam's Avatar
 
1978 31' Excella 500
1961 26' Overlander
Harmony , Pennsylvania
Join Date: Sep 2006
Posts: 312
Images: 36
Nope - it did nothing but sit there and look at us.

Which is just what it did when he checked it in the trailer too.
__________________
wannaroam is offline   Reply With Quote
Old 08-09-2009, 06:21 PM   #26
Rivet Master
 
richinny's Avatar
 
2011 34' Classic
Westchester Cty.NY , / Miami FL
Join Date: Jul 2007
Posts: 3,122
ship it out for repair.
__________________
Ricky
2012 F150 Super Crew 5-1/2' bed Ecoboost 4x4 3.73 elec. lock diff. Propride hitch
give life. kidney & pancreas transplant 9/9/06
Ingrid-my unofficial '"World's Oldest Streamer" 1909-2008 R.I.P.
richinny is offline   Reply With Quote
Old 08-09-2009, 06:32 PM   #27
4 Rivet Member
 
wannaroam's Avatar
 
1978 31' Excella 500
1961 26' Overlander
Harmony , Pennsylvania
Join Date: Sep 2006
Posts: 312
Images: 36
Ok; I guess we will do that. Thanks to everyone who helped answer questions for us.
__________________
wannaroam is offline   Reply With Quote
Old 07-06-2015, 03:03 PM   #28
1 Rivet Member
 
1990 33' Land Yacht
Chance , Maryland
Join Date: Apr 2013
Posts: 8
have a 1990 airstream landyacht with energenius eg3000 series the breaker with the white test button has blown, what do i do, and where do i get a new one?
__________________

__________________
bjkayla is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
power jack keeps blowing fuse? jlemmons Jacks, Stabilizers, Lifting and Leveling 6 08-01-2009 11:38 AM
Fuse blowing and sparking! Lily&Me Batteries, Univolts, Converters & Inverters 7 07-27-2009 02:18 PM
Fuse #1 keeps blowing Z33 Electrical - Systems, Generators, Batteries & Solar 12 12-16-2006 09:43 AM
Parking light fuse blowing andyfuson Tow Vehicles 7 07-26-2006 06:54 PM
Power converter "fuse" rfield54 1997 - 2004 Bambi 0 09-02-2003 03:26 PM


Virginia Campgrounds

Reviews provided by




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:18 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.

Airstream is a registered trademark of Airstream Inc. All rights reserved. Airstream trademark used under license to Social Knowledge LLC.